summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-04-20 23:06:58 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-04-20 23:06:58 +0000
commit5f51d7b6717e6b02fc71d118b9884df91217f960 (patch)
tree32ced059565a7b5878121056e087a878d80d3e3e /media-gfx/iscan-plugin-gt-f500
parentVersion bump. Remove old ebuild (diff)
downloadgentoo-2-5f51d7b6717e6b02fc71d118b9884df91217f960.tar.gz
gentoo-2-5f51d7b6717e6b02fc71d118b9884df91217f960.tar.bz2
gentoo-2-5f51d7b6717e6b02fc71d118b9884df91217f960.zip
Initial import of the iscan plugin/firmware for EPSON Perfection 2480/2580.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/iscan-plugin-gt-f500')
-rw-r--r--media-gfx/iscan-plugin-gt-f500/ChangeLog10
-rw-r--r--media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1.ebuild70
-rw-r--r--media-gfx/iscan-plugin-gt-f500/metadata.xml27
3 files changed, 107 insertions, 0 deletions
diff --git a/media-gfx/iscan-plugin-gt-f500/ChangeLog b/media-gfx/iscan-plugin-gt-f500/ChangeLog
new file mode 100644
index 000000000000..a14f62fe48af
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-f500/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-gfx/iscan-plugin-gt-f500
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan-plugin-gt-f500/ChangeLog,v 1.1 2011/04/20 23:06:58 flameeyes Exp $
+
+*iscan-plugin-gt-f500-1.0.0.1 (20 Apr 2011)
+
+ 20 Apr 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ +iscan-plugin-gt-f500-1.0.0.1.ebuild, +metadata.xml:
+ Initial import of the iscan plugin/firmware for EPSON Perfection 2480/2580.
+
diff --git a/media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1.ebuild b/media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1.ebuild
new file mode 100644
index 000000000000..8a3248431ac1
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1.ebuild,v 1.1 2011/04/20 23:06:58 flameeyes Exp $
+
+EAPI="4"
+
+inherit rpm versionator
+
+MY_P="${PN}-$(get_version_component_range 1-3)"
+
+DESCRIPTION="Epson Perfection V2480/2580 PHOTO scanner plugin for SANE 'epkowa' backend."
+HOMEPAGE="http://www.avasys.jp/english/linux_e/dl_scan.html"
+SRC_URI="http://lx1.avasys.jp/iscan/v1180/${PN}-$(replace_version_separator 3 -).i386.rpm"
+
+LICENSE="EPSON EAPL"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+IUSE="minimal"
+
+DEPEND="minimal? ( >=media-gfx/iscan-2.21.0 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ # install scanner firmware
+ insinto /usr/share/iscan
+ doins "${WORKDIR}/usr/share/iscan/"*
+
+ dodoc "usr/share/doc/${MY_P}/"*
+
+ if ! use minimal; then
+ # install scanner plugins
+ exeinto "/usr/$(get_libdir)/iscan"
+ doexe "${WORKDIR}/usr/$(get_libdir)/iscan/"*
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog "Firmware file esfw8b.bin for Epson Perfection 2480/2580 PHOTO"
+ elog "has been installed in /usr/share/iscan."
+ elog
+ use minimal && return
+
+ # Needed for scaner to work properly.
+ if [[ ${ROOT} == "/" ]]; then
+ iscan-registry --add interpreter usb 0x04b8 0x0121 "/usr/$(get_libdir)/iscan/libesint41.so.2 /usr/share/iscan/esfw41.bin"
+ else
+ ewarn "Unable to register the plugin and firmware when installing outside of /."
+ ewarn "execute the following command yourself:"
+ ewarn "iscan-registry --add interpreter usb 0x04b8 0x0121 '/usr/$(get_libdir)/iscan/libesint41.so.2 /usr/share/iscan/esfw41.bin'"
+ fi
+}
+
+pkg_prerm() {
+ use minimal && return
+
+ if [[ ${ROOT} == "/" ]]; then
+ iscan-registry --remove interpreter usb 0x04b8 0x0121 "/usr/$(get_libdir)/iscan/libesint41.so.2 /usr/share/iscan/esfw41.bin"
+ else
+ ewarn "Unable to register the plugin and firmware when installing outside of /."
+ ewarn "execute the following command yourself:"
+ ewarn "iscan-registry --remove interpreter usb 0x04b8 0x0121 '/usr/$(get_libdir)/iscan/libesint41.so.2 /usr/share/iscan/esfw41.bin'"
+ fi
+}
diff --git a/media-gfx/iscan-plugin-gt-f500/metadata.xml b/media-gfx/iscan-plugin-gt-f500/metadata.xml
new file mode 100644
index 000000000000..73e49419c3a0
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-f500/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Proprietary plugin for several EPSON scanner models, to be used
+ with the epkowa SANE backend (provided by
+ <pkg>media-gfx/iscan</pkg>). 32-bit only.
+
+ Also includes the firmware for them, to be used with the snapscan
+ SANE backend (provided by <pkg>media-gfx/sane-backends</pkg>).
+
+ Supports the following models:
+
+ EPSON Perfection 2480 PHOTO
+ EPSON Perfection 2580 PHOTO
+ </longdescription>
+
+ <use>
+ <flag name='minimal'>
+ Install the firmware only, and not the plugin.
+ </flag>
+ </use>
+</pkgmetadata>