summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2008-08-19 22:30:46 +0000
committerMarkus Meier <maekke@gentoo.org>2008-08-19 22:30:46 +0000
commit08d7b0788ef1564c194a1ffc2361f6f4e6c3d34a (patch)
tree166622ac71fa508be42a4101d5ab3e4203c6cb78 /media-gfx/imagemagick
parentFix typo in BUILD_CFLAGS #235209 by zimous. (diff)
downloadgentoo-2-08d7b0788ef1564c194a1ffc2361f6f4e6c3d34a.tar.gz
gentoo-2-08d7b0788ef1564c194a1ffc2361f6f4e6c3d34a.tar.bz2
gentoo-2-08d7b0788ef1564c194a1ffc2361f6f4e6c3d34a.zip
do not die if sys-devel/gcc has no openmp USE-flag, just disable it. bug #235156
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc2 i686)
Diffstat (limited to 'media-gfx/imagemagick')
-rw-r--r--media-gfx/imagemagick/ChangeLog6
-rw-r--r--media-gfx/imagemagick/imagemagick-6.4.2.9.ebuild10
2 files changed, 8 insertions, 8 deletions
diff --git a/media-gfx/imagemagick/ChangeLog b/media-gfx/imagemagick/ChangeLog
index f731c56c556d..aa2998d0d08a 100644
--- a/media-gfx/imagemagick/ChangeLog
+++ b/media-gfx/imagemagick/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/imagemagick
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/ChangeLog,v 1.297 2008/08/16 16:56:48 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/ChangeLog,v 1.298 2008/08/19 22:30:46 maekke Exp $
+
+ 19 Aug 2008; Markus Meier <maekke@gentoo.org> imagemagick-6.4.2.9.ebuild:
+ do not die if sys-devel/gcc has no openmp USE-flag, just disable it. bug
+ #235156
16 Aug 2008; Markus Meier <maekke@gentoo.org> imagemagick-6.4.2.9.ebuild:
not restricting -j1 for testing
diff --git a/media-gfx/imagemagick/imagemagick-6.4.2.9.ebuild b/media-gfx/imagemagick/imagemagick-6.4.2.9.ebuild
index cc57956671e3..4b06af6e39c1 100644
--- a/media-gfx/imagemagick/imagemagick-6.4.2.9.ebuild
+++ b/media-gfx/imagemagick/imagemagick-6.4.2.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/imagemagick-6.4.2.9.ebuild,v 1.3 2008/08/16 16:56:48 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/imagemagick-6.4.2.9.ebuild,v 1.4 2008/08/19 22:30:46 maekke Exp $
inherit eutils multilib perl-app toolchain-funcs
@@ -63,11 +63,6 @@ pkg_setup() {
elog "the svg USE-flag requires the X USE-flag set."
elog "disabling svg support for now."
fi
-
- if use openmp && ! built_with_use sys-devel/gcc openmp; then
- eerror "sys-devel/gcc needs to be built with openmp support."
- die "emerge sys-devel/gcc with USE=\"openmp\""
- fi
}
src_unpack() {
@@ -98,7 +93,7 @@ src_compile() {
#openmp support only works with >=sys-devel/gcc-4.3
# see bug #223825
- if use openmp ; then
+ if use openmp && built_with_use --missing false sys-devel/gcc openmp; then
if [[ $(gcc-version) != "4.3" ]] ; then
ewarn "you need sys-devel/gcc-4.3 to be able to use openmp, disabling."
myconf="${myconf} --disable-openmp"
@@ -106,6 +101,7 @@ src_compile() {
myconf="${myconf} --enable-openmp"
fi
else
+ elog "disabling openmp support"
myconf="${myconf} --disable-openmp"
fi