summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-12 23:46:46 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-12 23:46:46 +0000
commita171004f389e46c7472ee602204fca320f425703 (patch)
treeeb9a0b6b5e25fc6c49f3bde1854d4ded983692dd /media-gfx/graphviz
parentCompile against newest libpng (diff)
downloadgentoo-2-a171004f389e46c7472ee602204fca320f425703.tar.gz
gentoo-2-a171004f389e46c7472ee602204fca320f425703.tar.bz2
gentoo-2-a171004f389e46c7472ee602204fca320f425703.zip
Compile against newest libpng
Diffstat (limited to 'media-gfx/graphviz')
-rw-r--r--media-gfx/graphviz/ChangeLog8
-rw-r--r--media-gfx/graphviz/files/digest-graphviz-1.7.15-r21
-rw-r--r--media-gfx/graphviz/files/digest-graphviz-1.7.71
-rw-r--r--media-gfx/graphviz/graphviz-1.7.15-r2.ebuild50
-rw-r--r--media-gfx/graphviz/graphviz-1.7.7.ebuild18
5 files changed, 58 insertions, 20 deletions
diff --git a/media-gfx/graphviz/ChangeLog b/media-gfx/graphviz/ChangeLog
index 747b50f96f62..d04708d66609 100644
--- a/media-gfx/graphviz/ChangeLog
+++ b/media-gfx/graphviz/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/graphviz
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/ChangeLog,v 1.1 2002/02/01 21:53:29 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/ChangeLog,v 1.2 2002/04/12 23:44:32 seemant Exp $
+
+*graphviz-1.7.15-r2 (12 Apr 2002)
+
+ 12 Apr 2002; Seemant Kulleen <seemant@gentoo.org> graphviz-1.7.15-r2.ebuild :
+
+ Compile against newest libpng
*graphviz-1.7.15-r1 (1 Feb 2002)
diff --git a/media-gfx/graphviz/files/digest-graphviz-1.7.15-r2 b/media-gfx/graphviz/files/digest-graphviz-1.7.15-r2
new file mode 100644
index 000000000000..ee826cc2fc41
--- /dev/null
+++ b/media-gfx/graphviz/files/digest-graphviz-1.7.15-r2
@@ -0,0 +1 @@
+MD5 067848c829d159be81cbca8607ac7f30 graphviz-1.7.15.tgz 6032137
diff --git a/media-gfx/graphviz/files/digest-graphviz-1.7.7 b/media-gfx/graphviz/files/digest-graphviz-1.7.7
deleted file mode 100644
index c96955297220..000000000000
--- a/media-gfx/graphviz/files/digest-graphviz-1.7.7
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e04a6031b34d07ebceacc6ccb0745eb5 graphviz-1.7.7.tgz 2402089
diff --git a/media-gfx/graphviz/graphviz-1.7.15-r2.ebuild b/media-gfx/graphviz/graphviz-1.7.15-r2.ebuild
new file mode 100644
index 000000000000..8f73f87ea899
--- /dev/null
+++ b/media-gfx/graphviz/graphviz-1.7.15-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Aron Griffis <agriffis@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-1.7.7.ebuild,v 1.1 2001/10/19 17:03:38 agriffis Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="open source graph drawing software"
+SRC_URI="http://www.research.att.com/sw/tools/graphviz/dist/$P.tgz"
+HOMEPAGE="http://www.research.att.com/sw/tools/graphviz/"
+
+#Can use freetype-1.3 or 2.0, but not both
+DEPEND=">=sys-libs/zlib-1.1.3
+ media-libs/libpng
+ >=media-libs/jpeg-6b
+ media-libs/freetype
+ tcltk? ( =dev-lang/tk-8.3* )"
+
+src_compile() {
+
+ local myconf
+ #if no tcltk, this will generate configure warnings, but will
+ #compile without tcltk support
+ use tcltk || myconf="$myconf --without-tcl --without-tk"
+
+ #They seem to have forgot configure when packaging 1.7.15
+ ./autogen.sh --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ make || die
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS ChangeLog FAQ.txt INSTALL MINTERMS.txt \
+ NEWS README
+
+ insinto /usr/share/doc/${P}/html
+ doins LICENSE.html doc/*.html
+
+
+ insinto /usr/share/doc/${P}/pdf
+ doins doc/*.pdf
+
+}
diff --git a/media-gfx/graphviz/graphviz-1.7.7.ebuild b/media-gfx/graphviz/graphviz-1.7.7.ebuild
deleted file mode 100644
index 9e1ed5e56fbc..000000000000
--- a/media-gfx/graphviz/graphviz-1.7.7.ebuild
+++ /dev/null
@@ -1,18 +0,0 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author: Aron Griffis <agriffis@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-1.7.7.ebuild,v 1.1 2001/10/19 17:03:38 agriffis Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="open source graph drawing software"
-SRC_URI="http://www.research.att.com/sw/tools/graphviz/dist/$P.tgz"
-HOMEPAGE="http://www.research.att.com/sw/tools/graphviz/"
-
-src_compile() {
- ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST} || die
- make || die
-}
-
-src_install () {
- make DESTDIR=${D} install || die
-}