summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-01-27 00:01:27 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-01-27 00:01:27 +0000
commit75b65c8c306192eb39b051edd3f760bf28a5c89d (patch)
treefe6447b0d7bcdd0e9cf2dc5d93e3190f3c5f649b /media-gfx/feh
parentAdd missing patch from kde overlay (diff)
downloadgentoo-2-75b65c8c306192eb39b051edd3f760bf28a5c89d.tar.gz
gentoo-2-75b65c8c306192eb39b051edd3f760bf28a5c89d.tar.bz2
gentoo-2-75b65c8c306192eb39b051edd3f760bf28a5c89d.zip
Version bump. Add myself as maintainer
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/feh')
-rw-r--r--media-gfx/feh/ChangeLog8
-rw-r--r--media-gfx/feh/feh-1.11.1.ebuild60
-rw-r--r--media-gfx/feh/metadata.xml4
3 files changed, 71 insertions, 1 deletions
diff --git a/media-gfx/feh/ChangeLog b/media-gfx/feh/ChangeLog
index e9b7dd3090db..746e53d5948c 100644
--- a/media-gfx/feh/ChangeLog
+++ b/media-gfx/feh/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/feh
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/feh/ChangeLog,v 1.65 2011/01/22 23:19:26 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/feh/ChangeLog,v 1.66 2011/01/27 00:01:27 hwoarang Exp $
+
+*feh-1.11.1 (27 Jan 2011)
+
+ 27 Jan 2011; Markos Chandras <hwoarang@gentoo.org> +feh-1.11.1.ebuild,
+ metadata.xml:
+ Version bump. Add myself as maintainer
*feh-1.11 (22 Jan 2011)
diff --git a/media-gfx/feh/feh-1.11.1.ebuild b/media-gfx/feh/feh-1.11.1.ebuild
new file mode 100644
index 000000000000..f2a0a4ad6c3a
--- /dev/null
+++ b/media-gfx/feh/feh-1.11.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/feh/feh-1.11.1.ebuild,v 1.1 2011/01/27 00:01:27 hwoarang Exp $
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="A fast, lightweight imageviewer using imlib2"
+HOMEPAGE="https://derf.homelinux.org/~derf/projects/feh/"
+SRC_URI="http://www.chaosdorf.de/~derf/feh/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test xinerama"
+
+COMMON_DEPEND=">=media-libs/giblib-1.2.4
+ media-libs/imlib2
+ >=media-libs/libpng-1.4
+ x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/jpeg"
+DEPEND="${COMMON_DEPEND}
+ x11-libs/libXt
+ x11-proto/xproto
+ test? ( >=dev-lang/perl-5.10
+ dev-perl/Test-Command )"
+
+pkg_setup() {
+ fehopts=(
+ DESTDIR="${D}"
+ PREFIX=/usr
+ doc_dir='${main_dir}'/share/doc/${PF}
+ )
+}
+
+src_prepare() {
+ if ! use xinerama; then
+ sed -i -e '/^xinerama/d' config.mk || die
+ fi
+}
+
+src_compile() {
+ tc-export CC
+ emake "${fehopts[@]}" || die
+}
+
+src_install() {
+ emake "${fehopts[@]}" install || die
+ prepalldocs
+}
+
+pkg_postinst(){
+ elog
+ elog "Default configuration path was moved to:"
+ elog "/home/<user>/.config/feh/themes. Please "
+ elog "update your configuration"
+ elog
+}
diff --git a/media-gfx/feh/metadata.xml b/media-gfx/feh/metadata.xml
index e6e0d53dbdf9..72ace7364311 100644
--- a/media-gfx/feh/metadata.xml
+++ b/media-gfx/feh/metadata.xml
@@ -2,6 +2,10 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>graphics</herd>
+<maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+</maintainer>
<longdescription>
feh is an image viewer at heart, though it does other cool stuff.
</longdescription>