summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-08-27 21:24:07 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-08-27 21:24:07 +0000
commitf2c64dc33742cac03fd129cbfe33064227440460 (patch)
tree957177c405116bd9b391913a7631be0d8a187620 /media-gfx/f-spot
parentFix bug 282384, seems gconf is a rock-hard requirement if you use linux. Bump... (diff)
downloadgentoo-2-f2c64dc33742cac03fd129cbfe33064227440460.tar.gz
gentoo-2-f2c64dc33742cac03fd129cbfe33064227440460.tar.bz2
gentoo-2-f2c64dc33742cac03fd129cbfe33064227440460.zip
Get the fix for parallel-building into the ebuild. I only saw this on git.g.o, didn't check if it had been put into the tarball.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/f-spot')
-rw-r--r--media-gfx/f-spot/ChangeLog7
-rw-r--r--media-gfx/f-spot/f-spot-0.6.1.1.ebuild3
-rw-r--r--media-gfx/f-spot/files/f-spot-0.6.1.1-parallel-build.patch124
3 files changed, 132 insertions, 2 deletions
diff --git a/media-gfx/f-spot/ChangeLog b/media-gfx/f-spot/ChangeLog
index 9163e222ebba..28b08fcd8663 100644
--- a/media-gfx/f-spot/ChangeLog
+++ b/media-gfx/f-spot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/f-spot
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/f-spot/ChangeLog,v 1.40 2009/08/27 21:16:25 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/f-spot/ChangeLog,v 1.41 2009/08/27 21:24:07 loki_val Exp $
+
+ 27 Aug 2009; Peter Alfredsen <loki_val@gentoo.org> f-spot-0.6.1.1.ebuild,
+ +files/f-spot-0.6.1.1-parallel-build.patch:
+ Get the fix for parallel-building into the ebuild. I only saw this on
+ git.g.o, didn't check if it had been put into the tarball.
*f-spot-0.6.1.1 (27 Aug 2009)
diff --git a/media-gfx/f-spot/f-spot-0.6.1.1.ebuild b/media-gfx/f-spot/f-spot-0.6.1.1.ebuild
index c2e82e64b732..01b0b06227e1 100644
--- a/media-gfx/f-spot/f-spot-0.6.1.1.ebuild
+++ b/media-gfx/f-spot/f-spot-0.6.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/f-spot/f-spot-0.6.1.1.ebuild,v 1.1 2009/08/27 21:16:25 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/f-spot/f-spot-0.6.1.1.ebuild,v 1.2 2009/08/27 21:24:07 loki_val Exp $
EAPI=2
@@ -48,6 +48,7 @@ SCROLLKEEPER_UPDATE=0
src_prepare() {
epatch "${FILESDIR}/${PN}-0.6.0.0-sandbox-violation.patch"
+ epatch "${FILESDIR}/${PN}-0.6.1.1-parallel-build.patch"
sed -r -i -e 's:-D[A-Z]+_DISABLE_DEPRECATED::g' \
lib/libfspot/Makefile.am
eautoreconf
diff --git a/media-gfx/f-spot/files/f-spot-0.6.1.1-parallel-build.patch b/media-gfx/f-spot/files/f-spot-0.6.1.1-parallel-build.patch
new file mode 100644
index 000000000000..efd651f23073
--- /dev/null
+++ b/media-gfx/f-spot/files/f-spot-0.6.1.1-parallel-build.patch
@@ -0,0 +1,124 @@
+From 07f2cd2724560b4d7870e553f2900bb7265183e1 Mon Sep 17 00:00:00 2001
+From: Christian Krause <chkr@plauener.de>
+Date: Wed, 26 Aug 2009 22:51:47 +0000
+Subject: fix parallel build
+
+1. adding some missing dependencies.
+
+2. If the recursive make is called explicitely AND if the name for
+the variable is SUBDIRS then make consider the target containing
+the "make -C" call and the content of the SUBDIRS variable
+as independent targets and it will execute them in parallel.
+To prevent this behavior rename the special variable SUBDIRS to
+SUBDIR.
+---
+diff --git a/extensions/Exporters/FlickrExport/Makefile.am b/extensions/Exporters/FlickrExport/Makefile.am
+index 812904c..45e23fd 100644
+--- a/extensions/Exporters/FlickrExport/Makefile.am
++++ b/extensions/Exporters/FlickrExport/Makefile.am
+@@ -27,7 +27,7 @@ PKGS = \
+ -pkg:gtk-sharp-2.0 \
+ -pkg:glade-sharp-2.0
+
+-SUBDIRS = \
++SUBDIR = \
+ FlickrNet
+
+ RESOURCES = \
+@@ -40,7 +40,7 @@ mpack: $(PLUGIN_ASSEMBLY)
+ mautil p $(PLUGIN_ASSEMBLY)
+
+ $(PLUGIN_ASSEMBLY): $(PLUGIN_SOURCES) $(PLUGIN_MANIFEST)
+- $(MAKE) -C $(SUBDIRS)
++ $(MAKE) -C $(SUBDIR)
+ $(CSC_LIB) -out:$@ $(PLUGIN_SOURCES) $(REFS) $(PKGS) $(ASSEMBLIES) $(RESOURCES)
+
+ plugindir = $(pkglibdir)/extensions
+diff --git a/extensions/Exporters/PicasaWebExport/Makefile.am b/extensions/Exporters/PicasaWebExport/Makefile.am
+index 45e3bac..e123ada 100644
+--- a/extensions/Exporters/PicasaWebExport/Makefile.am
++++ b/extensions/Exporters/PicasaWebExport/Makefile.am
+@@ -28,7 +28,7 @@ PKGS = \
+ -pkg:gtk-sharp-2.0 \
+ -pkg:glade-sharp-2.0
+
+-SUBDIRS = \
++SUBDIR = \
+ google-sharp
+
+ RESOURCES = \
+@@ -41,7 +41,7 @@ mpack: $(PLUGIN_ASSEMBLY)
+ mautil p $(PLUGIN_ASSEMBLY)
+
+ $(PLUGIN_ASSEMBLY): $(PLUGIN_SOURCES) $(PLUGIN_MANIFEST)
+- $(MAKE) -C $(SUBDIRS)
++ $(MAKE) -C $(SUBDIR)
+ $(CSC_LIB) -out:$@ $(PLUGIN_SOURCES) $(REFS) $(PKGS) $(ASSEMBLIES) $(RESOURCES)
+
+ plugindir = $(pkglibdir)/extensions
+diff --git a/extensions/Exporters/SmugMugExport/Makefile.am b/extensions/Exporters/SmugMugExport/Makefile.am
+index 397461f..2f0dc2b 100644
+--- a/extensions/Exporters/SmugMugExport/Makefile.am
++++ b/extensions/Exporters/SmugMugExport/Makefile.am
+@@ -31,7 +31,7 @@ RESOURCES = \
+ -resource:$(srcdir)/$(PLUGIN_MANIFEST) \
+ -resource:$(srcdir)/$(PLUGIN_NAME).glade
+
+-SUBDIRS = \
++SUBDIR = \
+ SmugMugNet
+
+
+@@ -41,7 +41,7 @@ mpack: $(PLUGIN_ASSEMBLY)
+ mautil p $(PLUGIN_ASSEMBLY)
+
+ $(PLUGIN_ASSEMBLY): $(PLUGIN_SOURCES) $(PLUGIN_MANIFEST)
+- $(MAKE) -C $(SUBDIRS)
++ $(MAKE) -C $(SUBDIR)
+ $(CSC_LIB) -out:$@ $(PLUGIN_SOURCES) $(REFS) $(PKGS) $(ASSEMBLIES) $(RESOURCES)
+
+ plugindir = $(pkglibdir)/extensions
+diff --git a/extensions/Exporters/TabbloExport/Makefile.am b/extensions/Exporters/TabbloExport/Makefile.am
+index b7465d6..acf2d24 100644
+--- a/extensions/Exporters/TabbloExport/Makefile.am
++++ b/extensions/Exporters/TabbloExport/Makefile.am
+@@ -36,7 +36,7 @@ PKGS = \
+ -pkg:gtk-sharp-2.0 \
+ -pkg:glade-sharp-2.0
+
+-SUBDIRS = \
++SUBDIR = \
+ Tabblo
+
+ RESOURCES = \
+@@ -50,7 +50,7 @@ mpack: $(PLUGIN_ASSEMBLY)
+ mautil p $(PLUGIN_ASSEMBLY)
+
+ $(PLUGIN_ASSEMBLY): $(PLUGIN_SOURCES) $(PLUGIN_MANIFEST)
+- $(MAKE) -C $(SUBDIRS)
++ $(MAKE) -C $(SUBDIR)
+ $(CSC_LIB) -out:$@ $(PLUGIN_SOURCES) $(REFS) $(PKGS) $(ASSEMBLIES) $(RESOURCES)
+
+ plugindir = $(pkglibdir)/extensions
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 02add7d..ba9bcaf 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -509,13 +509,13 @@ FSpot.JobScheduler.dll: $(JOBSCHEDULER_CSFILES) FSpot.Utils.dll
+
+ FSpot.Bling.dll.mdb: FSpot.Bling.dll
+
+-FSpot.Bling.dll: $(BLING_CSFILES)
++FSpot.Bling.dll: $(BLING_CSFILES) FSpot.Utils.dll
+ @echo -e "\n*** Compiling $@"
+ $(CSC_LIB) -out:$@ $(EXTRAFLAGS) $(BLING_CSFILES) $(BLING_ASSEMBLIES)
+
+ FSpot.Widgets.dll.mdb: FSpot.Widgets.dll
+
+-FSpot.Widgets.dll: $(WIDGETS_CSFILES) FSpot.Utils.dll FSpot.Core.dll
++FSpot.Widgets.dll: $(WIDGETS_CSFILES) FSpot.Utils.dll FSpot.Core.dll Cms.dll
+ @echo -e "\n*** Compiling $@"
+ $(CSC_LIB) -out:$@ $(EXTRAFLAGS) $(WIDGETS_CSFILES) $(WIDGETS_ASSEMBLIES)
+
+--
+cgit v0.8.2