summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2013-03-03 17:48:48 +0000
committerMarkus Meier <maekke@gentoo.org>2013-03-03 17:48:48 +0000
commit3d48987a4020c897ae379d9994308028e15dcbe3 (patch)
tree45f08ae3330711e3bdecb95573d3d4c62b239419 /media-gfx/enblend
parentThis will now be proxy maintained https://bugs.gentoo.org/show_bug.cgi?id=430... (diff)
downloadgentoo-2-3d48987a4020c897ae379d9994308028e15dcbe3.tar.gz
gentoo-2-3d48987a4020c897ae379d9994308028e15dcbe3.tar.bz2
gentoo-2-3d48987a4020c897ae379d9994308028e15dcbe3.zip
version bump
(Portage version: 2.1.11.53/cvs/Linux x86_64, signed Manifest commit with key 072AD062)
Diffstat (limited to 'media-gfx/enblend')
-rw-r--r--media-gfx/enblend/ChangeLog9
-rw-r--r--media-gfx/enblend/enblend-4.1.1.ebuild81
2 files changed, 88 insertions, 2 deletions
diff --git a/media-gfx/enblend/ChangeLog b/media-gfx/enblend/ChangeLog
index ab93e141a87d..ca8f42f90cc6 100644
--- a/media-gfx/enblend/ChangeLog
+++ b/media-gfx/enblend/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/enblend
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/enblend/ChangeLog,v 1.50 2012/12/11 22:33:45 maekke Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/enblend/ChangeLog,v 1.51 2013/03/03 17:48:48 maekke Exp $
+
+*enblend-4.1.1 (03 Mar 2013)
+
+ 03 Mar 2013; Markus Meier <maekke@gentoo.org> +enblend-4.1.1.ebuild:
+ version bump
11 Dec 2012; Markus Meier <maekke@gentoo.org> enblend-4.1.ebuild:
add missing sci-libs/gsl dependency by Martin Jansa in bug #446816
diff --git a/media-gfx/enblend/enblend-4.1.1.ebuild b/media-gfx/enblend/enblend-4.1.1.ebuild
new file mode 100644
index 000000000000..84ca20873239
--- /dev/null
+++ b/media-gfx/enblend/enblend-4.1.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/enblend/enblend-4.1.1.ebuild,v 1.1 2013/03/03 17:48:48 maekke Exp $
+
+EAPI=2
+
+inherit eutils
+
+MY_P="${PN}-enfuse-${PV/_rc/rc}"
+
+DESCRIPTION="Image Blending with Multiresolution Splines"
+HOMEPAGE="http://enblend.sourceforge.net/"
+SRC_URI="mirror://sourceforge/enblend/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 VIGRA"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug doc gpu +image-cache +openexr openmp"
+
+RDEPEND="
+ media-libs/glew
+ =media-libs/lcms-2*
+ >=media-libs/libpng-1.2.43
+ media-libs/plotutils[X]
+ media-libs/tiff
+ >=media-libs/vigra-1.8.0
+ sci-libs/gsl
+ virtual/jpeg
+ gpu? ( media-libs/freeglut )
+ openexr? ( >=media-libs/openexr-1.0 )"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.31.0
+ virtual/pkgconfig
+ doc? (
+ media-gfx/transfig
+ sci-visualization/gnuplot[gd]
+ virtual/latex-base
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use image-cache && use openmp; then
+ ewarn "the openmp and image-cache USE-flags are mutually exclusive"
+ ewarn "image-cache will be disabled in favour of openmp"
+ fi
+}
+
+src_configure() {
+ local myconf="--with-boost-filesystem"
+ if use image-cache && use openmp; then
+ myconf="${myconf} --disable-image-cache --enable-openmp"
+ else
+ myconf="${myconf} $(use_enable image-cache) $(use_enable openmp)"
+ fi
+
+ use doc && myconf="${myconf} --with-gnuplot=$(type -p gnuplot)" \
+ || myconf="${myconf} --with-gnuplot=false"
+
+ econf \
+ --with-x \
+ $(use_enable debug) \
+ $(use_enable gpu gpu-support) \
+ $(use_with openexr) \
+ ${myconf}
+}
+
+src_compile() {
+ # forcing -j1 as every parallel compilation process needs about 1 GB RAM.
+ emake -j1 || die
+ if use doc; then
+ cd doc
+ make enblend.pdf enfuse.pdf || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README || die
+ use doc && dodoc doc/en{blend,fuse}.pdf
+}