summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-06-17 07:22:17 +0000
committerTim Harder <radhermit@gentoo.org>2013-06-17 07:22:17 +0000
commit5e6aa8fa662fd7a91d85e3d15bf14b7e1827ccf3 (patch)
tree384c3203dcd0781186ee625153b4bbe5532ecfda /media-gfx/duhdraw/duhdraw-2.8.13-r1.ebuild
parentVersion bump (diff)
downloadgentoo-2-5e6aa8fa662fd7a91d85e3d15bf14b7e1827ccf3.tar.gz
gentoo-2-5e6aa8fa662fd7a91d85e3d15bf14b7e1827ccf3.tar.bz2
gentoo-2-5e6aa8fa662fd7a91d85e3d15bf14b7e1827ccf3.zip
Revbump, update to EAPI 5 and respect LDFLAGS (bug #335177, patch by Michael Mair-Keimberger).
(Portage version: 2.2.0_alpha180/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-gfx/duhdraw/duhdraw-2.8.13-r1.ebuild')
-rw-r--r--media-gfx/duhdraw/duhdraw-2.8.13-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-gfx/duhdraw/duhdraw-2.8.13-r1.ebuild b/media-gfx/duhdraw/duhdraw-2.8.13-r1.ebuild
new file mode 100644
index 000000000000..7037af67324e
--- /dev/null
+++ b/media-gfx/duhdraw/duhdraw-2.8.13-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/duhdraw/duhdraw-2.8.13-r1.ebuild,v 1.1 2013/06/17 07:22:17 radhermit Exp $
+
+EAPI=5
+inherit toolchain-funcs eutils
+
+DESCRIPTION="ASCII art editor"
+HOMEPAGE="http://www.cs.helsinki.fi/u/penberg/duhdraw"
+SRC_URI="http://www.cs.helsinki.fi/u/penberg/duhdraw/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-macos.patch
+ epatch "${FILESDIR}"/${P}-prestrip.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dobin ansi ansitoc duhdraw
+ dodoc CREDITS HISTORY TODO
+}