summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-04-12 00:14:09 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-04-12 00:14:09 +0000
commit90e1fa8990cfdfb60850bbdb7713828012362d26 (patch)
tree6903ef5066f75030ddd67e2c7fb6245cbeee1f51 /mate-base/mate-menus
parentbump (diff)
downloadgentoo-2-90e1fa8990cfdfb60850bbdb7713828012362d26.tar.gz
gentoo-2-90e1fa8990cfdfb60850bbdb7713828012362d26.tar.bz2
gentoo-2-90e1fa8990cfdfb60850bbdb7713828012362d26.zip
Version bump to 1.8.0.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'mate-base/mate-menus')
-rw-r--r--mate-base/mate-menus/ChangeLog7
-rw-r--r--mate-base/mate-menus/mate-menus-1.8.0.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/mate-base/mate-menus/ChangeLog b/mate-base/mate-menus/ChangeLog
index c1db6828bbd8..450e1ec130a3 100644
--- a/mate-base/mate-menus/ChangeLog
+++ b/mate-base/mate-menus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mate-base/mate-menus
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mate-base/mate-menus/ChangeLog,v 1.5 2014/03/10 23:11:17 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/mate-base/mate-menus/ChangeLog,v 1.6 2014/04/12 00:14:09 tomwij Exp $
+
+*mate-menus-1.8.0 (12 Apr 2014)
+
+ 12 Apr 2014; Tom Wijsman <TomWij@gentoo.org> +mate-menus-1.8.0.ebuild:
+ Version bump to 1.8.0.
10 Mar 2014; Tom Wijsman <TomWij@gentoo.org> mate-menus-1.6.0.ebuild:
Update dependencies per the consensus formed with ssuominen.
diff --git a/mate-base/mate-menus/mate-menus-1.8.0.ebuild b/mate-base/mate-menus/mate-menus-1.8.0.ebuild
new file mode 100644
index 000000000000..f3986c5e8bec
--- /dev/null
+++ b/mate-base/mate-menus/mate-menus-1.8.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mate-base/mate-menus/mate-menus-1.8.0.ebuild,v 1.1 2014/04/12 00:14:09 tomwij Exp $
+
+EAPI="5"
+
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit gnome2 python-r1
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="MATE menu system, implementing the F.D.O cross-desktop spec"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="debug +introspection python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND=">=dev-libs/glib-2.15.2:2
+ virtual/libintl:0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:0 )
+ python? (
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40:*
+ >=mate-base/mate-common-1.6:0
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+my_command() {
+ if use python ; then
+ python_foreach_impl run_in_build_dir $@
+ else
+ $@
+ fi
+}
+
+src_configure() {
+ G2CONF="${G2CONF} \
+ $(use_enable python) \
+ $(use_enable introspection)"
+
+ # Do NOT compile with --disable-debug/--enable-debug=no as it disables API
+ # usage checks.
+ if ! use debug ; then
+ G2CONF="${G2CONF} --enable-debug=minimum"
+ fi
+
+ if use python ; then
+ python_copy_sources
+ fi
+
+ my_command gnome2_src_configure
+}
+
+src_compile() {
+ my_command gnome2_src_compile
+}
+
+src_test() {
+ my_command emake check
+}
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_install() {
+ my_command gnome2_src_install
+
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}/10-xdg-menu-mate"
+}