summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-02-01 11:42:02 +0000
committerFabian Groffen <grobian@gentoo.org>2011-02-01 11:42:02 +0000
commit019977668fc93ad8a5bd8a51bc69fa5bc0011af0 (patch)
tree04c117d870f6a817607a30e2c550228933756bac /mail-mta
parentVersion bump to 1.9.2 (diff)
downloadgentoo-2-019977668fc93ad8a5bd8a51bc69fa5bc0011af0.tar.gz
gentoo-2-019977668fc93ad8a5bd8a51bc69fa5bc0011af0.tar.bz2
gentoo-2-019977668fc93ad8a5bd8a51bc69fa5bc0011af0.zip
Grabbed some fixes from upstream to resolve misc building issues
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/exim/ChangeLog9
-rw-r--r--mail-mta/exim/exim-4.74-r1.ebuild (renamed from mail-mta/exim/exim-4.74.ebuild)6
-rw-r--r--mail-mta/exim/files/exim-4.74-makefile-command-envs.patch59
-rw-r--r--mail-mta/exim/files/exim-4.74-makefile-posix.patch86
-rw-r--r--mail-mta/exim/files/exim-4.74-pcre.patch29
5 files changed, 187 insertions, 2 deletions
diff --git a/mail-mta/exim/ChangeLog b/mail-mta/exim/ChangeLog
index 91e3368878f4..e5ea63d449f6 100644
--- a/mail-mta/exim/ChangeLog
+++ b/mail-mta/exim/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-mta/exim
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/exim/ChangeLog,v 1.174 2011/02/01 08:03:32 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/exim/ChangeLog,v 1.175 2011/02/01 11:42:02 grobian Exp $
+
+*exim-4.74-r1 (01 Feb 2011)
+
+ 01 Feb 2011; Fabian Groffen <grobian@gentoo.org> -exim-4.74.ebuild,
+ +exim-4.74-r1.ebuild, +files/exim-4.74-makefile-command-envs.patch,
+ +files/exim-4.74-makefile-posix.patch, +files/exim-4.74-pcre.patch:
+ Grabbed some fixes from upstream to resolve misc building issues
*exim-4.74 (01 Feb 2011)
diff --git a/mail-mta/exim/exim-4.74.ebuild b/mail-mta/exim/exim-4.74-r1.ebuild
index 711ca97f26ee..93b1036064a3 100644
--- a/mail-mta/exim/exim-4.74.ebuild
+++ b/mail-mta/exim/exim-4.74-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/exim/exim-4.74.ebuild,v 1.1 2011/02/01 08:03:32 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/exim/exim-4.74-r1.ebuild,v 1.1 2011/02/01 11:42:02 grobian Exp $
EAPI="3"
@@ -61,6 +61,10 @@ src_prepare() {
epatch "${FILESDIR}"/exim-4.14-tail.patch
epatch "${FILESDIR}"/exim-4.43-r2-localscan_dlopen.patch
epatch "${FILESDIR}"/exim-4.69-r1.27021.patch
+ # from upstream
+ epatch "${FILESDIR}"/${P}-pcre.patch
+ epatch "${FILESDIR}"/${P}-makefile-posix.patch
+ epatch "${FILESDIR}"/${P}-makefile-command-envs.patch
use maildir && epatch "${FILESDIR}"/exim-4.20-maildir.patch
use dsn && epatch "${DISTDIR}"/exim_${DSN_EXIM_V}_dsn_${DSN_V}.patch
diff --git a/mail-mta/exim/files/exim-4.74-makefile-command-envs.patch b/mail-mta/exim/files/exim-4.74-makefile-command-envs.patch
new file mode 100644
index 000000000000..30a1091f9f60
--- /dev/null
+++ b/mail-mta/exim/files/exim-4.74-makefile-command-envs.patch
@@ -0,0 +1,59 @@
+From: Phil Pennock <pdp@exim.org>
+Date: Fri, 28 Jan 2011 00:07:05 +0000 (-0500)
+Subject: Permit make values to be indented or in env.
+X-Git-Url: http://git.exim.org/exim.git/commitdiff_plain/0cc9542ab26b35cba3a5523acb8991eb18ce0656
+
+Permit make values to be indented or in env.
+
+It appears some make(1)s are not complaining about variables defined
+with leading whitespace on the line. Permit that where we can, for the
+lookups, but it's not tenable for CFLAGS_DYNAMIC.
+
+Some people are specifying knobs on the make command-line, so we get
+them via the environment.
+
+Tested: indented LOOKUP_CDB and commented out LOOKUP_DNSDB, supplying it
+via { make LOOKUP_DNSDB=yes }. { exim -d --version } shows both are
+built-in, no results from { fgrep DNSDB build-*/Makefile }.
+---
+
+diff --git a/src/scripts/lookups-Makefile b/src/scripts/lookups-Makefile
+index dd0472b..d5c450e 100755
+--- a/src/scripts/lookups-Makefile
++++ b/src/scripts/lookups-Makefile
+@@ -21,6 +21,9 @@ tab=' '
+ # We always do something now, since there should always be a lookup,
+ # and now we need to run in order to put the OBJ=$(OBJ)+ rules in.
+
++# nb: do not permit leading whitespace for this, as CFLAGS_DYNAMIC is exported
++# to the lookups subdir via a line with leading whitespace which otherwise
++# matches
+ if grep -q "^CFLAGS_DYNAMIC[ $tab]*=" "$defs_source"
+ then
+ # we have a definition, we're good to go
+@@ -32,14 +35,23 @@ fi
+
+ tmp="$target.t"
+
++# For the want_ checks, we need to let the user override values from the make
++# command-line, not just check the Makefile.
++
+ want_dynamic() {
+ local dyn_name="$1"
+- grep -q "^LOOKUP_${dyn_name}[ $tab]*=[ $tab]*2" "$defs_source"
++ local re="LOOKUP_${dyn_name}[ $tab]*=[ $tab]*2"
++ env | grep -q "^$re"
++ if [ $? -eq 0 ]; then return 0; fi
++ grep -q "^[ $tab]*$re" "$defs_source"
+ }
+
+ want_at_all() {
+ local want_name="$1"
+- grep -q "^LOOKUP_${want_name}[ $tab]*=[ $tab]*." "$defs_source"
++ local re="LOOKUP_${want_name}[ $tab]*=[ $tab]*."
++ env | grep -q "^$re"
++ if [ $? -eq 0 ]; then return 0; fi
++ grep -q "^[ $tab]*$re" "$defs_source"
+ }
+
+ # The values of these variables will be emitted into the Makefile.
diff --git a/mail-mta/exim/files/exim-4.74-makefile-posix.patch b/mail-mta/exim/files/exim-4.74-makefile-posix.patch
new file mode 100644
index 000000000000..54cf0388a2f7
--- /dev/null
+++ b/mail-mta/exim/files/exim-4.74-makefile-posix.patch
@@ -0,0 +1,86 @@
+From: Tony Finch <dot@dotat.at>
+Date: Thu, 27 Jan 2011 16:26:36 +0000 (+0000)
+Subject: Fix portability of Makefiles to HP-UX and other non-extended makes.
+X-Git-Url: http://git.exim.org/exim.git/commitdiff_plain/159f52d231c010cbc4e149502b7f906293233f94
+
+Fix portability of Makefiles to HP-UX and other non-extended makes.
+---
+
+diff --git a/src/scripts/lookups-Makefile b/src/scripts/lookups-Makefile
+index 2c4dc96..dd0472b 100755
+--- a/src/scripts/lookups-Makefile
++++ b/src/scripts/lookups-Makefile
+@@ -19,7 +19,7 @@ tag_marker='MAGIC-TAG-MODS-OBJ-RULES-GO-HERE'
+ tab=' '
+
+ # We always do something now, since there should always be a lookup,
+-# and now we need to run in order to put the OBJ+= rules in.
++# and now we need to run in order to put the OBJ=$(OBJ)+ rules in.
+
+ if grep -q "^CFLAGS_DYNAMIC[ $tab]*=" "$defs_source"
+ then
+@@ -42,6 +42,11 @@ want_at_all() {
+ grep -q "^LOOKUP_${want_name}[ $tab]*=[ $tab]*." "$defs_source"
+ }
+
++# The values of these variables will be emitted into the Makefile.
++
++MODS=""
++OBJ=""
++
+ emit_module_rule() {
+ local lookup_name="$1"
+ local mod_name
+@@ -59,13 +64,13 @@ emit_module_rule() {
+ echo >&2 "Inhibited dynamic modules prevents building dynamic $lookup_name"
+ exit 1
+ fi
+- echo "MODS += ${mod_name}.so"
++ MODS="${MODS} ${mod_name}.so"
+ grep "^LOOKUP_${lookup_name}_" "$defs_source"
+ echo "LOOKUP_${mod_name}_INCLUDE = \$(LOOKUP_${lookup_name}_INCLUDE)"
+ echo "LOOKUP_${mod_name}_LIBS = \$(LOOKUP_${lookup_name}_LIBS)"
+ elif want_at_all "$lookup_name"
+ then
+- echo "OBJ += ${mod_name}.o"
++ OBJ="${OBJ} ${mod_name}.o"
+ fi
+ }
+
+@@ -83,9 +88,18 @@ done
+
+ if want_at_all LDAP
+ then
+- echo "OBJ += ldap.o"
++ OBJ="${OBJ} ldap.o"
+ fi
+
++# Because the variable is EXPERIMENTAL_SPF and not LOOKUP_SPF we
++# always include spf.o and compile a dummy if EXPERIMENTAL_SPF is not
++# defined.
++
++OBJ="${OBJ} spf.o"
++
++echo "MODS = $MODS"
++echo "OBJ = $OBJ"
++
+ sed -n "/$tag_marker/,\$p" < "$input"
+
+ exec >&5
+diff --git a/src/src/lookups/Makefile b/src/src/lookups/Makefile
+index 623f24f..2495348 100644
+--- a/src/src/lookups/Makefile
++++ b/src/src/lookups/Makefile
+@@ -8,12 +8,6 @@
+ # This is called from the main make file, after cd'ing
+ # to the lookups subdirectory.
+
+-# because the variable is EXPERIMENTAL_SPF and not LOOKUP_SPF
+-# we put this one here by default and compile a dummy if
+-# EXPERIMENTAL_SPF is not defined
+-OBJ=spf.o
+-MODS=
+-
+ # MAGIC-TAG-MODS-OBJ-RULES-GO-HERE
+
+
diff --git a/mail-mta/exim/files/exim-4.74-pcre.patch b/mail-mta/exim/files/exim-4.74-pcre.patch
new file mode 100644
index 000000000000..361b03e75290
--- /dev/null
+++ b/mail-mta/exim/files/exim-4.74-pcre.patch
@@ -0,0 +1,29 @@
+From: Nigel Metheringham <nigel@exim.org>
+Date: Wed, 26 Jan 2011 11:04:32 +0000 (+0000)
+Subject: Workround compile error with old PCRE versions
+X-Git-Url: http://git.exim.org/exim.git/commitdiff_plain/aa097c4c00f62487128d74f65c521f9e877b184f
+
+Workround compile error with old PCRE versions
+
+Fixes bug #1073
+---
+
+diff --git a/src/src/exim.c b/src/src/exim.c
+index e236975..b3035ca 100644
+--- a/src/src/exim.c
++++ b/src/src/exim.c
+@@ -931,8 +931,13 @@ DEBUG(D_any) do {
+ " Runtime: %s\n",
+ PCRE_MAJOR, PCRE_MINOR,
+ /* PRE_PRERELEASE is either defined and empty or a string.
+- * This should work: */
++ * unless its an ancient version of PCRE in which case it
++ * is not defined */
++#ifdef PCRE_PRERELEASE
+ PCRE_PRERELEASE "",
++#else
++ "",
++#endif
+ pcre_version());
+
+ init_lookup_list();