summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Smee <strerror@gentoo.org>2007-07-30 00:58:02 +0000
committerBenjamin Smee <strerror@gentoo.org>2007-07-30 00:58:02 +0000
commitf11d009e2925fce07839cfb980ad1fc93a4b15ce (patch)
tree3bde0753cb06852ea9bf66959d11131f057c46a8 /mail-filter
parentstable on ppc64 (diff)
downloadgentoo-2-f11d009e2925fce07839cfb980ad1fc93a4b15ce.tar.gz
gentoo-2-f11d009e2925fce07839cfb980ad1fc93a4b15ce.tar.bz2
gentoo-2-f11d009e2925fce07839cfb980ad1fc93a4b15ce.zip
Version bump for bug #181324
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/policyd/ChangeLog7
-rw-r--r--mail-filter/policyd/files/digest-policyd-1.813
-rw-r--r--mail-filter/policyd/policyd-1.81.ebuild72
3 files changed, 81 insertions, 1 deletions
diff --git a/mail-filter/policyd/ChangeLog b/mail-filter/policyd/ChangeLog
index 9f226d3aeec9..0227c3c15623 100644
--- a/mail-filter/policyd/ChangeLog
+++ b/mail-filter/policyd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/policyd
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/policyd/ChangeLog,v 1.1 2007/01/12 00:23:21 strerror Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/policyd/ChangeLog,v 1.2 2007/07/30 00:58:02 strerror Exp $
+
+*policyd-1.81 (30 Jul 2007)
+
+ 30 Jul 2007; Benjamin Smee <strerror@gentoo.org> +policyd-1.81.ebuild:
+ Version bump for bug #181324
12 Jan 2007; Benjamin Smee <strerror@gentoo.org> ChangeLog:
Initial import. Thanks to those who contributed to bug #112261
diff --git a/mail-filter/policyd/files/digest-policyd-1.81 b/mail-filter/policyd/files/digest-policyd-1.81
new file mode 100644
index 000000000000..8c9c684c72ec
--- /dev/null
+++ b/mail-filter/policyd/files/digest-policyd-1.81
@@ -0,0 +1,3 @@
+MD5 1632180ff820f94d04f4dd1f6cddb46a policyd-1.81.tar.gz 68309
+RMD160 e25798338d7ff082e32ec5288e721ed7c75235c3 policyd-1.81.tar.gz 68309
+SHA256 5880d77ebd07bd6083b2a915b0e57ea0b9f8912140815de9bbde7d0bb48825f0 policyd-1.81.tar.gz 68309
diff --git a/mail-filter/policyd/policyd-1.81.ebuild b/mail-filter/policyd/policyd-1.81.ebuild
new file mode 100644
index 000000000000..3b2153d39229
--- /dev/null
+++ b/mail-filter/policyd/policyd-1.81.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/policyd/policyd-1.81.ebuild,v 1.1 2007/07/30 00:58:02 strerror Exp $
+
+inherit eutils
+
+DESCRIPTION="Policy daemon for postfix and other MTAs"
+HOMEPAGE="http://policyd.sf.net/"
+
+# This is not available through SF mirrors
+SRC_URI="http://policyd.sourceforge.net/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND="dev-db/mysql
+ dev-libs/openssl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-makefile.patch"
+
+ ebegin "Applying config patches"
+ sed -i -e s:UID=0:UID=65534:g \
+ -e s:GID=0:GID=65534:g \
+ -e s:DAEMON=0:DAEMON=1:g \
+ -e s:DEBUG=3:DEBUG=0:g \
+ -e s:DATABASE_KEEPALIVE=0:DATABASE_KEEPALIVE=1:g \
+ policyd.conf || "sed failed"
+ eend
+}
+
+src_compile() {
+ emake build || "emake build failed"
+}
+
+src_install() {
+ insopts -o root -g nobody -m 0750
+ mv cleanup policyd_cleanup
+ mv stats policyd_stats
+
+ dosbin policyd policyd_cleanup policyd_stats
+
+ insopts -o root -g nobody -m 0640
+ insinto /etc
+ doins policyd.conf
+
+ insopts -o root -g nobody -m 0700
+ exeinto /etc/cron.hourly
+ newexe "${FILESDIR}/${PN}-cleanup.cron" ${PN}-cleanup.cron
+
+ dodoc ChangeLog DATABASE.mysql LICENSE README doc/support.txt
+
+ newinitd "${FILESDIR}/${PN}.rc" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}
+
+pkg_postinst() {
+ einfo "You will need to create the database using the script provided in"
+ einfo "/usr/share/doc/${PF}/DATABASE.mysql.gz"
+ einfo "Read the mysql section of the README.txt for details."
+ einfo
+ einfo "To use policyd with postfix, update your /etc/postfix/main.cf file by adding"
+ einfo " check_policy_service inet:127.0.0.1:10031"
+ einfo "to your smtpd_recipient_restrictions line, or similar."
+ einfo
+ einfo "Also remember to start the daemon at boot:"
+ einfo " rc-update add policyd default"
+ einfo
+ einfo "Read the documentation for more info."
+}