summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-03-31 02:15:48 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-03-31 02:15:48 +0000
commit35ccd51d48ca0dd70fcb276abf5e22480843963a (patch)
treef513ed45216823fd18dfb3182df27d9443e81acf /mail-filter
parentfix manifests (diff)
downloadgentoo-2-35ccd51d48ca0dd70fcb276abf5e22480843963a.tar.gz
gentoo-2-35ccd51d48ca0dd70fcb276abf5e22480843963a.tar.bz2
gentoo-2-35ccd51d48ca0dd70fcb276abf5e22480843963a.zip
Bug #312065: Fix the cosmetic version number that upstream forgot to bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/razor/ChangeLog8
-rw-r--r--mail-filter/razor/files/razor-2.85-cosmetic-pv-fix.patch22
-rw-r--r--mail-filter/razor/razor-2.85-r1.ebuild72
3 files changed, 101 insertions, 1 deletions
diff --git a/mail-filter/razor/ChangeLog b/mail-filter/razor/ChangeLog
index 8db6be8388e1..16bd5b7e45e9 100644
--- a/mail-filter/razor/ChangeLog
+++ b/mail-filter/razor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-filter/razor
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/razor/ChangeLog,v 1.88 2010/03/25 00:39:36 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/razor/ChangeLog,v 1.89 2010/03/31 02:15:47 robbat2 Exp $
+
+*razor-2.85-r1 (31 Mar 2010)
+
+ 31 Mar 2010; Robin H. Johnson <robbat2@gentoo.org> +razor-2.85-r1.ebuild,
+ +files/razor-2.85-cosmetic-pv-fix.patch:
+ Bug #312065: Fix the cosmetic version number that upstream forgot to bump.
*razor-2.85 (25 Mar 2010)
diff --git a/mail-filter/razor/files/razor-2.85-cosmetic-pv-fix.patch b/mail-filter/razor/files/razor-2.85-cosmetic-pv-fix.patch
new file mode 100644
index 000000000000..c391d48fbc4f
--- /dev/null
+++ b/mail-filter/razor/files/razor-2.85-cosmetic-pv-fix.patch
@@ -0,0 +1,22 @@
+--- a/lib/Razor2/Client/Version.pm 2007-05-10 22:32:10.000000000 +0200
++++ b/lib/Razor2/Client/Version.pm 2010-03-25 11:11:36.911409707 +0100
+@@ -14,7 +14,7 @@
+
+ $PROTOCOL = 3;
+
+-$VERSION = '2.84';
++$VERSION = '2.85';
+
+ 1;
+
+--- a/META.yml 2007-05-23 20:29:34.000000000 +0200
++++ b/META.yml 2010-03-25 11:11:43.691408628 +0100
+@@ -1,7 +1,7 @@
+ # http://module-build.sourceforge.net/META-spec.html
+ #XXXXXXX This is a prototype!!! It will change in the future!!! XXXXX#
+ name: razor-agents
+-version: 2.84
++version: 2.85
+ version_from: lib/Razor2/Client/Version.pm
+ installdirs: site
+ requires:
diff --git a/mail-filter/razor/razor-2.85-r1.ebuild b/mail-filter/razor/razor-2.85-r1.ebuild
new file mode 100644
index 000000000000..c558df0ed1cb
--- /dev/null
+++ b/mail-filter/razor/razor-2.85-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/razor/razor-2.85-r1.ebuild,v 1.1 2010/03/31 02:15:47 robbat2 Exp $
+
+inherit perl-app
+
+MY_PN="razor-agents"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Vipul's Razor is a distributed, collaborative spam detection and filtering network"
+HOMEPAGE="http://razor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/razor/${MY_P}.tar.bz2"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+
+RDEPEND="dev-perl/Net-DNS
+ virtual/perl-net-ping
+ virtual/perl-Time-HiRes
+ || ( virtual/perl-Digest-SHA dev-perl/Digest-SHA1 )
+ dev-perl/URI
+ dev-perl/Digest-Nilsimsa"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.85-use-sha-not-sha1.patch"
+ "${FILESDIR}/${PN}-2.85-cosmetic-pv-fix.patch"
+ )
+
+S=${WORKDIR}/${MY_P}
+
+pkg_postinst() {
+ elog
+ elog "Run 'razor-admin -create' to create a default config file in your"
+ elog "home directory under /home/user/.razor. (Remember to change user to"
+ elog "your username from root before running razor-admin)"
+ elog
+ elog "Razor v2 requires reporters to be registered so their reputations can"
+ elog "be computed over time and they can participate in the revocation"
+ elog "mechanism. Registration is done with razor-admin -register. It has to be"
+ elog "manually invoked in either of the following ways:"
+ elog
+ elog "To register user foo with 's1kr3t' as password: "
+ elog
+ elog "razor-admin -register -user=foo -pass=s1kr3t"
+ elog
+ elog "To register with an email address and have the password assigned:"
+ elog
+ elog "razor-admin -register -user=foo@bar.com "
+ elog
+ elog "To have both (random) username and password assgined: "
+ elog
+ elog "razor-admin -register "
+ elog
+ elog "razor-admin -register negotiates a registration with the Nomination Server"
+ elog "and writes the identity information in"
+ elog "/home/user/.razor/identity-username, or /etc/razor/identity-username"
+ elog "when invoked as root."
+ elog
+ elog "You can edit razor-agent.conf to change the defaults. Config options"
+ elog "and their values are defined in the razor-agent.conf(5) manpage."
+ elog
+ elog "The next step is to integrate razor-check, razor-report and"
+ elog "razor-revoke in your mail system. If you are running Razor v1, the"
+ elog "change will be transparent, new versions of razor agents will overwrite"
+ elog "the old ones. You would still need to plugin razor-revoke in your MUA,"
+ elog "since it's a new addition in Razor v2. If you are not running Razor v1,"
+ elog "refer to manpages of razor-check(1), razor-report(1), and"
+ elog "razor-revoke(1) for integration instructions."
+ elog
+}