summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-06-07 12:02:20 +0000
committerPacho Ramos <pacho@gentoo.org>2015-06-07 12:02:20 +0000
commit46b022efa18cb707ec9ac401468f50d8d82921a6 (patch)
tree94fd7e67d0c0b464223afc4e1f6c00ac6452e882 /mail-client
parentVersion Bump (diff)
downloadgentoo-2-46b022efa18cb707ec9ac401468f50d8d82921a6.tar.gz
gentoo-2-46b022efa18cb707ec9ac401468f50d8d82921a6.tar.bz2
gentoo-2-46b022efa18cb707ec9ac401468f50d8d82921a6.zip
Version bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/balsa/ChangeLog9
-rw-r--r--mail-client/balsa/balsa-2.5.2.ebuild102
-rw-r--r--mail-client/balsa/metadata.xml1
3 files changed, 110 insertions, 2 deletions
diff --git a/mail-client/balsa/ChangeLog b/mail-client/balsa/ChangeLog
index c5f6e8d7826b..a717e9fc56a1 100644
--- a/mail-client/balsa/ChangeLog
+++ b/mail-client/balsa/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/balsa
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/ChangeLog,v 1.133 2014/11/13 12:58:36 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/ChangeLog,v 1.134 2015/06/07 12:02:20 pacho Exp $
+
+*balsa-2.5.2 (07 Jun 2015)
+
+ 07 Jun 2015; Pacho Ramos <pacho@gentoo.org> +balsa-2.5.2.ebuild, metadata.xml:
+ Version bump
13 Nov 2014; Pacho Ramos <pacho@gentoo.org> -balsa-2.4.13.ebuild:
Drop old (#508854)
diff --git a/mail-client/balsa/balsa-2.5.2.ebuild b/mail-client/balsa/balsa-2.5.2.ebuild
new file mode 100644
index 000000000000..3f9f3ea50c5d
--- /dev/null
+++ b/mail-client/balsa/balsa-2.5.2.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/balsa-2.5.2.ebuild,v 1.1 2015/06/07 12:02:20 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
+
+DESCRIPTION="Email client for GNOME"
+HOMEPAGE="http://pawsa.fedorapeople.org/balsa/"
+SRC_URI="http://pawsa.fedorapeople.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+IUSE="crypt gnome gtkhtml gnome-keyring +gtkspell kerberos ldap libnotify rubrica sqlite ssl webkit xface"
+REQUIRED_USE="gtkhtml? ( !webkit )"
+
+# TODO: esmtp can be optional, do we want it?
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.4.0:3
+ dev-libs/gmime:2.6
+ >=net-libs/libesmtp-1.0.3:=
+ net-mail/mailbase
+ media-libs/libcanberra:=[gtk3]
+ x11-themes/hicolor-icon-theme
+ x11-themes/gnome-icon-theme
+ crypt? ( >=app-crypt/gpgme-1.0:= )
+ gnome? ( >=x11-libs/gtksourceview-3.2.0:3.0 )
+ gnome-keyring? ( app-crypt/libsecret )
+ gtkhtml? ( gnome-extra/gtkhtml:4.0 )
+ sqlite? ( >=dev-db/sqlite-2.8:= )
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ gtkspell? ( >=app-text/gtkspell-3.0.3:3 )
+ !gtkspell? ( app-text/enchant )
+ kerberos? ( app-crypt/mit-krb5 )
+ ldap? ( net-nds/openldap )
+ rubrica? ( dev-libs/libxml2:2 )
+ ssl? ( dev-libs/openssl:= )
+ webkit? ( net-libs/webkit-gtk:3 )
+ xface? ( >=media-libs/compface-1.5.1:= )
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+src_prepare() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README TODO docs/*"
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=750516
+ sed -i -e 's/@TOOLKIT_CATEGORIES@//' balsa-mailto-handler.desktop.in.in || die
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=750515
+ echo "src/balsa-print-object.c" >> po/POTFILES.in || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf
+
+ if use crypt ; then
+ myconf+=" --with-gpgme=gpgme-config"
+ else
+ myconf+=" --without-gpgme"
+ fi
+
+ if use webkit || use gtkhtml; then
+ if use gtkhtml ; then
+ myconf+=" --with-html-widget=gtkhtml4"
+ else
+ myconf+=" --with-html-widget=webkit2"
+ fi
+ else
+ myconf+=" --with-html-widget=no"
+ fi
+
+ gnome2_src_configure \
+ --disable-pcre \
+ --enable-gregex \
+ --enable-threads \
+ --with-gmime=2.6 \
+ --with-canberra \
+ $(use_with gnome) \
+ $(use_with gnome gtksourceview) \
+ $(use_with gnome-keyring libsecret) \
+ $(use_with gtkspell) \
+ $(use_with kerberos gss) \
+ $(use_with ldap) \
+ $(use_with libnotify) \
+ $(use_with rubrica) \
+ $(use_with sqlite) \
+ $(use_with ssl) \
+ $(use_with xface compface) \
+ ${myconf}
+}
diff --git a/mail-client/balsa/metadata.xml b/mail-client/balsa/metadata.xml
index 65f17b1489b3..43c78fdfad4a 100644
--- a/mail-client/balsa/metadata.xml
+++ b/mail-client/balsa/metadata.xml
@@ -4,6 +4,7 @@
<herd>gnome</herd>
<use>
<flag name='crypt'>Adds support for GnuPG encryption</flag>
+ <flag name='gtkhtml'>Use gtkhtml for HTML rendering</flag>
<flag name='gtkspell'>Use gtkspell for dictionary support</flag>
<flag name='rubrica'>Adds support for <pkg>app-office/rubrica</pkg>
addressbook</flag>