summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2006-07-29 10:32:25 +0000
committerBryan Østergaard <kloeri@gentoo.org>2006-07-29 10:32:25 +0000
commit124140a14957fdb990974b47f47e2cb7d89ba53b (patch)
tree956a3e3ae6559da2944825546795ff7fd1a3f775 /mail-client
parentVersion bump, bug 141842. (diff)
downloadgentoo-2-124140a14957fdb990974b47f47e2cb7d89ba53b.tar.gz
gentoo-2-124140a14957fdb990974b47f47e2cb7d89ba53b.tar.bz2
gentoo-2-124140a14957fdb990974b47f47e2cb7d89ba53b.zip
Version bump, bug 141842.
(Portage version: 2.1.1_pre3-r5)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mozilla-thunderbird-bin/ChangeLog8
-rw-r--r--mail-client/mozilla-thunderbird-bin/files/digest-mozilla-thunderbird-bin-1.5.0.53
-rw-r--r--mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-1.5.0.5.ebuild86
3 files changed, 96 insertions, 1 deletions
diff --git a/mail-client/mozilla-thunderbird-bin/ChangeLog b/mail-client/mozilla-thunderbird-bin/ChangeLog
index dbe91c7b2e32..e4691bc23ab1 100644
--- a/mail-client/mozilla-thunderbird-bin/ChangeLog
+++ b/mail-client/mozilla-thunderbird-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/mozilla-thunderbird-bin
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/ChangeLog,v 1.42 2006/06/12 02:12:42 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/ChangeLog,v 1.43 2006/07/29 10:32:25 kloeri Exp $
+
+*mozilla-thunderbird-bin-1.5.0.5 (29 Jul 2006)
+
+ 29 Jul 2006; Bryan Østergaard <kloeri@gentoo.org>
+ +mozilla-thunderbird-bin-1.5.0.5.ebuild:
+ Version bump, bug 141842.
12 Jun 2006; Jory A. Pratt <anarchy@gentoo.org>
-mozilla-thunderbird-bin-1.0.8.ebuild,
diff --git a/mail-client/mozilla-thunderbird-bin/files/digest-mozilla-thunderbird-bin-1.5.0.5 b/mail-client/mozilla-thunderbird-bin/files/digest-mozilla-thunderbird-bin-1.5.0.5
new file mode 100644
index 000000000000..fdf21329fba7
--- /dev/null
+++ b/mail-client/mozilla-thunderbird-bin/files/digest-mozilla-thunderbird-bin-1.5.0.5
@@ -0,0 +1,3 @@
+MD5 cf534af1278aa39a232e8046efa07c85 thunderbird-1.5.0.5.tar.gz 10610567
+RMD160 9884c236cb40a30a507cb18ff3a6a4c502dedc19 thunderbird-1.5.0.5.tar.gz 10610567
+SHA256 f8789404949240e18845e73b459c1be5b4bf4d1e575075b7699e9790bd175725 thunderbird-1.5.0.5.tar.gz 10610567
diff --git a/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-1.5.0.5.ebuild b/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-1.5.0.5.ebuild
new file mode 100644
index 000000000000..eee3899e7f28
--- /dev/null
+++ b/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-1.5.0.5.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-1.5.0.5.ebuild,v 1.1 2006/07/29 10:32:25 kloeri Exp $
+
+inherit eutils mozilla-launcher multilib
+
+DESCRIPTION="The Mozilla Thunderbird Mail & News Reader"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/${PV}/linux-i686/en-US/thunderbird-${PV}.tar.gz"
+HOMEPAGE="http://www.mozilla.org/projects/thunderbird"
+RESTRICT="nostrip"
+
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+IUSE=""
+
+DEPEND="virtual/libc"
+RDEPEND="|| ( ( x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ )
+ virtual/x11
+ )
+ x86? (
+ >=sys-libs/lib-compat-1.0-r2
+ >=x11-libs/gtk+-2.2
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-2.1.1
+ >=app-emulation/emul-linux-x86-gtklibs-2.1
+ )
+ >=www-client/mozilla-launcher-1.41"
+
+S=${WORKDIR}/thunderbird
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/opt/thunderbird
+
+ # Install thunderbird in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv ${S} ${D}${MOZILLA_FIVE_HOME}
+
+ # Install /usr/bin/thunderbird-bin
+ install_mozilla_launcher_stub thunderbird-bin ${MOZILLA_FIVE_HOME}
+
+ # Install icon and .desktop for menu entry
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/icon/mozillathunderbird-bin-icon.png
+ insinto /usr/share/applications
+ doins ${FILESDIR}/icon/mozillathunderbird-bin.desktop
+
+ # revdep-rebuild entry
+ insinto /etc/revdep-rebuild
+ doins ${FILESDIR}/10thunderbird-bin
+}
+
+pkg_preinst() {
+ declare MOZILLA_FIVE_HOME=/opt/thunderbird
+
+ # Remove entire installed instance to solve various
+ # problems, for example see bug 27719
+ rm -rf ${ROOT}${MOZILLA_FIVE_HOME}
+}
+
+pkg_postinst() {
+ einfo "For enigmail, please see instructions at"
+ einfo " http://enigmail.mozdev.org/"
+
+ if use amd64; then
+ echo
+ einfo "NB: You just installed a 32-bit thunderbird"
+ fi
+
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}