summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2014-06-13 13:37:26 +0000
committerAkinori Hattori <hattya@gentoo.org>2014-06-13 13:37:26 +0000
commit0e91e3b0451fabb188b3dcedde09f619002ac8cd (patch)
treeefee1ee8008c7d0431f463f77c1f65bccc3cb3f4 /mail-client/sylpheed
parentRemove libtasn-1 mask, since long time we could have done this, bug#492522 (diff)
downloadgentoo-2-0e91e3b0451fabb188b3dcedde09f619002ac8cd.tar.gz
gentoo-2-0e91e3b0451fabb188b3dcedde09f619002ac8cd.tar.bz2
gentoo-2-0e91e3b0451fabb188b3dcedde09f619002ac8cd.zip
new upstream release
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key EC917A6D)
Diffstat (limited to 'mail-client/sylpheed')
-rw-r--r--mail-client/sylpheed/ChangeLog7
-rw-r--r--mail-client/sylpheed/sylpheed-3.4.2.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/mail-client/sylpheed/ChangeLog b/mail-client/sylpheed/ChangeLog
index d5860a3b32f8..49de37fa5720 100644
--- a/mail-client/sylpheed/ChangeLog
+++ b/mail-client/sylpheed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/sylpheed
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.335 2014/04/04 11:03:44 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.336 2014/06/13 13:37:26 hattya Exp $
+
+*sylpheed-3.4.2 (13 Jun 2014)
+
+ 13 Jun 2014; Akinori Hattori <hattya@gentoo.org> +sylpheed-3.4.2.ebuild:
+ new upstream release
*sylpheed-3.4.1 (04 Apr 2014)
diff --git a/mail-client/sylpheed/sylpheed-3.4.2.ebuild b/mail-client/sylpheed/sylpheed-3.4.2.ebuild
new file mode 100644
index 000000000000..3b50788f02d2
--- /dev/null
+++ b/mail-client/sylpheed/sylpheed-3.4.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-3.4.2.ebuild,v 1.1 2014/06/13 13:37:26 hattya Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="A lightweight email client and newsreader"
+HOMEPAGE="http://sylpheed.sraoss.jp/"
+SRC_URI="http://${PN}.sraoss.jp/${PN}/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt ipv6 ldap nls oniguruma pda spell ssl xface"
+
+CDEPEND="x11-libs/gtk+:2
+ crypt? ( app-crypt/gpgme )
+ ldap? ( net-nds/openldap )
+ nls? ( sys-devel/gettext )
+ oniguruma? ( dev-libs/oniguruma )
+ pda? ( app-pda/jpilot )
+ spell? ( app-text/gtkspell:2 )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${CDEPEND}
+ app-misc/mime-types
+ net-misc/curl"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ xface? ( media-libs/compface )"
+
+src_configure() {
+ local htmldir=/usr/share/doc/${PF}/html
+ econf \
+ $(use_enable crypt gpgme) \
+ $(use_enable ipv6) \
+ $(use_enable ldap) \
+ $(use_enable oniguruma) \
+ $(use_enable pda jpilot) \
+ $(use_enable spell gtkspell) \
+ $(use_enable ssl) \
+ $(use_enable xface compface) \
+ --with-manualdir=${htmldir}/manual \
+ --with-faqdir=${htmldir}/faq \
+ --disable-updatecheck
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog* NEWS* PLUGIN* README* TODO*
+
+ doicon *.png
+ domenu *.desktop
+
+ cd plugin/attachment_tool
+ docinto plugin/attachment_tool
+ emake DESTDIR="${D}" install-plugin
+ dodoc README
+}