summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-08-12 10:50:22 +0000
committerJeroen Roovers <jer@gentoo.org>2014-08-12 10:50:22 +0000
commit9f3ea67ad02a40b4239c0fd8c88ded355f405dbc (patch)
treeff11ec37654331fe64482fbc49ff2ca0fff0ccae /mail-client/roundcube
parentMarked ~hppa (bug #507512). (diff)
downloadgentoo-2-9f3ea67ad02a40b4239c0fd8c88ded355f405dbc.tar.gz
gentoo-2-9f3ea67ad02a40b4239c0fd8c88ded355f405dbc.tar.bz2
gentoo-2-9f3ea67ad02a40b4239c0fd8c88ded355f405dbc.zip
Version bump (bug #507512).
(Portage version: 2.2.11-r1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'mail-client/roundcube')
-rw-r--r--mail-client/roundcube/ChangeLog9
-rw-r--r--mail-client/roundcube/roundcube-1.0.2.ebuild72
2 files changed, 79 insertions, 2 deletions
diff --git a/mail-client/roundcube/ChangeLog b/mail-client/roundcube/ChangeLog
index cce114f921c9..a15159e9fd6e 100644
--- a/mail-client/roundcube/ChangeLog
+++ b/mail-client/roundcube/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/roundcube
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.132 2013/11/12 09:35:25 radhermit Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.133 2014/08/12 10:50:22 jer Exp $
+
+*roundcube-1.0.2 (12 Aug 2014)
+
+ 12 Aug 2014; Jeroen Roovers <jer@gentoo.org> +roundcube-1.0.2.ebuild:
+ Version bump (bug #507512).
12 Nov 2013; Tim Harder <radhermit@gentoo.org> -roundcube-0.8.6.ebuild,
-roundcube-0.9.2.ebuild, -roundcube-0.9.3.ebuild, -roundcube-0.9.4.ebuild:
diff --git a/mail-client/roundcube/roundcube-1.0.2.ebuild b/mail-client/roundcube/roundcube-1.0.2.ebuild
new file mode 100644
index 000000000000..2d735907bc9f
--- /dev/null
+++ b/mail-client/roundcube/roundcube-1.0.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/roundcube-1.0.2.ebuild,v 1.1 2014/08/12 10:50:22 jer Exp $
+
+EAPI=5
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_P=${MY_PN}-${PV/_/-}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="http://roundcube.net"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="ldap +mysql postgres sqlite ssl spell"
+
+# this function only sets DEPEND so we need to include that in RDEPEND
+need_httpd_cgi
+
+RDEPEND="
+ ${DEPEND}
+ >=dev-lang/php-5.3[crypt,filter,gd,iconv,json,ldap?,pdo,postgres?,session,sockets,ssl?,unicode,xml]
+ >=dev-php/PEAR-Auth_SASL-1.0.3
+ >=dev-php/PEAR-Crypt_GPG-1.3.2
+ >=dev-php/PEAR-Mail_Mime-1.8.1
+ >=dev-php/PEAR-Net_IDNA2-0.1.1
+ >=dev-php/PEAR-Net_SMTP-1.4.2
+ >=dev-php/PEAR-Net_Sieve-1.3.2
+ >=dev-php/PEAR-Net_Socket-1.0.14
+ mysql? ( || ( dev-lang/php[mysql] dev-lang/php[mysqli] ) )
+ spell? ( dev-lang/php[curl,spell] )
+ sqlite? ( || ( dev-lang/php[sqlite] dev-lang/php[sqlite3] ) )
+ virtual/httpd-php
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # Remove bundled PEAR packages
+ rm -r program/lib/{Auth,Crypt,Mail,Net,PEAR*} || die
+}
+
+src_install() {
+ webapp_src_preinst
+ dodoc CHANGELOG INSTALL README.md UPGRADING
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
+ webapp_postupgrade_txt en UPGRADING
+ webapp_src_install
+}
+
+pkg_postinst() {
+ ewarn "When upgrading from <= 0.9, note that the old configuration files"
+ ewarn "named main.inc.php and db.inc.php are deprecated and should be"
+ ewarn "replaced with one single config.inc.php file."
+ ewarn "Run the ./bin/update.sh script to convert those"
+ ewarn "or manually merge the files."
+ ewarn "The new config.inc.php should only contain options that"
+ ewarn "differ from the ones listed in defaults.inc.php."
+}