summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-05-24 22:55:07 +0000
committerBen de Groot <yngwin@gentoo.org>2009-05-24 22:55:07 +0000
commitfd926edbd0687663a93f3106a94c29300edcf68d (patch)
tree7eda3801341e26b987ec5ce6711c2afad5cd37ac /lxde-base
parentVersion bump (diff)
downloadgentoo-2-fd926edbd0687663a93f3106a94c29300edcf68d.tar.gz
gentoo-2-fd926edbd0687663a93f3106a94c29300edcf68d.tar.bz2
gentoo-2-fd926edbd0687663a93f3106a94c29300edcf68d.zip
Version bump. Dropped ~ppc keyword because of unkeyworded deps.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxpanel/ChangeLog7
-rw-r--r--lxde-base/lxpanel/lxpanel-0.4.1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/lxde-base/lxpanel/ChangeLog b/lxde-base/lxpanel/ChangeLog
index 5f0e340edb21..0807f34c41aa 100644
--- a/lxde-base/lxpanel/ChangeLog
+++ b/lxde-base/lxpanel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for lxde-base/lxpanel
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/ChangeLog,v 1.3 2009/01/02 00:36:52 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/ChangeLog,v 1.4 2009/05/24 22:55:07 yngwin Exp $
+
+*lxpanel-0.4.1 (24 May 2009)
+
+ 24 May 2009; Ben de Groot <yngwin@gentoo.org> +lxpanel-0.4.1.ebuild:
+ Version bump. Dropped ~ppc keyword because of unkeyworded deps.
02 Jan 2009; Ben de Groot <yngwin@gentoo.org>
+files/lxpanel-sandbox.patch, lxpanel-0.3.8.1.ebuild:
diff --git a/lxde-base/lxpanel/lxpanel-0.4.1.ebuild b/lxde-base/lxpanel/lxpanel-0.4.1.ebuild
new file mode 100644
index 000000000000..52c9d172614c
--- /dev/null
+++ b/lxde-base/lxpanel/lxpanel-0.4.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/lxpanel-0.4.1.ebuild,v 1.1 2009/05/24 22:55:07 yngwin Exp $
+
+EAPI="2"
+inherit eutils
+
+DESCRIPTION="Lightweight X11 desktop panel for LXDE"
+HOMEPAGE="http://lxde.sf.net/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="+X +alsa wifi"
+RESTRICT="test" # bug 249598
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libXmu
+ x11-libs/libXpm
+ lxde-base/lxmenu-data
+ lxde-base/menu-cache
+ alsa? ( media-libs/alsa-lib )
+ wifi? ( net-wireless/wireless-tools )
+ X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_configure() {
+ econf $(use_enable alsa) \
+ $(use_enable wifi libiw) \
+ $(use_with X x) \
+ --with-plugins=all
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+}