summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2007-08-04 17:34:36 +0000
committerSteve Dibb <beandog@gentoo.org>2007-08-04 17:34:36 +0000
commit828b2c39f539de82494885413304fe9bdbb60a38 (patch)
treee8df8edacdf42e84aa07e0afb68883c9554eabb4 /kde-misc
parentfix ChangeLog header (diff)
downloadgentoo-2-828b2c39f539de82494885413304fe9bdbb60a38.tar.gz
gentoo-2-828b2c39f539de82494885413304fe9bdbb60a38.tar.bz2
gentoo-2-828b2c39f539de82494885413304fe9bdbb60a38.zip
Version bump, bug 187521
(Portage version: 2.1.2.11)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/tellico/ChangeLog7
-rw-r--r--kde-misc/tellico/files/digest-tellico-1.2.133
-rw-r--r--kde-misc/tellico/tellico-1.2.13.ebuild53
3 files changed, 62 insertions, 1 deletions
diff --git a/kde-misc/tellico/ChangeLog b/kde-misc/tellico/ChangeLog
index d0c1f624feac..a04258d61040 100644
--- a/kde-misc/tellico/ChangeLog
+++ b/kde-misc/tellico/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/tellico
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/ChangeLog,v 1.69 2007/07/26 21:58:37 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/ChangeLog,v 1.70 2007/08/04 17:34:36 beandog Exp $
+
+*tellico-1.2.13 (04 Aug 2007)
+
+ 04 Aug 2007; Steve Dibb <beandog@gentoo.org> +tellico-1.2.13.ebuild:
+ Version bump, bug 187521
26 Jul 2007; Gustavo Zacarias <gustavoz@gentoo.org> tellico-1.2.11.ebuild:
Stable on sparc
diff --git a/kde-misc/tellico/files/digest-tellico-1.2.13 b/kde-misc/tellico/files/digest-tellico-1.2.13
new file mode 100644
index 000000000000..ac02bf3a31af
--- /dev/null
+++ b/kde-misc/tellico/files/digest-tellico-1.2.13
@@ -0,0 +1,3 @@
+MD5 7c0371d1e2b8e97d62fafb3fd5d79e7e tellico-1.2.13.tar.gz 4795795
+RMD160 8f6e5a784392f9f39038637fa7cec42ac525f9c8 tellico-1.2.13.tar.gz 4795795
+SHA256 3392ef2abd502f9e8b4da4b92eea0b9ff2bf8c1e4c97380e9e3e0cffbeba8cb0 tellico-1.2.13.tar.gz 4795795
diff --git a/kde-misc/tellico/tellico-1.2.13.ebuild b/kde-misc/tellico/tellico-1.2.13.ebuild
new file mode 100644
index 000000000000..d2d31d581616
--- /dev/null
+++ b/kde-misc/tellico/tellico-1.2.13.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/tellico-1.2.13.ebuild,v 1.1 2007/08/04 17:34:36 beandog Exp $
+
+inherit kde sgml-catalog
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A collection manager for the KDE environment."
+HOMEPAGE="http://www.periapsis.org/tellico"
+SRC_URI="http://www.periapsis.org/tellico/download/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="calendar cddb yaz"
+
+RDEPEND=">=dev-libs/libxml2-2.6
+ >=dev-libs/libxslt-1.0.19
+ cddb? ( || ( kde-base/libkcddb kde-base/kdemultimedia ) )
+ calendar? ( || ( ( kde-base/ktnef kde-base/libkcal ) kde-base/kdepim ) )
+ media-libs/taglib
+ yaz? ( dev-libs/yaz )"
+
+need-kde 3.5
+
+src_compile() {
+ local myconf="$(use_enable cddb libkcddb) $(use_enable calendar libkcal)"
+ kde_src_compile
+}
+
+pkg_postinst() {
+ einfo "Installing catalog..."
+ ${ROOT}/usr/bin/xmlcatalog --noout --add "delegatePublic" \
+ "-//Robby Stephenson/DTD Tellico V9.0//EN" \
+ "file://${ROOT}usr/share/apps/tellico/tellico.dtd" \
+ ${ROOT}/etc/xml/catalog
+ ${ROOT}/usr/bin/xmlcatalog --noout --add "delegateSystem" \
+ "http://www.periapsis.org/tellico/dtd/v9/tellico.dtd" \
+ "file://${ROOT}usr/share/apps/tellico/tellico.dtd" \
+ ${ROOT}/etc/xml/catalog
+ ${ROOT}/usr/bin/xmlcatalog --noout --add "delegateURI" \
+ "http://www.periapsis.org/tellico/dtd/v9/tellico.dtd" \
+ "file://${ROOT}usr/share/apps/tellico/tellico.dtd" \
+ ${ROOT}/etc/xml/catalog
+}
+
+pkg_postrm() {
+ ${ROOT}/usr/bin/xmlcatalog --noout --del \
+ "file://${ROOT}usr/share/apps/tellico/tellico.dtd" \
+ ${ROOT}/etc/xml/catalog
+}