summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-10-16 11:57:08 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-10-16 11:57:08 +0000
commit89ac9cd256e49a00ee0758f6e907a6ab1cff5cd2 (patch)
treead78af17bda248a3003e01b7350e8c89e71e0896 /kde-misc/wicd-client-kde
parentStable for amd64, wrt bug #438374 (diff)
downloadgentoo-2-89ac9cd256e49a00ee0758f6e907a6ab1cff5cd2.tar.gz
gentoo-2-89ac9cd256e49a00ee0758f6e907a6ab1cff5cd2.tar.bz2
gentoo-2-89ac9cd256e49a00ee0758f6e907a6ab1cff5cd2.zip
Force python-2, wrt bug #409375.
(Portage version: 2.1.11.27/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'kde-misc/wicd-client-kde')
-rw-r--r--kde-misc/wicd-client-kde/ChangeLog8
-rw-r--r--kde-misc/wicd-client-kde/wicd-client-kde-0.3.0-r1.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/kde-misc/wicd-client-kde/ChangeLog b/kde-misc/wicd-client-kde/ChangeLog
index 3453d525d741..b1adb696c362 100644
--- a/kde-misc/wicd-client-kde/ChangeLog
+++ b/kde-misc/wicd-client-kde/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-misc/wicd-client-kde
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/wicd-client-kde/ChangeLog,v 1.15 2012/07/20 21:35:52 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/wicd-client-kde/ChangeLog,v 1.16 2012/10/16 11:57:08 kensington Exp $
+
+*wicd-client-kde-0.3.0-r1 (16 Oct 2012)
+
+ 16 Oct 2012; Michael Palimaka <kensington@gentoo.org>
+ +wicd-client-kde-0.3.0-r1.ebuild:
+ Force python-2, wrt bug #409375.
20 Jul 2012; Johannes Huber <johu@gentoo.org> wicd-client-kde-0.3.0.ebuild:
Move from SLOT 0 to 4.
diff --git a/kde-misc/wicd-client-kde/wicd-client-kde-0.3.0-r1.ebuild b/kde-misc/wicd-client-kde/wicd-client-kde-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..ee462e60618a
--- /dev/null
+++ b/kde-misc/wicd-client-kde/wicd-client-kde-0.3.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/wicd-client-kde/wicd-client-kde-0.3.0-r1.ebuild,v 1.1 2012/10/16 11:57:08 kensington Exp $
+
+EAPI=4
+
+# Incompatible linguas handling
+#KDE_LINGUAS="cs da de el en_GB es et fr hu it lt nb nds nl pa pl pt pt_BR ru sv
+#uk zh_CN zh_TW"
+EGIT_REPONAME="wicd-kde"
+MY_P=${P/-client/}
+KDE_SCM="git"
+PYTHON_DEPEND="2"
+inherit python kde4-base
+
+DESCRIPTION="Wicd client built on the KDE Development Platform"
+HOMEPAGE="http://kde-apps.org/content/show.php/Wicd+Client+KDE?content=132366"
+[[ ${PV} == *9999 ]] || \
+ SRC_URI="http://kde-apps.org/CONTENT/content-files/132366-${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-misc/wicd"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN/-client/}
+
+pkg_setup() {
+ python_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPYTHONBIN=/usr/bin/python2
+ )
+
+ kde4-base_src_configure
+}