summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-03-21 19:12:04 +0000
committerJohannes Huber <johu@gentoo.org>2014-03-21 19:12:04 +0000
commit3f2aea5f241328b8878c46248236e1aad39f5a8a (patch)
tree1ee7aa11bed2bb09692fa865826930af37cdd3b4 /kde-misc/stock-quote
parentRevision bump to EAPI 5. (diff)
downloadgentoo-2-3f2aea5f241328b8878c46248236e1aad39f5a8a.tar.gz
gentoo-2-3f2aea5f241328b8878c46248236e1aad39f5a8a.tar.bz2
gentoo-2-3f2aea5f241328b8878c46248236e1aad39f5a8a.zip
Revision bump to EAPI 5.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-misc/stock-quote')
-rw-r--r--kde-misc/stock-quote/ChangeLog10
-rw-r--r--kde-misc/stock-quote/stock-quote-2.1-r1.ebuild4
-rw-r--r--kde-misc/stock-quote/stock-quote-2.1-r2.ebuild33
3 files changed, 43 insertions, 4 deletions
diff --git a/kde-misc/stock-quote/ChangeLog b/kde-misc/stock-quote/ChangeLog
index 82180258de7a..70dc267e78df 100644
--- a/kde-misc/stock-quote/ChangeLog
+++ b/kde-misc/stock-quote/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-misc/stock-quote
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/stock-quote/ChangeLog,v 1.9 2012/11/14 21:18:46 johu Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/stock-quote/ChangeLog,v 1.10 2014/03/21 19:12:04 johu Exp $
+
+*stock-quote-2.1-r2 (21 Mar 2014)
+
+ 21 Mar 2014; Johannes Huber <johu@gentoo.org> +stock-quote-2.1-r2.ebuild,
+ stock-quote-2.1-r1.ebuild:
+ Revision bump to EAPI 5.
14 Nov 2012; Johannes Huber <johu@gentoo.org> -stock-quote-2.1.ebuild:
Remove old.
diff --git a/kde-misc/stock-quote/stock-quote-2.1-r1.ebuild b/kde-misc/stock-quote/stock-quote-2.1-r1.ebuild
index c973a69b46c8..104d02f7f2c4 100644
--- a/kde-misc/stock-quote/stock-quote-2.1-r1.ebuild
+++ b/kde-misc/stock-quote/stock-quote-2.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/stock-quote/stock-quote-2.1-r1.ebuild,v 1.4 2012/11/14 21:18:16 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/stock-quote/stock-quote-2.1-r1.ebuild,v 1.5 2014/03/21 19:12:04 johu Exp $
EAPI=4
inherit kde4-base
diff --git a/kde-misc/stock-quote/stock-quote-2.1-r2.ebuild b/kde-misc/stock-quote/stock-quote-2.1-r2.ebuild
new file mode 100644
index 000000000000..53f9610e8e59
--- /dev/null
+++ b/kde-misc/stock-quote/stock-quote-2.1-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/stock-quote/stock-quote-2.1-r2.ebuild,v 1.1 2014/03/21 19:12:04 johu Exp $
+
+EAPI=5
+
+inherit kde4-base
+
+MY_P=plasma_${PN/-/_}-${PV}
+
+DESCRIPTION="Displays stock quotes pulled from the Yahoo! servers"
+HOMEPAGE="http://www.kde-look.org/content/show.php/Stock+Quote?content=90695"
+SRC_URI="http://www.kde-look.org/CONTENT/content-files/90695-${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ $(add_kdebase_dep plasma-workspace)
+"
+S=${WORKDIR}/${MY_P}
+
+DOCS=( CHANGELOG README )
+
+src_prepare() {
+ sed -e 's:^[ \t]*::' \
+ -i applet/plasma-applet-stock-quote.desktop || die "fixing .desktop file failed"
+ sed -e 's:^[ \t]*::' \
+ -i dataengine/plasma-dataengine-stockquote.desktop || die "fixing .desktop file failed"
+ kde4-base_src_prepare
+}