summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2012-08-25 19:59:50 +0000
committerChris Reffett <creffett@gentoo.org>2012-08-25 19:59:50 +0000
commit358470ed6b4eea6b43c87ee2bc58f318ec5d7c10 (patch)
tree43fb94dc8c620a2b4eafb84cfccec050fadfd261 /kde-misc/stock-quote
parentVersion bump to 2.5.3 (diff)
downloadgentoo-2-358470ed6b4eea6b43c87ee2bc58f318ec5d7c10.tar.gz
gentoo-2-358470ed6b4eea6b43c87ee2bc58f318ec5d7c10.tar.bz2
gentoo-2-358470ed6b4eea6b43c87ee2bc58f318ec5d7c10.zip
Revision bump, bump to EAPI 4 and fix .desktop validation errors
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'kde-misc/stock-quote')
-rw-r--r--kde-misc/stock-quote/ChangeLog10
-rw-r--r--kde-misc/stock-quote/stock-quote-2.1-r1.ebuild32
2 files changed, 39 insertions, 3 deletions
diff --git a/kde-misc/stock-quote/ChangeLog b/kde-misc/stock-quote/ChangeLog
index bff2fd940a8e..ba7502dff248 100644
--- a/kde-misc/stock-quote/ChangeLog
+++ b/kde-misc/stock-quote/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/stock-quote
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/stock-quote/ChangeLog,v 1.4 2011/01/31 06:45:43 tampakrap Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/stock-quote/ChangeLog,v 1.5 2012/08/25 19:59:50 creffett Exp $
+
+*stock-quote-2.1-r1 (25 Aug 2012)
+
+ 25 Aug 2012; Chris Reffett <creffett@gentoo.org> +stock-quote-2.1-r1.ebuild:
+ Revision bump, bump to EAPI 4 and fix .desktop validation errors
31 Jan 2011; Theo Chatzimichos <tampakrap@gentoo.org> stock-quote-2.1.ebuild:
EAPI3
@@ -16,4 +21,3 @@
13 Feb 2010; Samuli Suominen <ssuominen@gentoo.org>
+stock-quote-2.1.ebuild:
Initial commit.
-
diff --git a/kde-misc/stock-quote/stock-quote-2.1-r1.ebuild b/kde-misc/stock-quote/stock-quote-2.1-r1.ebuild
new file mode 100644
index 000000000000..05d3d997847b
--- /dev/null
+++ b/kde-misc/stock-quote/stock-quote-2.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/stock-quote/stock-quote-2.1-r1.ebuild,v 1.1 2012/08/25 19:59:50 creffett Exp $
+
+EAPI=3
+inherit kde4-base
+
+MY_P=plasma_${PN/-/_}-${PV}
+
+DESCRIPTION="Displays stock quotes pulled from the Yahoo! servers"
+HOMEPAGE="http://www.kde-look.org/content/show.php/Stock+Quote?content=90695"
+SRC_URI="http://www.kde-look.org/CONTENT/content-files/90695-${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ $(add_kdebase_dep plasma-workspace)
+"
+S=${WORKDIR}/${MY_P}
+
+DOCS=( CHANGELOG README )
+
+src_prepare() {
+ sed -e 's:^[ \t]*::' \
+ -i applet/plasma-applet-stock-quote.desktop || die "fixing .desktop file failed"
+ sed -e 's:^[ \t]*::' \
+ -i dataengine/plasma-dataengine-stockquote.desktop || die "fixing .desktop file failed"
+ kde4-base_src_prepare
+}