summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-01-31 13:21:02 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-01-31 13:21:02 +0000
commitb310e94badc2e7810948f7582ac3039924eb4c36 (patch)
tree49da90cf957ec2057f6a885e67b97d6ce951ad08 /kde-base
parentVersion bump (diff)
downloadgentoo-2-b310e94badc2e7810948f7582ac3039924eb4c36.tar.gz
gentoo-2-b310e94badc2e7810948f7582ac3039924eb4c36.tar.bz2
gentoo-2-b310e94badc2e7810948f7582ac3039924eb4c36.zip
Build all mail-related agents here; bug 499538
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kmail/ChangeLog8
-rw-r--r--kde-base/kmail/kmail-4.12.1-r2.ebuild110
2 files changed, 117 insertions, 1 deletions
diff --git a/kde-base/kmail/ChangeLog b/kde-base/kmail/ChangeLog
index 4744262408ba..6e7efc8b7102 100644
--- a/kde-base/kmail/ChangeLog
+++ b/kde-base/kmail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kmail
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.387 2014/01/27 23:26:25 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.388 2014/01/31 13:21:02 dilfridge Exp $
+
+*kmail-4.12.1-r2 (31 Jan 2014)
+
+ 31 Jan 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kmail-4.12.1-r2.ebuild:
+ Build all mail-related agents here; bug 499538
*kmail-4.12.1-r1 (27 Jan 2014)
diff --git a/kde-base/kmail/kmail-4.12.1-r2.ebuild b/kde-base/kmail/kmail-4.12.1-r2.ebuild
new file mode 100644
index 000000000000..b4cc05d7c601
--- /dev/null
+++ b/kde-base/kmail/kmail-4.12.1-r2.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-4.12.1-r2.ebuild,v 1.1 2014/01/31 13:21:02 dilfridge Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+VIRTUALX_REQUIRED=test
+inherit flag-o-matic kde4-meta
+
+DESCRIPTION="KMail is the email component of Kontact, the integrated personal information manager of KDE."
+HOMEPAGE="http://www.kde.org/applications/internet/kmail/"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs)
+ $(add_kdebase_dep korganizer)
+ $(add_kdebase_dep kdepim-common-libs "" 4.12.1-r2)
+"
+RDEPEND="
+ ${DEPEND}
+ !=kde-base/kdepim-common-libs-4.12.1-r1
+"
+
+RESTRICT="test"
+# bug 393147
+
+KMEXTRACTONLY="
+ agents/sendlateragent/
+ akonadi_next/
+ calendarsupport/
+ korganizer/
+ kresources/
+ libkleo/
+ libkpgp/
+ libkdepimdbusinterfaces/
+ kdgantt2/
+"
+KMCOMPILEONLY="
+ grantleetheme/
+ kaddressbookgrantlee/
+ messagecomposer/
+ messagecore/
+ messagelist/
+ messageviewer/
+ pimcommon/
+ templateparser/
+ incidenceeditor-ng/
+ calendarsupport/
+"
+KMEXTRA="
+ agents/archivemailagent/
+ agents/folderarchiveagent/
+ agents/mailfilteragent/
+ grantleethemeeditor/
+ headerthemeeditor/
+ kmailcvt/
+ ksendemail/
+ importwizard/
+ libksieve/
+ mailcommon/
+ mailimporter/
+ ontologies/
+ pimsettingexporter/
+ plugins/messageviewer/
+"
+
+KMLOADLIBS="kdepim-common-libs"
+
+src_configure() {
+ # Bug 308903
+ use ppc64 && append-flags -mminimal-toc
+
+ kde4-meta_src_configure
+}
+
+src_compile() {
+ kde4-meta_src_compile kmail_xml
+ kde4-meta_src_compile
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kdepim-kresources:${SLOT}; then
+ echo
+ elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
+ echo
+ fi
+ if ! has_version kde-base/kleopatra:${SLOT}; then
+ echo
+ elog "For certificate management and the gnupg log viewer, please install kde-base/kleopatra:${SLOT}"
+ echo
+ fi
+
+ if has_version "app-office/akonadi-server[sqlite]"; then
+ ewarn
+ ewarn "We strongly recommend you set your Akonadi database backend to QMYSQL in your"
+ ewarn "user configuration. This is the backend recommended by KDE upstream."
+ ewarn "Reports indicate that kde-base/kmail-4.10 does not work properly with the sqlite"
+ ewarn "backend anymore."
+ if has_version "app-office/akonadi-server[-mysql]"; then
+ ewarn "FOR THAT, YOU WILL HAVE TO RE-BUILD app-office/akonadi-server WITH mysql USEFLAG ENABLED."
+ fi
+ ewarn "You can select the backend in your ~/.config/akonadi/akonadiserverrc."
+ ewarn
+ fi
+}