summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-08-04 14:07:49 +0000
committerJohannes Huber <johu@gentoo.org>2012-08-04 14:07:49 +0000
commit89d95f90da9c54d93df6fb5e56277292638a0995 (patch)
treef731cf613a40a639646ffaf03dc75f060c7cc536 /kde-base
parentStable on amd64 wrt bug #428924 (diff)
downloadgentoo-2-89d95f90da9c54d93df6fb5e56277292638a0995.tar.gz
gentoo-2-89d95f90da9c54d93df6fb5e56277292638a0995.tar.bz2
gentoo-2-89d95f90da9c54d93df6fb5e56277292638a0995.zip
Add upstream patch by Michael Palimaka <kensington@gentoo.org> to fix parellel build issue wrt bug #415015.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/cantor/ChangeLog8
-rw-r--r--kde-base/cantor/cantor-4.9.0.ebuild4
-rw-r--r--kde-base/cantor/files/cantor-4.9.0-parallel-build.patch13
3 files changed, 22 insertions, 3 deletions
diff --git a/kde-base/cantor/ChangeLog b/kde-base/cantor/ChangeLog
index 52ce45bbf640..5dea33c121a9 100644
--- a/kde-base/cantor/ChangeLog
+++ b/kde-base/cantor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/cantor
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.73 2012/08/01 22:16:56 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.74 2012/08/04 14:07:49 johu Exp $
+
+ 04 Aug 2012; Johannes Huber <johu@gentoo.org>
+ +files/cantor-4.9.0-parallel-build.patch, cantor-4.9.0.ebuild:
+ Add upstream patch by Michael Palimaka <kensington@gentoo.org> to fix parellel
+ build issue wrt bug #415015.
*cantor-4.9.0 (01 Aug 2012)
@@ -284,4 +289,3 @@
08 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org> +cantor-4.4.0.ebuild:
Version bump to KDE SC 4.4.0
-
diff --git a/kde-base/cantor/cantor-4.9.0.ebuild b/kde-base/cantor/cantor-4.9.0.ebuild
index 6c34e489bffe..a8d7170da1c0 100644
--- a/kde-base/cantor/cantor-4.9.0.ebuild
+++ b/kde-base/cantor/cantor-4.9.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/cantor-4.9.0.ebuild,v 1.1 2012/08/01 22:16:56 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/cantor-4.9.0.ebuild,v 1.2 2012/08/04 14:07:49 johu Exp $
EAPI=4
@@ -27,6 +27,8 @@ DEPEND="${RDEPEND}
>=dev-cpp/eigen-2.0.3:2
"
+PATCHES=( "${FILESDIR}/${P}-parallel-build.patch" )
+
src_configure() {
mycmakeargs=(
$(cmake-utils_use_with analitza)
diff --git a/kde-base/cantor/files/cantor-4.9.0-parallel-build.patch b/kde-base/cantor/files/cantor-4.9.0-parallel-build.patch
new file mode 100644
index 000000000000..a0fce7f4aeed
--- /dev/null
+++ b/kde-base/cantor/files/cantor-4.9.0-parallel-build.patch
@@ -0,0 +1,13 @@
+diff --git a/src/backends/qalculate/plotassistant/qalculateplotassistant.h b/src/backends/qalculate/plotassistant/qalculateplotassistant.h
+index ac55b51cd67c1c403f28ca99eb72390a2f03a834..22f6c215d5026594d96483741e48c9c7dce97ce5 100644
+--- a/src/backends/qalculate/plotassistant/qalculateplotassistant.h
++++ b/src/backends/qalculate/plotassistant/qalculateplotassistant.h
+@@ -22,7 +22,7 @@
+ #define QALCULATE_PLOT_ASSISTANT_H
+
+ #include "assistant.h"
+-#include "../settings.h"
++#include "settings.h"
+ #include "ui_qalculateplotdialog.h"
+ #include <kdialog.h>
+ #include <qlist.h>