summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-03-19 00:31:24 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-03-19 00:31:24 +0000
commit5c16aa700cbb3a7694ffd6c32c7f4e03d042df76 (patch)
treed822510461dd08c5b2d989c1d597e3a822733413 /kde-base
parentrm old (diff)
downloadgentoo-2-5c16aa700cbb3a7694ffd6c32c7f4e03d042df76.tar.gz
gentoo-2-5c16aa700cbb3a7694ffd6c32c7f4e03d042df76.tar.bz2
gentoo-2-5c16aa700cbb3a7694ffd6c32c7f4e03d042df76.zip
Add search path for speex headers.
(Portage version: 2.0.51.19)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdemultimedia/kdemultimedia-3.4.0.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/kde-base/kdemultimedia/kdemultimedia-3.4.0.ebuild b/kde-base/kdemultimedia/kdemultimedia-3.4.0.ebuild
index e116f48099b6..58153a3bd5d2 100644
--- a/kde-base/kdemultimedia/kdemultimedia-3.4.0.ebuild
+++ b/kde-base/kdemultimedia/kdemultimedia-3.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/kdemultimedia-3.4.0.ebuild,v 1.3 2005/03/18 18:06:32 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/kdemultimedia-3.4.0.ebuild,v 1.4 2005/03/19 00:31:24 greg_g Exp $
inherit kde-dist eutils
@@ -34,14 +34,16 @@ src_unpack() {
}
src_compile() {
+ use speex && myconf="--with-extra-includes=/usr/include/speex"
+
use xine && myconf="${myconf} --with-xine-prefix=/usr"
use xine || DO_NOT_COMPILE="${DO_NOT_COMPILE} xine_artsplugin"
- myconf="${myconf} --with-cdparanoia --enable-cdparanoia"
- myconf="${myconf} $(use_with alsa arts-alsa) $(use_with alsa)"
- myconf="${myconf} $(use_with oggvorbis vorbis) $(use_with encode lame)"
- myconf="${myconf} $(use_with flac) $(use_with speex)"
- myconf="${myconf} $(use_with mad libmad) $(use_with jack)"
+ myconf="${myconf} --with-cdparanoia --enable-cdparanoia
+ $(use_with alsa arts-alsa) $(use_with alsa)
+ $(use_with oggvorbis vorbis) $(use_with encode lame)
+ $(use_with flac) $(use_with speex)
+ $(use_with mad libmad) $(use_with jack)"
kde_src_compile
}