summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-08-07 11:05:11 +0000
committerJohannes Huber <johu@gentoo.org>2012-08-07 11:05:11 +0000
commitc0c69592703d4bcb645ca889af281f6ad98e2d80 (patch)
treeb93e1ef3a3bc78eb187a28815fdcec5e0227568f /kde-base/qyoto
parentStable arm, bug #428900 (diff)
downloadgentoo-2-c0c69592703d4bcb645ca889af281f6ad98e2d80.tar.gz
gentoo-2-c0c69592703d4bcb645ca889af281f6ad98e2d80.tar.bz2
gentoo-2-c0c69592703d4bcb645ca889af281f6ad98e2d80.zip
Version bump KDE SC 4.8.5
(Portage version: 2.2.0_alpha120/cvs/Linux i686)
Diffstat (limited to 'kde-base/qyoto')
-rw-r--r--kde-base/qyoto/ChangeLog7
-rw-r--r--kde-base/qyoto/qyoto-4.8.5.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/kde-base/qyoto/ChangeLog b/kde-base/qyoto/ChangeLog
index 6f562762847e..c883138339e8 100644
--- a/kde-base/qyoto/ChangeLog
+++ b/kde-base/qyoto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/qyoto
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.30 2012/08/01 22:16:57 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.31 2012/08/07 11:04:57 johu Exp $
+
+*qyoto-4.8.5 (07 Aug 2012)
+
+ 07 Aug 2012; Johannes Huber <johu@gentoo.org> +qyoto-4.8.5.ebuild:
+ Version bump KDE SC 4.8.5
*qyoto-4.9.0 (01 Aug 2012)
diff --git a/kde-base/qyoto/qyoto-4.8.5.ebuild b/kde-base/qyoto/qyoto-4.8.5.ebuild
new file mode 100644
index 000000000000..d6d1c3195ded
--- /dev/null
+++ b/kde-base/qyoto/qyoto-4.8.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/qyoto-4.8.5.ebuild,v 1.1 2012/08/07 11:04:57 johu Exp $
+
+EAPI=4
+
+KDE_REQUIRED="never"
+KDE_SCM="git"
+inherit kde4-base mono
+
+DESCRIPTION="C# bindings for Qt"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qscintilla webkit"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smokeqt 'opengl,phonon?,qscintilla?,webkit?')
+"
+RDEPEND="${DEPEND}"
+
+# Split from kdebindings-csharp in 4.7
+add_blocker kdebindings-csharp
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable qscintilla QScintilla)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}