summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2012-12-05 16:58:30 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2012-12-05 16:58:30 +0000
commitb9d227823671a4217d7d0f9e194c5108eacc548e (patch)
tree8d57d37d8c5552901a88ade2d47df6941892d5aa /kde-base/qyoto
parentStable for HPPA (bug #444546). (diff)
downloadgentoo-2-b9d227823671a4217d7d0f9e194c5108eacc548e.tar.gz
gentoo-2-b9d227823671a4217d7d0f9e194c5108eacc548e.tar.bz2
gentoo-2-b9d227823671a4217d7d0f9e194c5108eacc548e.zip
[kde-base] Add KDE SC 4.9.4
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key F82F92E6)
Diffstat (limited to 'kde-base/qyoto')
-rw-r--r--kde-base/qyoto/ChangeLog7
-rw-r--r--kde-base/qyoto/qyoto-4.9.4.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/kde-base/qyoto/ChangeLog b/kde-base/qyoto/ChangeLog
index e59168b3d382..115bc6cfa2d7 100644
--- a/kde-base/qyoto/ChangeLog
+++ b/kde-base/qyoto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/qyoto
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.47 2012/11/30 16:45:31 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.48 2012/12/05 16:57:49 alexxy Exp $
+
+*qyoto-4.9.4 (05 Dec 2012)
+
+ 05 Dec 2012; Alexey Shvetsov <alexxy@gentoo.org> +qyoto-4.9.4.ebuild:
+ Version bump KDE SC 4.9.4
30 Nov 2012; <ago@gentoo.org> qyoto-4.9.3.ebuild:
Stable for ppc, wrt bug #442394
diff --git a/kde-base/qyoto/qyoto-4.9.4.ebuild b/kde-base/qyoto/qyoto-4.9.4.ebuild
new file mode 100644
index 000000000000..bef634a25004
--- /dev/null
+++ b/kde-base/qyoto/qyoto-4.9.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/qyoto-4.9.4.ebuild,v 1.1 2012/12/05 16:57:49 alexxy Exp $
+
+EAPI=4
+
+KDE_REQUIRED="never"
+inherit kde4-base mono
+
+DESCRIPTION="C# bindings for Qt"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qscintilla webkit"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smokeqt 'opengl,phonon?,qscintilla?,webkit?')
+"
+RDEPEND="${DEPEND}"
+
+# Split from kdebindings-csharp in 4.7
+add_blocker kdebindings-csharp
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable qscintilla QScintilla)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}