summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-09-06 02:00:19 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-09-06 02:00:19 +0000
commit74c48cf7b932d098c5615a765482e4b81221c830 (patch)
treed8bcdc2276cfaf80fab689f9bea20061c3b8cba5 /kde-base/pykde4
parentVersion bump KDE SC 4.5.1 (diff)
downloadgentoo-2-74c48cf7b932d098c5615a765482e4b81221c830.tar.gz
gentoo-2-74c48cf7b932d098c5615a765482e4b81221c830.tar.bz2
gentoo-2-74c48cf7b932d098c5615a765482e4b81221c830.zip
Version bump KDE SC 4.5.1
(Portage version: 2.2_rc75/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/pykde4')
-rw-r--r--kde-base/pykde4/ChangeLog8
-rw-r--r--kde-base/pykde4/files/pykde4-mapped-type-fix.patch64
-rw-r--r--kde-base/pykde4/pykde4-4.5.1-r1.ebuild85
3 files changed, 156 insertions, 1 deletions
diff --git a/kde-base/pykde4/ChangeLog b/kde-base/pykde4/ChangeLog
index 7c4d4d3b3d13..aeca4fef4c99 100644
--- a/kde-base/pykde4/ChangeLog
+++ b/kde-base/pykde4/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/pykde4
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.87 2010/09/05 22:23:38 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.88 2010/09/06 02:00:19 tampakrap Exp $
+
+*pykde4-4.5.1-r1 (06 Sep 2010)
+
+ 06 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +files/pykde4-mapped-type-fix.patch, +pykde4-4.5.1-r1.ebuild:
+ Version bump
05 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
-pykde4-4.4.9999.ebuild:
diff --git a/kde-base/pykde4/files/pykde4-mapped-type-fix.patch b/kde-base/pykde4/files/pykde4-mapped-type-fix.patch
new file mode 100644
index 000000000000..ebf1a54026f6
--- /dev/null
+++ b/kde-base/pykde4/files/pykde4-mapped-type-fix.patch
@@ -0,0 +1,64 @@
+--- trunk/KDE/kdebindings/python/pykde4/sip/kdecore/typedefs.sip 2010/01/16 10:06:39 1075490
++++ trunk/KDE/kdebindings/python/pykde4/sip/kdecore/typedefs.sip 2010/09/01 15:31:50 1170602
+@@ -733,61 +733,6 @@
+ };
+
+
+-%MappedType QList<uint>
+-{
+-%TypeHeaderCode
+-#include <qlist.h>
+-%End
+-
+-%ConvertFromTypeCode
+- // Create the list.
+- PyObject *l;
+-
+- if ((l = PyList_New(sipCpp->size())) == NULL)
+- return NULL;
+-
+- // Set the list elements.
+- for (int i = 0; i < sipCpp->size(); ++i) {
+- PyObject *pobj;
+-
+-#if PY_MAJOR_VERSION >= 3
+- if ((pobj = PyLong_FromLong(sipCpp->value(i))) == NULL) {
+-#else
+- if ((pobj = PyInt_FromLong(sipCpp->value(i))) == NULL) {
+-#endif
+- Py_DECREF(l);
+-
+- return NULL;
+- }
+-
+- PyList_SET_ITEM(l, i, pobj);
+- }
+-
+- return l;
+-%End
+-
+-%ConvertToTypeCode
+- // Check the type if that is all that is required.
+- if (sipIsErr == NULL)
+- return PyList_Check(sipPy);
+-
+- QList<uint> *ql = new QList<uint>;
+-
+- for (int i = 0; i < PyList_GET_SIZE(sipPy); ++i) {
+-#if PY_MAJOR_VERSION >= 3
+- ql->append(PyLong_AsLong(PyList_GET_ITEM(sipPy, i)));
+-#else
+- ql->append(PyInt_AsLong(PyList_GET_ITEM(sipPy, i)));
+-#endif
+- }
+-
+- *sipCppPtr = ql;
+-
+- return sipGetState(sipTransferObj);
+-%End
+-};
+-
+-
+ template <TYPE*>
+ %MappedType QStack<TYPE*>
+ {
diff --git a/kde-base/pykde4/pykde4-4.5.1-r1.ebuild b/kde-base/pykde4/pykde4-4.5.1-r1.ebuild
new file mode 100644
index 000000000000..3be2e28973d1
--- /dev/null
+++ b/kde-base/pykde4/pykde4-4.5.1-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/pykde4-4.5.1-r1.ebuild,v 1.1 2010/09/06 02:00:19 tampakrap Exp $
+
+EAPI="3"
+
+KMNAME="kdebindings"
+KMMODULE="python/pykde4"
+OPENGL_REQUIRED="always"
+PYTHON_USE_WITH="threads"
+RESTRICT_PYTHON_ABIS="2.4"
+inherit python kde4-meta
+
+DESCRIPTION="Python bindings for KDE4"
+KEYWORDS=""
+IUSE="debug doc examples semantic-desktop"
+
+# blocker added due to compatibility issues and error during compile time
+DEPEND="
+ !dev-python/pykde
+ $(add_kdebase_dep kdelibs 'opengl,semantic-desktop?')
+ semantic-desktop? ( $(add_kdebase_dep kdepimlibs 'semantic-desktop') )
+ aqua? ( >=dev-python/PyQt4-4.7[dbus,sql,svg,webkit,aqua] )
+ !aqua? ( >=dev-python/PyQt4-4.7[dbus,sql,svg,webkit,X] )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-mapped-type-fix.patch" )
+
+pkg_setup() {
+ python_pkg_setup
+ kde4-meta_pkg_setup
+}
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ if ! use examples; then
+ sed -e '/^ADD_SUBDIRECTORY(examples)/s/^/# DISABLED /' -i python/${PN}/CMakeLists.txt \
+ || die "Failed to disable examples"
+ fi
+
+ # See bug 322351
+ use arm && epatch "${FILESDIR}/${PN}-4.4.4-arm-sip.patch"
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_QScintilla=OFF
+ -DWITH_PolkitQt=OFF
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop KdepimLibs)
+ )
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${S}/python/pykde4/docs/html/")
+
+ kde4-meta_src_install
+
+ python_convert_shebangs -q -r $(python_get_version) "${ED}"
+ python_clean_installation_image -q
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ python_mod_optimize PyKDE4 PyQt4
+
+ if use examples; then
+ echo
+ elog "PyKDE4 examples have been installed to"
+ elog "${EKDEDIR}/share/apps/${PN}/examples"
+ echo
+ fi
+}
+
+pkg_postrm() {
+ kde4-meta_pkg_postrm
+
+ python_mod_cleanup PyKDE4 PyQt4
+}