summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-03 12:44:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-03 12:44:34 +0000
commit1c0a44d68c902612403977c3ea28539494abf379 (patch)
tree7624973212d44814bd7142d6c98149fa0e332f57 /kde-base/kwin
parentAdded patch to fix crypt issue, removed unneeded versions. (diff)
downloadgentoo-2-1c0a44d68c902612403977c3ea28539494abf379.tar.gz
gentoo-2-1c0a44d68c902612403977c3ea28539494abf379.tar.bz2
gentoo-2-1c0a44d68c902612403977c3ea28539494abf379.zip
Bump to 3.5.5 (pre-release).
(Portage version: 2.1.2_pre2-r1)
Diffstat (limited to 'kde-base/kwin')
-rw-r--r--kde-base/kwin/ChangeLog7
-rw-r--r--kde-base/kwin/files/digest-kwin-3.5.53
-rw-r--r--kde-base/kwin/kwin-3.5.5.ebuild28
3 files changed, 37 insertions, 1 deletions
diff --git a/kde-base/kwin/ChangeLog b/kde-base/kwin/ChangeLog
index 10a83c852ba7..2495ba3187d4 100644
--- a/kde-base/kwin/ChangeLog
+++ b/kde-base/kwin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kwin
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.64 2006/09/17 22:53:03 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.65 2006/10/03 12:44:34 flameeyes Exp $
+
+*kwin-3.5.5 (03 Oct 2006)
+
+ 03 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> +kwin-3.5.5.ebuild:
+ Bump to 3.5.5 (pre-release).
17 Sep 2006; Carsten Lohrke <carlo@gentoo.org> -kwin-3.4.3.ebuild:
Drop KDE 3.4.
diff --git a/kde-base/kwin/files/digest-kwin-3.5.5 b/kde-base/kwin/files/digest-kwin-3.5.5
new file mode 100644
index 000000000000..e34daba3f91c
--- /dev/null
+++ b/kde-base/kwin/files/digest-kwin-3.5.5
@@ -0,0 +1,3 @@
+MD5 7c16b95c5281dccdc9e917e74bff4029 kdebase-3.5.5.tar.bz2 23848082
+RMD160 9dbf9f210b3126ae8a7b0c703a54def869793234 kdebase-3.5.5.tar.bz2 23848082
+SHA256 58c37f98a83589ad7a7fb9d83817e9fdd0310b280324420d8db65f1b087906b9 kdebase-3.5.5.tar.bz2 23848082
diff --git a/kde-base/kwin/kwin-3.5.5.ebuild b/kde-base/kwin/kwin-3.5.5.ebuild
new file mode 100644
index 000000000000..2955751f7315
--- /dev/null
+++ b/kde-base/kwin/kwin-3.5.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-3.5.5.ebuild,v 1.1 2006/10/03 12:44:34 flameeyes Exp $
+
+KMNAME=kdebase
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE window manager"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="xcomposite"
+RDEPEND="xcomposite? ( || ( (
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ ) <x11-base/xorg-x11-7 )
+ )"
+DEPEND="${RDEPEND}
+ xcomposite? ( || ( (
+ x11-proto/compositeproto
+ x11-proto/damageproto
+ ) <x11-base/xorg-x11-7 )
+ )"
+
+src_compile() {
+ myconf="$myconf $(use_with xcomposite composite)"
+ kde-meta_src_compile
+}