summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-11-05 22:23:23 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-11-05 22:23:23 +0000
commit3d71d92c727066f449accc1c2b7461faade152ef (patch)
tree76c3626fcc383e0dea8d20c1bf208a6e28044206 /kde-base/ksystemlog
parentupdated HOMEPAGE to http://www.ugetdm.com (diff)
downloadgentoo-2-3d71d92c727066f449accc1c2b7461faade152ef.tar.gz
gentoo-2-3d71d92c727066f449accc1c2b7461faade152ef.tar.bz2
gentoo-2-3d71d92c727066f449accc1c2b7461faade152ef.zip
Version bump KDE SC 4.11.3
(Portage version: 2.2.7/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/ksystemlog')
-rw-r--r--kde-base/ksystemlog/ChangeLog8
-rw-r--r--kde-base/ksystemlog/ksystemlog-4.11.3.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/ksystemlog/ChangeLog b/kde-base/ksystemlog/ChangeLog
index 68a8cd13cb18..0eee5b2000d7 100644
--- a/kde-base/ksystemlog/ChangeLog
+++ b/kde-base/ksystemlog/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/ksystemlog
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.174 2013/10/10 01:27:07 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.175 2013/11/05 22:22:53 dilfridge Exp $
+
+*ksystemlog-4.11.3 (05 Nov 2013)
+
+ 05 Nov 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ +ksystemlog-4.11.3.ebuild:
+ Version bump KDE SC 4.11.3
10 Oct 2013; Chris Reffett <creffett@gentoo.org> -ksystemlog-4.11.1.ebuild:
Drop KDE SC 4.11.1
diff --git a/kde-base/ksystemlog/ksystemlog-4.11.3.ebuild b/kde-base/ksystemlog/ksystemlog-4.11.3.ebuild
new file mode 100644
index 000000000000..99876cd48080
--- /dev/null
+++ b/kde-base/ksystemlog/ksystemlog-4.11.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ksystemlog-4.11.3.ebuild,v 1.1 2013/11/05 22:22:53 dilfridge Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+VIRTUALX_REQUIRED=test
+inherit kde4-base
+
+DESCRIPTION="KDE system log viewer"
+HOMEPAGE="http://www.kde.org/applications/system/ksystemlog/"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug test"
+
+RESTRICT=test
+# bug 378101
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i tests/systemAnalyzerTest.cpp
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" -i ksystemlog/tests/CMakeLists.txt
+ fi
+}