summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-11-02 20:48:23 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-11-02 20:48:23 +0000
commit07a5746d946658a2d5d39b2008bdad2d2b2e127c (patch)
treea949b9dad962aee8c01f5011d077283fc50836d4 /kde-base/ksplash
parent[profiles/arch/powerpc] Update kde mask (diff)
downloadgentoo-2-07a5746d946658a2d5d39b2008bdad2d2b2e127c.tar.gz
gentoo-2-07a5746d946658a2d5d39b2008bdad2d2b2e127c.tar.bz2
gentoo-2-07a5746d946658a2d5d39b2008bdad2d2b2e127c.zip
[kde-base] KDE SC 4.7.3
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/ChangeLog7
-rw-r--r--kde-base/ksplash/ksplash-4.7.3.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index 9c74ff5efa52..0827b8c458cb 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.103 2011/10/28 19:03:32 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.104 2011/11/02 20:48:09 alexxy Exp $
+
+*ksplash-4.7.3 (02 Nov 2011)
+
+ 02 Nov 2011; Alexey Shvetsov <alexxy@gentoo.org> +ksplash-4.7.3.ebuild:
+ Version bump KDE SC 4.7.3
28 Oct 2011; Andreas K. Huettel <dilfridge@gentoo.org> -ksplash-4.7.1.ebuild:
Drop KDEpim 4.6.1 and KDE 4.7.1
diff --git a/kde-base/ksplash/ksplash-4.7.3.ebuild b/kde-base/ksplash/ksplash-4.7.3.ebuild
new file mode 100644
index 000000000000..1243df33bf9a
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.7.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.7.3.ebuild,v 1.1 2011/11/02 20:48:09 alexxy Exp $
+
+EAPI=4
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+COMMONDEPEND="
+ media-libs/libpng
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-4.4.2-xinerama_cmake_automagic.patch" )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_has 3dnow X86_3DNOW)
+ $(cmake-utils_use_has altivec PPC_ALTIVEC)
+ $(cmake-utils_use_has mmx X86_MMX)
+ $(cmake-utils_use_has sse X86_SSE)
+ $(cmake-utils_use_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama X11_Xinerama)
+ )
+
+ kde4-meta_src_configure
+}