summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-06-21 21:55:08 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-06-21 21:55:08 +0000
commit34c78a7dee48cc1df1e35264ea7e2c682926f487 (patch)
treef8ccbed0c1c5eda4ad6795fb2d3a688f91bb62e1 /kde-base/korundum
parentMark stable for amd64/x86 per bug #415255 (diff)
downloadgentoo-2-34c78a7dee48cc1df1e35264ea7e2c682926f487.tar.gz
gentoo-2-34c78a7dee48cc1df1e35264ea7e2c682926f487.tar.bz2
gentoo-2-34c78a7dee48cc1df1e35264ea7e2c682926f487.zip
KDE 4.8.4 version bump
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/korundum')
-rw-r--r--kde-base/korundum/ChangeLog8
-rw-r--r--kde-base/korundum/korundum-4.8.4.ebuild77
2 files changed, 84 insertions, 1 deletions
diff --git a/kde-base/korundum/ChangeLog b/kde-base/korundum/ChangeLog
index 64e4738c780d..c7828bea5105 100644
--- a/kde-base/korundum/ChangeLog
+++ b/kde-base/korundum/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/korundum
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/ChangeLog,v 1.115 2012/05/24 11:37:47 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/ChangeLog,v 1.116 2012/06/21 21:54:58 dilfridge Exp $
+
+*korundum-4.8.4 (21 Jun 2012)
+
+ 21 Jun 2012; Andreas K. Huettel <dilfridge@gentoo.org>
+ +korundum-4.8.4.ebuild:
+ Version bump KDE SC 4.8.4
24 May 2012; Johannes Huber <johu@gentoo.org> -korundum-4.8.1.ebuild:
Remove KDE SC 4.8.1
diff --git a/kde-base/korundum/korundum-4.8.4.ebuild b/kde-base/korundum/korundum-4.8.4.ebuild
new file mode 100644
index 000000000000..b6007bb7ff70
--- /dev/null
+++ b/kde-base/korundum/korundum-4.8.4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/korundum-4.8.4.ebuild,v 1.1 2012/06/21 21:54:58 dilfridge Exp $
+
+EAPI=4
+
+OPENGL_REQUIRED="always"
+
+USE_RUBY="ruby18"
+# No ruby19 for three reasons:
+# 1) it does not build (yet) - will likely be solved soon
+# 2) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
+# 3) the ebuild can only be installed for one ruby variant, otherwise the compiled
+# files with identical path+name will overwrite each other - difficult :(
+
+inherit kde4-base ruby-ng
+
+DESCRIPTION="KDE Ruby bindings"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="akonadi debug kate okular"
+
+# unfortunately single modules cannot be disabled with cmake defines
+# possible more useflags have no effect... does anyone actually build this stuff?
+# may need some hacking, for now semantic-desktop just becomes a hard dependency
+
+DEPEND="
+ $(add_kdebase_dep qtruby)
+ $(add_kdebase_dep smokekde 'kate?,okular?,semantic-desktop')
+ $(add_kdebase_dep smokeqt)
+"
+RDEPEND="${DEPEND}
+"
+
+# Split from kdebindings-ruby in 4.7
+add_blocker kdebindings-ruby
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_unpack() {
+ local S="${WORKDIR}/${P}"
+ kde4-base_src_unpack
+
+ cd "${WORKDIR}"
+ mkdir all
+ mv ${P} all/ || die "Could not move sources"
+}
+
+all_ruby_prepare() {
+ kde4-base_src_prepare
+}
+
+each_ruby_configure() {
+ CMAKE_USE_DIR=${S}
+ mycmakeargs=(
+ -DRUBY_LIBRARY=$(ruby_get_libruby)
+ -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
+ -DRUBY_EXECUTABLE=${RUBY}
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_disable kate)
+ $(cmake-utils_use_with okular)
+ )
+ kde4-base_src_configure
+}
+
+each_ruby_compile() {
+ CMAKE_USE_DIR=${S}
+ kde4-base_src_compile
+}
+
+each_ruby_install() {
+ CMAKE_USE_DIR=${S}
+ kde4-base_src_install
+}