summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-12-06 10:28:24 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-12-06 10:28:24 +0000
commit6bdee878faab5002e138b8d44111313293dcf955 (patch)
tree63d2a20c69077a642b5807d56bcbb880a7e8f348 /kde-base/kontact
parentAdd support for KDEPIM 4.4.8 in kde eclasses (diff)
downloadgentoo-2-6bdee878faab5002e138b8d44111313293dcf955.tar.gz
gentoo-2-6bdee878faab5002e138b8d44111313293dcf955.tar.bz2
gentoo-2-6bdee878faab5002e138b8d44111313293dcf955.zip
Version bump KDEPIM 4.4.8
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kontact')
-rw-r--r--kde-base/kontact/ChangeLog7
-rw-r--r--kde-base/kontact/kontact-4.4.8.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/kde-base/kontact/ChangeLog b/kde-base/kontact/ChangeLog
index 6ede3b7d6739..9b2616241498 100644
--- a/kde-base/kontact/ChangeLog
+++ b/kde-base/kontact/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kontact
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kontact/ChangeLog,v 1.168 2010/11/06 19:28:59 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kontact/ChangeLog,v 1.169 2010/12/06 10:28:24 tampakrap Exp $
+
+*kontact-4.4.8 (06 Dec 2010)
+
+ 06 Dec 2010; Theo Chatzimichos <tampakrap@gentoo.org> +kontact-4.4.8.ebuild:
+ Version bump KDE SC 4.4.8
06 Nov 2010; Christian Faulhammer <fauli@gentoo.org> kontact-4.4.7.ebuild:
stable x86, bug 343969
diff --git a/kde-base/kontact/kontact-4.4.8.ebuild b/kde-base/kontact/kontact-4.4.8.ebuild
new file mode 100644
index 000000000000..495594b8a341
--- /dev/null
+++ b/kde-base/kontact/kontact-4.4.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kontact/kontact-4.4.8.ebuild,v 1.1 2010/12/06 10:28:24 tampakrap Exp $
+
+EAPI="3"
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="KDE personal information manager"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs)
+ $(add_kdebase_dep libkdepim)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-runtime)
+"
+
+KMLOADLIBS="libkdepim"
+KMSAVELIBS="true"
+
+# We remove plugins that are related to external kdepim programs. This way
+# kontact doesn't have to depend on all programs it has plugins for.
+# kcontactmanager gone from kdesvn
+#
+# xml targets from kmail/ are being uncommented by kde4-meta.eclass
+KMEXTRACTONLY="
+ kmail/
+ kontact/plugins/akregator/
+ kontact/plugins/kaddressbook/
+ kontact/plugins/kjots/
+ kontact/plugins/kmail/
+ kontact/plugins/knode/
+ kontact/plugins/knotes/
+ kontact/plugins/korganizer/
+ kontact/plugins/ktimetracker/
+ kontact/plugins/planner/
+ kontact/plugins/specialdates/
+"
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA+="
+ doc/kontact-admin/
+ "
+ fi
+
+ kde4-meta_src_unpack
+}