summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-06-15 16:57:08 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-06-15 16:57:08 +0000
commitb19b0ead03dc10cdaa9aea4001d560c962a1f597 (patch)
treef22852d83a670996da46e118f610a0f6dfa2f4ba /kde-base/kig
parentsys-kernel/aufs-sources: Fix problem due to renamed tmpfs patch, #513332 (diff)
downloadgentoo-2-b19b0ead03dc10cdaa9aea4001d560c962a1f597.tar.gz
gentoo-2-b19b0ead03dc10cdaa9aea4001d560c962a1f597.tar.bz2
gentoo-2-b19b0ead03dc10cdaa9aea4001d560c962a1f597.zip
Version bump KDE SC 4.13.2
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'kde-base/kig')
-rw-r--r--kde-base/kig/ChangeLog8
-rw-r--r--kde-base/kig/kig-4.13.2.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/kig/ChangeLog b/kde-base/kig/ChangeLog
index bf5cee6857af..c810a27013e1 100644
--- a/kde-base/kig/ChangeLog
+++ b/kde-base/kig/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kig
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kig/ChangeLog,v 1.330 2014/05/13 17:43:10 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kig/ChangeLog,v 1.331 2014/06/15 16:56:58 kensington Exp $
+
+*kig-4.13.2 (15 Jun 2014)
+
+ 15 Jun 2014; Michael Palimaka <kensington@gentoo.org> +kig-4.13.2.ebuild,
+ files/kig-4.12.0-boostpython.patch:
+ Version bump KDE SC 4.13.2
*kig-4.13.1 (13 May 2014)
diff --git a/kde-base/kig/kig-4.13.2.ebuild b/kde-base/kig/kig-4.13.2.ebuild
new file mode 100644
index 000000000000..583dac32a06c
--- /dev/null
+++ b/kde-base/kig/kig-4.13.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kig/kig-4.13.2.ebuild,v 1.1 2014/06/15 16:56:58 kensington Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 kde4-base
+
+DESCRIPTION="KDE Interactive Geometry tool"
+HOMEPAGE="http://www.kde.org/applications/education/kig http://edu.kde.org/kig"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug scripting"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ scripting? ( >=dev-libs/boost-1.48:=[python,${PYTHON_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-4.12.0-boostpython.patch" )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ python_fix_shebang .
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package scripting BoostPython)
+ )
+
+ kde4-base_src_configure
+}