summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-08-22 11:29:04 +0000
committerDan Armak <danarmak@gentoo.org>2001-08-22 11:29:04 +0000
commit0b3b27e0e71c44ef16fa542945a6a940c6057273 (patch)
tree21f1045c67f3ff80d949553879229dc48caee1c8 /kde-base/kdetoys
parentadded xalf, see http://www.lysator.liu.se/~astrand/projects/xalf/ for descrip... (diff)
downloadgentoo-2-0b3b27e0e71c44ef16fa542945a6a940c6057273.tar.gz
gentoo-2-0b3b27e0e71c44ef16fa542945a6a940c6057273.tar.bz2
gentoo-2-0b3b27e0e71c44ef16fa542945a6a940c6057273.zip
Multiple changes:
1. added kdegames, kdetoys modules 2. added objprelink support to all modules (use objprelink USE flag) 3. variable cleanup (${A}, ${V}) - made short and unified, removed misc. workarounds added for 2.2_beta1 4. $Header$ fixes 5. kdebase now installs, under /usr/X11R6/bin, the file 'kde22' and a symlink to it, 'kde'.
Diffstat (limited to 'kde-base/kdetoys')
-rw-r--r--kde-base/kdetoys/kdetoys-2.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-base/kdetoys/kdetoys-2.2.ebuild b/kde-base/kdetoys/kdetoys-2.2.ebuild
new file mode 100644
index 000000000000..1c6d42b2cae1
--- /dev/null
+++ b/kde-base/kdetoys/kdetoys-2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Philippe Namias <pnamias@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdetoys/kdetoys-2.2.ebuild,v 1.1 2001/08/22 11:29:04 danarmak Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="KDE ${PV} - Toys"
+SRC_PATH="kde/stable/${PV}/src/${P}.tar.bz2"
+SRC_URI="ftp://ftp.kde.org/pub/$SRC_PATH
+ ftp://ftp.sourceforge.net/pub/mirrors/$SRC_PATH
+ http://www.research.att.com/~leonb/objprelink/kde-admin-acinclude.patch"
+
+HOMEPAGE="http://www.kde.org/"
+
+DEPEND=">=kde-base/kdelibs-${PV}
+ objprelink? ( dev-util/objprelink )"
+
+RDEPEND="$DEPEND"
+
+src_compile() {
+ if [ "`use objprelink`" ] ; then
+ myconf="--enable-objprelink"
+ fi
+ QTBASE=/usr/X11R6/lib/qt
+ try ./configure --prefix=${KDEDIR} --host=${CHOST} \
+ --with-qt-dir=$QTBASE --with-xinerama $myconf
+ try make
+}
+
+src_install() {
+ try make install DESTDIR=${D}
+ dodoc AUTHORS COPYING README
+}