summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-02-24 09:38:19 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-02-24 09:38:19 +0000
commitdb21c54c6c167bed5144797d7de00a8c2cea55fc (patch)
tree50a0aa54bae6e7f09ab9d8dccacb3d31bf2a67a0 /kde-base/kdepimlibs
parentmark ~x86-freebsd (diff)
downloadgentoo-2-db21c54c6c167bed5144797d7de00a8c2cea55fc.tar.gz
gentoo-2-db21c54c6c167bed5144797d7de00a8c2cea55fc.tar.bz2
gentoo-2-db21c54c6c167bed5144797d7de00a8c2cea55fc.zip
Apply patch from upstream trunk for Sieve script editing wrt #305211, thanks to Martin Regner and Andreas K. Huettel.
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kdepimlibs')
-rw-r--r--kde-base/kdepimlibs/ChangeLog9
-rw-r--r--kde-base/kdepimlibs/files/kdepimlibs-4.4.0-sieve.patch20
-rw-r--r--kde-base/kdepimlibs/kdepimlibs-4.4.0-r1.ebuild59
3 files changed, 87 insertions, 1 deletions
diff --git a/kde-base/kdepimlibs/ChangeLog b/kde-base/kdepimlibs/ChangeLog
index 1f246307f0ac..df4c14c3a6e1 100644
--- a/kde-base/kdepimlibs/ChangeLog
+++ b/kde-base/kdepimlibs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/kdepimlibs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.64 2010/02/20 10:37:04 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.65 2010/02/24 09:38:18 ssuominen Exp $
+
+*kdepimlibs-4.4.0-r1 (24 Feb 2010)
+
+ 24 Feb 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +kdepimlibs-4.4.0-r1.ebuild, +files/kdepimlibs-4.4.0-sieve.patch:
+ Apply patch from upstream trunk for Sieve script editing wrt #305211,
+ thanks to Martin Regner and Andreas K. Huettel.
20 Feb 2010; Samuli Suominen <ssuominen@gentoo.org>
kdepimlibs-4.3.5.ebuild:
diff --git a/kde-base/kdepimlibs/files/kdepimlibs-4.4.0-sieve.patch b/kde-base/kdepimlibs/files/kdepimlibs-4.4.0-sieve.patch
new file mode 100644
index 000000000000..006c7b5a47e5
--- /dev/null
+++ b/kde-base/kdepimlibs/files/kdepimlibs-4.4.0-sieve.patch
@@ -0,0 +1,20 @@
+http://bugs.kde.org/show_bug.cgi?id=212951
+http://bugs.gentoo.org/show_bug.cgi?id=305211
+
+--- kioslave/sieve/sieve.cpp
++++ kioslave/sieve/sieve.cpp
+@@ -364,12 +364,11 @@
+ }
+
+ // FIXME find a test server and test that this works
+- // TODO ask the system whether SSL is available
+- if (useTLSIfAvailable && QSslSocket::supportsSsl()) {
++ if (useTLSIfAvailable && m_supportsTLS && QSslSocket::supportsSsl()) {
+ sendData("STARTTLS");
+ if (operationSuccessful()) {
+ ksDebug << "TLS has been accepted. Starting TLS..." << endl
+- << "WARNING this is untested and may fail.";
++ << "WARNING this is untested and may fail.";
+ if (startSsl()) {
+ ksDebug << "TLS enabled successfully." << endl;
+ // reparse capabilities:
diff --git a/kde-base/kdepimlibs/kdepimlibs-4.4.0-r1.ebuild b/kde-base/kdepimlibs/kdepimlibs-4.4.0-r1.ebuild
new file mode 100644
index 000000000000..1ae40681975c
--- /dev/null
+++ b/kde-base/kdepimlibs/kdepimlibs-4.4.0-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/kdepimlibs-4.4.0-r1.ebuild,v 1.1 2010/02/24 09:38:18 ssuominen Exp $
+
+EAPI="2"
+
+CPPUNIT_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Common library for KDE PIM apps."
+HOMEPAGE="http://www.kde.org/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="LGPL-2.1"
+IUSE="+akonadi debug +handbook ldap"
+
+# some akonadi tests timeout, that probaly needs more work as its ~700 tests
+RESTRICT="test"
+
+DEPEND="
+ >=app-crypt/gpgme-1.1.6
+ >=dev-libs/boost-1.35.0-r5
+ dev-libs/libgpg-error
+ >=dev-libs/libical-0.43
+ dev-libs/cyrus-sasl
+ akonadi? ( >=app-office/akonadi-server-1.3.1 )
+ ldap? ( net-nds/openldap )
+"
+RDEPEND="${DEPEND}"
+
+# libakonadi-kcal moved here from akonadi in 4.3.86
+add_blocker akonadi '<4.3.86'
+# @since 4.3 - libkholidays is in kdepimlibs now
+add_blocker libkholidays
+# @since 4.4 - kontactinterfaces is in kdepimlibs now
+add_blocker kontactinterfaces
+
+PATCHES=( "${FILESDIR}/${P}-sieve.patch" )
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ if ! use akonadi; then
+ sed -e '/find_package(Akonadi/s/^/# DISABLED /' \
+ -e '/macro_log_feature(Akonadi_FOUND/s/TRUE/FALSE/' \
+ -e '/add_subdirectory(akonadi)/s/^/# DISABLED /' \
+ -e '/add_subdirectory(mailtransport)/s/^/# DISABLED /' \
+ -i CMakeLists.txt || die "failed to disable akonadi"
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build handbook doc)
+ $(cmake-utils_use_with ldap)
+ )
+
+ kde4-base_src_configure
+}