summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-04-11 21:01:40 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-04-11 21:01:40 +0000
commitce91c9e0323fa2978ac6136ec392d41a9838be42 (patch)
tree99e1120510eb2a741806ee3cb91ff851590ebb8d /kde-base/kdepim/kdepim-3.5.6-r2.ebuild
parentStable for HPPA (bug #172752). (diff)
downloadgentoo-2-ce91c9e0323fa2978ac6136ec392d41a9838be42.tar.gz
gentoo-2-ce91c9e0323fa2978ac6136ec392d41a9838be42.tar.bz2
gentoo-2-ce91c9e0323fa2978ac6136ec392d41a9838be42.zip
Several bugfixes form the KDE 3.5 branch. For more information see the corresponding split ebuild updates.
(Portage version: 2.1.2.3)
Diffstat (limited to 'kde-base/kdepim/kdepim-3.5.6-r2.ebuild')
-rw-r--r--kde-base/kdepim/kdepim-3.5.6-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/kde-base/kdepim/kdepim-3.5.6-r2.ebuild b/kde-base/kdepim/kdepim-3.5.6-r2.ebuild
new file mode 100644
index 000000000000..c30008559c5a
--- /dev/null
+++ b/kde-base/kdepim/kdepim-3.5.6-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim/kdepim-3.5.6-r2.ebuild,v 1.1 2007/04/11 21:01:40 carlo Exp $
+
+inherit kde-dist
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdepim-3.5-patchset-03.tar.bz2"
+
+DESCRIPTION="KDE PIM (Personal Information Management) applications: KOrganizer, KMail, KNode,..."
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt gnokii"
+
+# We use GnuPG 1.4.x for OpenPGP and 1.9 (via gpgme) for s/mime as upstream advises.
+DEPEND="~kde-base/kdebase-${PV}
+ >=dev-libs/cyrus-sasl-2
+ gnokii? ( app-mobilephone/gnokii )
+ crypt? ( >=app-crypt/gpgme-1.1.2-r1
+ || ( >=app-crypt/gnupg-2.0.1-r1 <app-crypt/gnupg-1.9 ) )
+ x11-libs/libXScrnSaver"
+# Requires pilot-link-0.12.0
+# pda? ( >=app-pda/pilot-link-0.12.0 dev-libs/libmal )
+
+RDEPEND="${DEPEND}
+ crypt? ( app-crypt/pinentry )"
+
+DEPEND="${DEPEND}
+ x11-proto/scrnsaverproto"
+
+src_unpack() {
+ kde_src_unpack
+ # Call Qt 3 designer
+ sed -i -e "s:\"designer\":\"${QTDIR}/bin/designer\":g" "${S}"/libkdepim/kcmdesignerfields.cpp || die "sed failed"
+
+ sed -e "s:SUBDIRS = libical versit tests:SUBDIRS = libical versit:" -i libkcal/Makefile.am || die "sed failed"
+}
+
+src_compile() {
+ local myconf="--with-sasl $(use_with gnokii)"
+ use crypt && myconf="${myconf} --with-gpg=/usr/bin/gpg"
+
+ # use pda || DO_NOT_COMPILE="${DO_NOT_COMPILE} kpilot"
+ DO_NOT_COMPILE="${DO_NOT_COMPILE} kpilot"
+
+ kde_src_compile
+}