summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-03-29 13:14:08 +0000
committerJohannes Huber <johu@gentoo.org>2015-03-29 13:14:08 +0000
commitb7509c3915c9467043448903d2cbe6f89e1d6a89 (patch)
treee6494b49a07e665cea806050a13c2f32fa2eb891 /kde-base/kdepim-runtime
parentVersion Bump; drop old (diff)
downloadgentoo-2-b7509c3915c9467043448903d2cbe6f89e1d6a89.tar.gz
gentoo-2-b7509c3915c9467043448903d2cbe6f89e1d6a89.tar.bz2
gentoo-2-b7509c3915c9467043448903d2cbe6f89e1d6a89.zip
Version bump KDE PIM 4.14.6
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xF3CFD2BD)
Diffstat (limited to 'kde-base/kdepim-runtime')
-rw-r--r--kde-base/kdepim-runtime/ChangeLog7
-rw-r--r--kde-base/kdepim-runtime/kdepim-runtime-4.14.6.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/kde-base/kdepim-runtime/ChangeLog b/kde-base/kdepim-runtime/ChangeLog
index 1452927f89f6..8bb3ebf0fbe8 100644
--- a/kde-base/kdepim-runtime/ChangeLog
+++ b/kde-base/kdepim-runtime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdepim-runtime
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.232 2015/02/18 16:26:48 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.233 2015/03/29 13:14:08 johu Exp $
+
+*kdepim-runtime-4.14.6 (29 Mar 2015)
+
+ 29 Mar 2015; Johannes Huber <johu@gentoo.org> +kdepim-runtime-4.14.6.ebuild:
+ Version bump KDE PIM 4.14.6
18 Feb 2015; Michał Górny <mgorny@gentoo.org> -kdepim-runtime-4.12.5.ebuild:
Remove KDE SC 4.12
diff --git a/kde-base/kdepim-runtime/kdepim-runtime-4.14.6.ebuild b/kde-base/kdepim-runtime/kdepim-runtime-4.14.6.ebuild
new file mode 100644
index 000000000000..b18617dbe37e
--- /dev/null
+++ b/kde-base/kdepim-runtime/kdepim-runtime-4.14.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/kdepim-runtime-4.14.6.ebuild,v 1.1 2015/03/29 13:14:08 johu Exp $
+
+EAPI=5
+
+KMNAME="kdepim-runtime"
+inherit kde4-base
+
+DESCRIPTION="KDE PIM runtime plugin collection"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug facebook google kolab"
+
+RESTRICT="test"
+# Would need test programs _testrunner and akonaditest from kdepimlibs, see bug 313233
+
+DEPEND="
+ >=app-office/akonadi-server-1.12.90
+ dev-libs/boost:=
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ $(add_kdebase_dep kdepimlibs)
+ x11-misc/shared-mime-info
+ facebook? ( net-libs/libkfbapi )
+ google? ( >=net-libs/libkgapi-2.0 )
+ kolab? ( >=net-libs/libkolab-0.5 )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-icons)
+ !kde-misc/akonadi-google
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package facebook LibKFbAPI)
+ $(cmake-utils_use_find_package google LibKGAPI2)
+ $(cmake-utils_use_find_package kolab Libkolab)
+ $(cmake-utils_use_find_package kolab Libkolabxml)
+ )
+
+ kde4-base_src_configure
+}