summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-01-26 20:29:26 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-01-26 20:29:26 +0000
commitb55417d98c3ac6be2310a3971632cceac43c9378 (patch)
tree76ff040300cffb0bfdb60a4c1a785df48fbbf7cd /kde-base/kdebindings-perl
parent[profiles] Mask marble with gps on ppc64 (diff)
downloadgentoo-2-b55417d98c3ac6be2310a3971632cceac43c9378.tar.gz
gentoo-2-b55417d98c3ac6be2310a3971632cceac43c9378.tar.bz2
gentoo-2-b55417d98c3ac6be2310a3971632cceac43c9378.zip
[kde-base] Add KDE SC 4.6.0
(Portage version: 2.2.0_alpha19_p2/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kdebindings-perl')
-rw-r--r--kde-base/kdebindings-perl/ChangeLog8
-rw-r--r--kde-base/kdebindings-perl/kdebindings-perl-4.6.0.ebuild53
-rw-r--r--kde-base/kdebindings-perl/metadata.xml2
3 files changed, 62 insertions, 1 deletions
diff --git a/kde-base/kdebindings-perl/ChangeLog b/kde-base/kdebindings-perl/ChangeLog
index b13e672143d2..1822d507b4d6 100644
--- a/kde-base/kdebindings-perl/ChangeLog
+++ b/kde-base/kdebindings-perl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdebindings-perl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-perl/ChangeLog,v 1.8 2011/01/10 11:53:27 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-perl/ChangeLog,v 1.9 2011/01/26 20:28:32 alexxy Exp $
+
+*kdebindings-perl-4.6.0 (26 Jan 2011)
+
+ 26 Jan 2011; Alexey Shvetsov <alexxy@gentoo.org>
+ +kdebindings-perl-4.6.0.ebuild:
+ Version bump KDE SC 4.6.0
*kdebindings-perl-4.5.5 (10 Jan 2011)
diff --git a/kde-base/kdebindings-perl/kdebindings-perl-4.6.0.ebuild b/kde-base/kdebindings-perl/kdebindings-perl-4.6.0.ebuild
new file mode 100644
index 000000000000..c0788ef5ba4f
--- /dev/null
+++ b/kde-base/kdebindings-perl/kdebindings-perl-4.6.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-perl/kdebindings-perl-4.6.0.ebuild,v 1.1 2011/01/26 20:28:32 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdebindings"
+KMMODULE="perl"
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+WEBKIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE Perl bindings"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="akonadi attica debug kate okular phonon plasma qimageblitz qscintilla qwt semantic-desktop"
+
+DEPEND="
+ >=dev-lang/perl-5.10.1
+ $(add_kdebase_dep smoke 'akonadi?,attica?,declarative?,kate?,multimedia?,okular?,phonon?,qimageblitz?,qscintilla?,qthelp?,qwt?,semantic-desktop?,webkit?')
+ semantic-desktop? ( >=dev-libs/soprano-2.4.64 )
+"
+RDEPEND="${DEPEND}"
+
+KMLOADLIBS="smoke"
+
+KMEXTRACTONLY="
+ smoke/
+"
+
+src_configure() {
+ mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable kate)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_with okular)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable plasma)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-meta_src_configure
+}
diff --git a/kde-base/kdebindings-perl/metadata.xml b/kde-base/kdebindings-perl/metadata.xml
index 6b553f6c8e25..8e2663e75018 100644
--- a/kde-base/kdebindings-perl/metadata.xml
+++ b/kde-base/kdebindings-perl/metadata.xml
@@ -5,6 +5,8 @@
<use>
<flag name="attica">Compile bindings for <pkg>dev-libs/libattica</pkg>.</flag>
<flag name="akonadi">Compile bindings for Akonadi.</flag>
+ <flag name="declarative">Compile bindings for <pkg>x11-libs/qt-declarative</pkg>.</flag>
+ <flag name="kate">Compile bindings for KDE Advanced Text Editor.</flag>
<flag name="multimedia">Compile bindings for <pkg>x11-libs/qt-multimedia</pkg>.</flag>
<flag name="okular">Compile bindings for <pkg>kde-base/okular</pkg>.</flag>
<flag name="phonon">Compile bindings for Phonon.</flag>