summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-12-09 09:27:21 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-12-09 09:27:21 +0000
commit3f3832d531cf3ea170b231b586de8322ad3e9a22 (patch)
tree4af29aecec5880d7b2f78c92551c6828b56ba990 /kde-base/kcheckpass
parentMarked ppc stable for bug #112842. (diff)
downloadgentoo-2-3f3832d531cf3ea170b231b586de8322ad3e9a22.tar.gz
gentoo-2-3f3832d531cf3ea170b231b586de8322ad3e9a22.tar.bz2
gentoo-2-3f3832d531cf3ea170b231b586de8322ad3e9a22.zip
Added support for non-lazy-bindings as per bug #114049.
(Portage version: 2.0.53)
Diffstat (limited to 'kde-base/kcheckpass')
-rw-r--r--kde-base/kcheckpass/ChangeLog6
-rw-r--r--kde-base/kcheckpass/files/kcheckpass-3.5.0-bindnow.patch13
-rw-r--r--kde-base/kcheckpass/kcheckpass-3.5.0.ebuild8
3 files changed, 24 insertions, 3 deletions
diff --git a/kde-base/kcheckpass/ChangeLog b/kde-base/kcheckpass/ChangeLog
index 58ba21ff3deb..7aff4a3d7026 100644
--- a/kde-base/kcheckpass/ChangeLog
+++ b/kde-base/kcheckpass/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kcheckpass
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.33 2005/12/09 03:34:34 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.34 2005/12/09 09:27:21 flameeyes Exp $
+
+ 09 Dec 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kcheckpass-3.5.0-bindnow.patch, kcheckpass-3.5.0.ebuild:
+ Added support for non-lazy-bindings as per bug #114049.
09 Dec 2005; Joseph Jezak <josejx@gentoo.org> kcheckpass-3.4.3.ebuild:
Marked ppc stable for bug #112842.
diff --git a/kde-base/kcheckpass/files/kcheckpass-3.5.0-bindnow.patch b/kde-base/kcheckpass/files/kcheckpass-3.5.0-bindnow.patch
new file mode 100644
index 000000000000..b04cfb37a2b2
--- /dev/null
+++ b/kde-base/kcheckpass/files/kcheckpass-3.5.0-bindnow.patch
@@ -0,0 +1,13 @@
+Index: kdebase-3.5.0/kcheckpass/Makefile.am
+===================================================================
+--- kdebase-3.5.0.orig/kcheckpass/Makefile.am
++++ kdebase-3.5.0/kcheckpass/Makefile.am
+@@ -10,7 +10,7 @@ kcheckpass_SOURCES = kcheckpass.c \
+ checkpass_etcpasswd.c checkpass_pam.c checkpass_shadow.c \
+ checkpass_osfc2passwd.c checkpass_aix.c
+ kcheckpass_LDADD = -lkdefakes $(PASSWDLIBS) $(LIBSOCKET)
+-kcheckpass_LDFLAGS = $(KDE_USE_PIE) $(all_libraries)
++kcheckpass_LDFLAGS = $(KDE_USE_PIE) $(all_libraries) $(BINDNOW_FLAGS)
+
+ noinst_HEADERS = kcheckpass.h
+
diff --git a/kde-base/kcheckpass/kcheckpass-3.5.0.ebuild b/kde-base/kcheckpass/kcheckpass-3.5.0.ebuild
index b94ac642b3f8..5244f5685adc 100644
--- a/kde-base/kcheckpass/kcheckpass-3.5.0.ebuild
+++ b/kde-base/kcheckpass/kcheckpass-3.5.0.ebuild
@@ -1,18 +1,22 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-3.5.0.ebuild,v 1.4 2005/12/04 01:39:16 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-3.5.0.ebuild,v 1.5 2005/12/09 09:27:21 flameeyes Exp $
KMNAME=kdebase
MAXKDEVER=$PV
KM_DEPRANGE="$PV $MAXKDEVER"
-inherit kde-meta eutils
+inherit kde-meta eutils flag-o-matic
DESCRIPTION="A simple password checker, used by any software in need of user authentication."
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
IUSE="pam"
DEPEND="pam? ( kde-base/kdebase-pam ) !pam? ( sys-apps/shadow )"
+PATCHES="${FILESDIR}/${P}-bindnow.patch"
+
src_compile() {
myconf="$(use_with pam)"
+
+ export BINDNOW_FLAGS="$(bindnow-flags)"
kde-meta_src_compile
}