summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-01-25 18:17:26 +0000
committerJohannes Huber <johu@gentoo.org>2012-01-25 18:17:26 +0000
commit8f5c0a404860825a8ca1de5f74decd3e3b2f411e (patch)
treefd54bf03f8193c4baefa01616ebd14e3b25f8717 /kde-base/cantor
parentUse github from thirdpartymirrors. (diff)
downloadgentoo-2-8f5c0a404860825a8ca1de5f74decd3e3b2f411e.tar.gz
gentoo-2-8f5c0a404860825a8ca1de5f74decd3e3b2f411e.tar.bz2
gentoo-2-8f5c0a404860825a8ca1de5f74decd3e3b2f411e.zip
Version bump KDE SC 4.8.0
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/cantor')
-rw-r--r--kde-base/cantor/ChangeLog7
-rw-r--r--kde-base/cantor/cantor-4.8.0.ebuild45
-rw-r--r--kde-base/cantor/metadata.xml1
3 files changed, 52 insertions, 1 deletions
diff --git a/kde-base/cantor/ChangeLog b/kde-base/cantor/ChangeLog
index b89d8d4e6c9c..f94fee898d54 100644
--- a/kde-base/cantor/ChangeLog
+++ b/kde-base/cantor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/cantor
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.56 2012/01/17 13:28:49 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.57 2012/01/25 18:17:14 johu Exp $
+
+*cantor-4.8.0 (25 Jan 2012)
+
+ 25 Jan 2012; Johannes Huber <johu@gentoo.org> +cantor-4.8.0.ebuild:
+ Version bump KDE SC 4.8.0
17 Jan 2012; Johannes Huber <johu@gentoo.org> -cantor-4.7.3.ebuild:
Remove KDE SC 4.7.3
diff --git a/kde-base/cantor/cantor-4.8.0.ebuild b/kde-base/cantor/cantor-4.8.0.ebuild
new file mode 100644
index 000000000000..6bd337588ccf
--- /dev/null
+++ b/kde-base/cantor/cantor-4.8.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/cantor-4.8.0.ebuild,v 1.1 2012/01/25 18:17:14 johu Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="KDE4 interface for doing mathematics and scientific computing"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="analitza debug ps +R"
+
+# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
+RDEPEND="
+ analitza? ( $(add_kdebase_dep analitza) )
+ ps? ( app-text/libspectre )
+ R? ( dev-lang/R )
+"
+DEPEND="${RDEPEND}
+ >=dev-cpp/eigen-2.0.3:2
+"
+
+src_configure() {
+ mycmakeargs+="
+ $(cmake-utils_use_with analitza Analitza)
+ $(cmake-utils_use_with ps LibSpectre)
+ $(cmake-utils_use_with R)
+ "
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! use R; then
+ echo
+ ewarn "You have decided to build ${PN} with no backend."
+ ewarn "To have this application functional, please do one of below:"
+ ewarn " # emerge -va1 '='${CATEGORY}/${P} with 'R' USE flag enabled"
+ ewarn " # emerge -vaDu sci-mathematics/maxima"
+ echo
+ fi
+}
diff --git a/kde-base/cantor/metadata.xml b/kde-base/cantor/metadata.xml
index 97b1e810f03d..77971e25cb8e 100644
--- a/kde-base/cantor/metadata.xml
+++ b/kde-base/cantor/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<herd>kde</herd>
<use>
+ <flag name="analitza">Enable support <pkg>kde-base/analitza</pkg></flag>
<flag name="ps">Enable rendering EPS files</flag>
<flag name="R">Enable R backend support</flag>
</use>