summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2012-12-05 16:58:30 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2012-12-05 16:58:30 +0000
commitb9d227823671a4217d7d0f9e194c5108eacc548e (patch)
tree8d57d37d8c5552901a88ade2d47df6941892d5aa /kde-base/ark/ark-4.9.4.ebuild
parentStable for HPPA (bug #444546). (diff)
downloadgentoo-2-b9d227823671a4217d7d0f9e194c5108eacc548e.tar.gz
gentoo-2-b9d227823671a4217d7d0f9e194c5108eacc548e.tar.bz2
gentoo-2-b9d227823671a4217d7d0f9e194c5108eacc548e.zip
[kde-base] Add KDE SC 4.9.4
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key F82F92E6)
Diffstat (limited to 'kde-base/ark/ark-4.9.4.ebuild')
-rw-r--r--kde-base/ark/ark-4.9.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-base/ark/ark-4.9.4.ebuild b/kde-base/ark/ark-4.9.4.ebuild
new file mode 100644
index 000000000000..4f04e9011800
--- /dev/null
+++ b/kde-base/ark/ark-4.9.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ark-4.9.4.ebuild,v 1.1 2012/12/05 16:57:56 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE Archiving tool"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+archive +bzip2 debug lzma"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+ sys-libs/zlib
+ archive? ( >=app-arch/libarchive-2.6.1[bzip2?,lzma?,zlib] )
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+# dbus problem
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with archive LibArchive)
+ $(cmake-utils_use_with bzip2 BZip2)
+ $(cmake-utils_use_with lzma LibLZMA)
+ )
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+ elog "For creating rar archives, install app-arch/rar"
+}