summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-10-24 16:15:56 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-10-24 16:15:56 +0000
commit8c0f49260d2b50a319b2c7c12be56391bc5688ae (patch)
treeb66620c792760ddd3cd806d9235fd86297f2a6e3 /kde-base/akonadi
parentStable x86 wrt bug 341821. (diff)
downloadgentoo-2-8c0f49260d2b50a319b2c7c12be56391bc5688ae.tar.gz
gentoo-2-8c0f49260d2b50a319b2c7c12be56391bc5688ae.tar.bz2
gentoo-2-8c0f49260d2b50a319b2c7c12be56391bc5688ae.zip
Version bump KDEPIM 4.4.7
(Portage version: 2.2_rc94/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/akonadi')
-rw-r--r--kde-base/akonadi/ChangeLog8
-rw-r--r--kde-base/akonadi/akonadi-4.4.7.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/kde-base/akonadi/ChangeLog b/kde-base/akonadi/ChangeLog
index 60db1ab2f72b..6d4ad8b1bcff 100644
--- a/kde-base/akonadi/ChangeLog
+++ b/kde-base/akonadi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/akonadi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/akonadi/ChangeLog,v 1.73 2010/09/11 05:50:50 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/akonadi/ChangeLog,v 1.74 2010/10/24 16:15:56 tampakrap Exp $
+
+*akonadi-4.4.7 (24 Oct 2010)
+
+ 24 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +akonadi-4.4.7.ebuild:
+ Version bump KDEPIM 4.4.7
*akonadi-4.4.6 (11 Sep 2010)
diff --git a/kde-base/akonadi/akonadi-4.4.7.ebuild b/kde-base/akonadi/akonadi-4.4.7.ebuild
new file mode 100644
index 000000000000..0592f38ed4fa
--- /dev/null
+++ b/kde-base/akonadi/akonadi-4.4.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/akonadi/akonadi-4.4.7.ebuild,v 1.1 2010/10/24 16:15:56 tampakrap Exp $
+
+EAPI="3"
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="An extensible cross-desktop storage service for PIM data and meta data"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ >=app-office/akonadi-server-1.3.1
+ $(add_kdebase_dep kdelibs 'semantic-desktop')
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ $(add_kdebase_dep libkdepim)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-runtime)
+"
+
+KMEXTRA="
+ akonadiconsole/
+"
+
+# @since 4.3 - blocks kdemaildir - no longer provided (it's in akonadi now)
+add_blocker kdemaildir
+add_blocker kdepim-kresources '<4.2.95'
+
+src_configure() {
+ mycmakeargs=(
+ # Set the dbus dirs, otherwise it searches in KDEDIR
+ -DAKONADI_DBUS_INTERFACES_INSTALL_DIR="${EPREFIX}/usr/share/dbus-1/interfaces"
+ -DAKONADI_DBUS_SERVICES_INSTALL_DIR="${EPREFIX}/usr/share/dbus-1/services"
+ )
+
+ kde4-meta_src_configure
+}