summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-03-09 18:58:29 +0000
committerFabian Groffen <grobian@gentoo.org>2010-03-09 18:58:29 +0000
commitdc4bcbca22d3bc476c50f6a95e11b3c00307e842 (patch)
tree9e971f35fa7815ebfd14f22d72f49e1447a297f2 /gnustep-base
parentRevbump for EAPI=3, Prefix fixes, transferred Prefix keywords (diff)
downloadgentoo-2-dc4bcbca22d3bc476c50f6a95e11b3c00307e842.tar.gz
gentoo-2-dc4bcbca22d3bc476c50f6a95e11b3c00307e842.tar.bz2
gentoo-2-dc4bcbca22d3bc476c50f6a95e11b3c00307e842.zip
rewrite to be a single econf statement
(Portage version: 2.2.00.15800-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-make/gnustep-make-2.2.0-r1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnustep-base/gnustep-make/gnustep-make-2.2.0-r1.ebuild b/gnustep-base/gnustep-make/gnustep-make-2.2.0-r1.ebuild
index 61c70139068a..6dd54e2f2316 100644
--- a/gnustep-base/gnustep-make/gnustep-make-2.2.0-r1.ebuild
+++ b/gnustep-base/gnustep-make/gnustep-make-2.2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/gnustep-make-2.2.0-r1.ebuild,v 1.1 2010/03/09 18:52:57 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/gnustep-make-2.2.0-r1.ebuild,v 1.2 2010/03/09 18:58:29 grobian Exp $
EAPI="3"
@@ -27,11 +27,12 @@ src_prepare() {
}
src_configure() {
- local myconf
- myconf="--prefix=${GNUSTEP_PREFIX} --with-layout=gnustep"
- myconf="$myconf --with-config-file=${EPREFIX}/etc/GNUstep/GNUstep.conf"
- myconf="$myconf $(use_enable native-exceptions native-objc-exceptions)"
- econf $myconf || die "configure failed"
+ econf \
+ --prefix="${GNUSTEP_PREFIX}" \
+ --with-layout=gnustep \
+ --with-config-file="${EPREFIX}"/etc/GNUstep/GNUstep.conf \
+ $(use_enable native-exceptions native-objc-exceptions) \
+ || die "configure failed"
}
src_compile() {