summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2011-04-20 17:42:10 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2011-04-20 17:42:10 +0000
commit90ed058ac9909672d06f3b7ceb387126ff892af3 (patch)
tree7f11afe79f4d5862ef375b450b77a96438d42791 /gnustep-base
parentfix build with latest ffmpeg (diff)
downloadgentoo-2-90ed058ac9909672d06f3b7ceb387126ff892af3.tar.gz
gentoo-2-90ed058ac9909672d06f3b7ceb387126ff892af3.tar.bz2
gentoo-2-90ed058ac9909672d06f3b7ceb387126ff892af3.zip
Version bump, preparing for switch to fhs layout
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-make/ChangeLog10
-rw-r--r--gnustep-base/gnustep-make/files/gnustep-4.csh19
-rw-r--r--gnustep-base/gnustep-make/files/gnustep-4.sh23
-rw-r--r--gnustep-base/gnustep-make/gnustep-make-2.6.0.ebuild73
4 files changed, 123 insertions, 2 deletions
diff --git a/gnustep-base/gnustep-make/ChangeLog b/gnustep-base/gnustep-make/ChangeLog
index b97b3deecf60..0f8bc282f290 100644
--- a/gnustep-base/gnustep-make/ChangeLog
+++ b/gnustep-base/gnustep-make/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-base/gnustep-make
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/ChangeLog,v 1.95 2010/08/20 12:29:02 voyageur Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/ChangeLog,v 1.96 2011/04/20 17:42:10 voyageur Exp $
+
+*gnustep-make-2.6.0 (20 Apr 2011)
+
+ 20 Apr 2011; Bernard Cafarelli <voyageur@gentoo.org>
+ +gnustep-make-2.6.0.ebuild, +files/gnustep-4.csh, +files/gnustep-4.sh:
+ Version bump, preparing for switch to fhs layout
20 Aug 2010; Bernard Cafarelli <voyageur@gentoo.org>
-gnustep-make-2.0.4.ebuild, -gnustep-make-2.2.0.ebuild,
diff --git a/gnustep-base/gnustep-make/files/gnustep-4.csh b/gnustep-base/gnustep-make/files/gnustep-4.csh
new file mode 100644
index 000000000000..f65067da0582
--- /dev/null
+++ b/gnustep-base/gnustep-make/files/gnustep-4.csh
@@ -0,0 +1,19 @@
+#!/usr/bin/env csh
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/files/gnustep-4.csh,v 1.1 2011/04/20 17:42:09 voyageur Exp $
+
+# Test for an interactive shell
+if ( $?prompt ) then
+
+ setenv GNUSTEP_SYSTEM_TOOLS "@GENTOO_PORTAGE_EPREFIX@"/usr/bin
+
+ if ( -x $GNUSTEP_SYSTEM_TOOLS/make_services ) then
+ $GNUSTEP_SYSTEM_TOOLS/make_services
+ endif
+
+ if ( -x $GNUSTEP_SYSTEM_TOOLS/gdnc ) then
+ $GNUSTEP_SYSTEM_TOOLS/gdnc
+ endif
+
+endif
diff --git a/gnustep-base/gnustep-make/files/gnustep-4.sh b/gnustep-base/gnustep-make/files/gnustep-4.sh
new file mode 100644
index 000000000000..904fc8922751
--- /dev/null
+++ b/gnustep-base/gnustep-make/files/gnustep-4.sh
@@ -0,0 +1,23 @@
+#!/usr/bin/env sh
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/files/gnustep-4.sh,v 1.1 2011/04/20 17:42:09 voyageur Exp $
+
+# Test for an interactive shell
+case $- in
+ *i*)
+ ;;
+ *)
+ return
+ ;;
+esac
+
+GNUSTEP_SYSTEM_TOOLS="@GENTOO_PORTAGE_EPREFIX@"/usr/bin
+
+if [ -x ${GNUSTEP_SYSTEM_TOOLS}/make_services ]; then
+ ${GNUSTEP_SYSTEM_TOOLS}/make_services
+fi
+
+if [ -x ${GNUSTEP_SYSTEM_TOOLS}/gdnc ]; then
+ ${GNUSTEP_SYSTEM_TOOLS}/gdnc
+fi
diff --git a/gnustep-base/gnustep-make/gnustep-make-2.6.0.ebuild b/gnustep-base/gnustep-make/gnustep-make-2.6.0.ebuild
new file mode 100644
index 000000000000..c17bec05c31f
--- /dev/null
+++ b/gnustep-base/gnustep-make/gnustep-make-2.6.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/gnustep-make-2.6.0.ebuild,v 1.1 2011/04/20 17:42:10 voyageur Exp $
+
+EAPI="3"
+
+inherit gnustep-base eutils prefix
+
+DESCRIPTION="GNUstep Makefile Package"
+
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="native-exceptions"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ >=sys-devel/gcc-3.3[objc]
+ >=sys-devel/make-3.75"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Multilib-strict
+ sed -e "s#/lib#/$(get_libdir)#" -i FilesystemLayouts/fhs-system || die "sed failed"
+ epatch "${FILESDIR}"/${PN}-2.0.1-destdir.patch
+ cp "${FILESDIR}"/gnustep-4.{csh,sh} "${T}"/
+ eprefixify "${T}"/gnustep-4.{csh,sh}
+}
+
+src_configure() {
+ econf \
+ --with-layout=fhs-system \
+ --with-config-file="${EPREFIX}"/etc/GNUstep/GNUstep.conf \
+ $(use_enable native-exceptions native-objc-exceptions) \
+ || die "configure failed"
+}
+
+src_compile() {
+ emake || die "compilation failed"
+ # Prepare doc here (needed when no gnustep-make is already installed)
+ if use doc ; then
+ # If a gnustep-1 environment is set
+ unset GNUSTEP_MAKEFILES
+ pushd Documentation &> /dev/null
+ emake all install || die "doc make has failed"
+ popd &> /dev/null
+ fi
+}
+
+src_install() {
+ # Get GNUSTEP_* variables
+ . ./GNUstep.conf
+
+ local make_eval
+ use debug || make_eval="${make_eval} debug=no"
+ make_eval="${make_eval} verbose=yes"
+
+ emake ${make_eval} DESTDIR="${D}" install || die "install has failed"
+
+ # Copy the documentation
+ if use doc ; then
+ dodir ${GNUSTEP_SYSTEM_LIBRARY}
+ cp -r Documentation/tmp-installation/System/Library/Documentation \
+ "${ED}"${GNUSTEP_SYSTEM_LIBRARY}
+ fi
+
+ dodoc FAQ README RELEASENOTES
+
+ exeinto /etc/profile.d
+ doexe "${T}"/gnustep-4.sh
+ doexe "${T}"/gnustep-4.csh
+}