summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2014-02-07 18:24:31 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2014-02-07 18:24:31 +0000
commitcab942153a2c436c6d21ba124700fba791d77d84 (patch)
tree0437c1543ca6c22c78ade7b58250bd52a7ee4ad2 /gnustep-apps
parentVersion bump. (diff)
downloadgentoo-2-cab942153a2c436c6d21ba124700fba791d77d84.tar.gz
gentoo-2-cab942153a2c436c6d21ba124700fba791d77d84.tar.bz2
gentoo-2-cab942153a2c436c6d21ba124700fba791d77d84.zip
Version bump, new homepage, updated dependencies
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'gnustep-apps')
-rw-r--r--gnustep-apps/cdplayer/ChangeLog9
-rw-r--r--gnustep-apps/cdplayer/cdplayer-0.6.0.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/gnustep-apps/cdplayer/ChangeLog b/gnustep-apps/cdplayer/ChangeLog
index fc5406e90179..b6fbeaf1e2ab 100644
--- a/gnustep-apps/cdplayer/ChangeLog
+++ b/gnustep-apps/cdplayer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnustep-apps/cdplayer
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/cdplayer/ChangeLog,v 1.3 2011/06/28 15:40:38 voyageur Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/cdplayer/ChangeLog,v 1.4 2014/02/07 18:24:31 voyageur Exp $
+
+*cdplayer-0.6.0 (07 Feb 2014)
+
+ 07 Feb 2014; Bernard Cafarelli <voyageur@gentoo.org> +cdplayer-0.6.0.ebuild:
+ Version bump, new homepage, updated dependencies
*cdplayer-0.5.1 (28 Jun 2011)
diff --git a/gnustep-apps/cdplayer/cdplayer-0.6.0.ebuild b/gnustep-apps/cdplayer/cdplayer-0.6.0.ebuild
new file mode 100644
index 000000000000..90fd8e3b5640
--- /dev/null
+++ b/gnustep-apps/cdplayer/cdplayer-0.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/cdplayer/cdplayer-0.6.0.ebuild,v 1.1 2014/02/07 18:24:31 voyageur Exp $
+
+EAPI=5
+inherit gnustep-2
+
+DESCRIPTION="Small CD Audio Player for GNUstep"
+HOMEPAGE="https://github.com/schik/cdplayer"
+SRC_URI="https://github.com/schik/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="dbus"
+DEPEND="dev-libs/libcdio
+ dev-libs/libcdio-paranoia
+ gnustep-apps/cynthiune
+ dbus? ( gnustep-libs/dbuskit )"
+RDEPEND="${DEPEND}
+ !gnustep-libs/cddb"
+
+src_prepare() {
+ sed -e "s#cdda.h#paranoia/cdda.h#" \
+ -e "s#paranoia.h#paranoia/paranoia.h#" \
+ -i AudioCD/AudioCD.h || die "AudioCD.h sed failed"
+}
+
+src_compile() {
+ local myconf=""
+ use dbus || myconf="${myconf} notifications=no"
+
+ egnustep_env
+ egnustep_make ${myconf}
+}