summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2014-10-27 09:57:22 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2014-10-27 09:57:22 +0000
commit6d0e719d19b40b76d9268d900e5d35befa4198c3 (patch)
tree796fee1c4a9076a2b6af293d5177590ae975616c /gnustep-apps
parentQA: fix OpenRC deprecation warning by removing last --oknodo in daemons-util,... (diff)
downloadgentoo-2-6d0e719d19b40b76d9268d900e5d35befa4198c3.tar.gz
gentoo-2-6d0e719d19b40b76d9268d900e5d35befa4198c3.tar.bz2
gentoo-2-6d0e719d19b40b76d9268d900e5d35befa4198c3.zip
Version bump, clean ebuild
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'gnustep-apps')
-rw-r--r--gnustep-apps/gnumail/ChangeLog7
-rw-r--r--gnustep-apps/gnumail/gnumail-1.2.2.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/gnustep-apps/gnumail/ChangeLog b/gnustep-apps/gnumail/ChangeLog
index b4653bd807d5..e50884f17394 100644
--- a/gnustep-apps/gnumail/ChangeLog
+++ b/gnustep-apps/gnumail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnustep-apps/gnumail
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gnumail/ChangeLog,v 1.38 2014/10/20 13:33:58 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gnumail/ChangeLog,v 1.39 2014/10/27 09:57:22 voyageur Exp $
+
+*gnumail-1.2.2 (27 Oct 2014)
+
+ 27 Oct 2014; Bernard Cafarelli <voyageur@gentoo.org> +gnumail-1.2.2.ebuild:
+ Version bump, clean ebuild
20 Oct 2014; Bernard Cafarelli <voyageur@gentoo.org>
-gnumail-1.2.0_pre3-r1.ebuild, gnumail-1.2.0.ebuild,
diff --git a/gnustep-apps/gnumail/gnumail-1.2.2.ebuild b/gnustep-apps/gnumail/gnumail-1.2.2.ebuild
new file mode 100644
index 000000000000..63717b644d88
--- /dev/null
+++ b/gnustep-apps/gnumail/gnumail-1.2.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gnumail/gnumail-1.2.2.ebuild,v 1.1 2014/10/27 09:57:22 voyageur Exp $
+
+EAPI=5
+inherit gnustep-2
+
+MY_P=${P/gnum/GNUM}
+
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A fully featured mail application for GNUstep"
+HOMEPAGE="http://www.collaboration-world.com/gnumail/"
+SRC_URI="http://download.gna.org/gnustep-nonfsf/${MY_P}.tar.gz"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="crypt"
+DEPEND=">=gnustep-base/gnustep-gui-0.11.0
+ =gnustep-libs/pantomime-1.2*
+ gnustep-apps/addresses"
+RDEPEND="crypt? ( app-crypt/gnupg )"
+
+src_prepare() {
+ sed -i -e 's|GNUMail_GUI_LIBS =|LIBRARIES_DEPEND_UPON +=|' \
+ Framework/GNUMail/GNUmakefile || die "as-needed sed failed"
+ use crypt || sed -i -e 's|Bundles/PGP||' \
+ GNUmakefile || die "PGP bundle sed failed"
+}
+
+src_install() {
+ gnustep-base_src_install
+ dodoc "${S}"/Documentation/*
+}