summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2008-12-09 17:12:34 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2008-12-09 17:12:34 +0000
commit22bc552989eb3854b099664a955e978e79429e53 (patch)
treed9dff6c4545c11790250e6af8c3da20ccfd389d0 /gnustep-apps/cynthiune
parentNew feature: USE=gzip to compress .idx and .dict files. Small cleanup. (diff)
downloadgentoo-2-22bc552989eb3854b099664a955e978e79429e53.tar.gz
gentoo-2-22bc552989eb3854b099664a955e978e79429e53.tar.bz2
gentoo-2-22bc552989eb3854b099664a955e978e79429e53.zip
Fix compilation with --as-needed, bug #250170
(Portage version: 2.2_rc17/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'gnustep-apps/cynthiune')
-rw-r--r--gnustep-apps/cynthiune/ChangeLog8
-rw-r--r--gnustep-apps/cynthiune/cynthiune-0.9.5-r2.ebuild70
-rw-r--r--gnustep-apps/cynthiune/files/cynthiune-0.9.5-as-needed.patch22
3 files changed, 99 insertions, 1 deletions
diff --git a/gnustep-apps/cynthiune/ChangeLog b/gnustep-apps/cynthiune/ChangeLog
index 0c3a495e6c97..143cdea5d788 100644
--- a/gnustep-apps/cynthiune/ChangeLog
+++ b/gnustep-apps/cynthiune/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-apps/cynthiune
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/cynthiune/ChangeLog,v 1.18 2008/07/21 08:25:11 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/cynthiune/ChangeLog,v 1.19 2008/12/09 17:12:34 voyageur Exp $
+
+*cynthiune-0.9.5-r2 (09 Dec 2008)
+
+ 09 Dec 2008; Bernard Cafarelli <voyageur@gentoo.org>
+ +files/cynthiune-0.9.5-as-needed.patch, +cynthiune-0.9.5-r2.ebuild:
+ Fix compilation with --as-needed, bug #250170
21 Jul 2008; Bernard Cafarelli <voyageur@gentoo.org>
cynthiune-0.9.5-r1.ebuild:
diff --git a/gnustep-apps/cynthiune/cynthiune-0.9.5-r2.ebuild b/gnustep-apps/cynthiune/cynthiune-0.9.5-r2.ebuild
new file mode 100644
index 000000000000..c3ed0e5a9115
--- /dev/null
+++ b/gnustep-apps/cynthiune/cynthiune-0.9.5-r2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/cynthiune/cynthiune-0.9.5-r2.ebuild,v 1.1 2008/12/09 17:12:34 voyageur Exp $
+
+inherit gnustep-2
+
+S=${WORKDIR}/${P/c/C}
+
+DESCRIPTION="Free software and romantic music player for GNUstep."
+HOMEPAGE="http://organact.mine.nu/~wolfgang/cynthiune"
+SRC_URI="http://organact.mine.nu/~wolfgang/cynthiune/${P/c/C}.tar.gz"
+
+IUSE="arts esd flac mad modplug musepack timidity vorbis"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="media-libs/audiofile
+ media-libs/taglib
+ arts? ( kde-base/arts )
+ esd? ( media-sound/esound )
+ flac? ( media-libs/flac )
+ mad? ( media-libs/libid3tag
+ media-libs/libmad )
+ musepack? ( media-libs/libmpcdec )
+ modplug? ( media-libs/libmodplug )
+ timidity? ( media-sound/timidity++ )
+ vorbis? ( >=media-libs/libogg-1.1.2
+ >=media-libs/libvorbis-1.0.1-r2 )
+ =media-libs/musicbrainz-2*"
+DEPEND="${RDEPEND}
+ mad? ( dev-util/pkgconfig )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-flac-1.1.3.patch
+ epatch "${FILESDIR}"/${P}-set-macro.patch
+ epatch "${FILESDIR}"/${P}-NSCellExtensions.patch
+ epatch "${FILESDIR}"/${P}-NSMutableDictionary.patch
+ epatch "${FILESDIR}"/${P}-gnustep-make-2.patch
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+}
+
+cynthiune_get_config() {
+ # Gentoo doesn't have libavi (any more)
+ local myconf="disable-windowsmedia=yes"
+ use arts || myconf="${myconf} disable-arts=yes"
+ use esd || myconf="${myconf} disable-esound=yes"
+ use flac || myconf="${myconf} disable-flac=yes disable-flactags=yes"
+ use mad || myconf="${myconf} disable-mp3=yes disable-id3tag=yes"
+ use modplug || myconf="${myconf} disable-mod=yes"
+ use musepack || myconf="${myconf} disable-musepack=yes"
+ use timidity || myconf="${myconf} disable-timidity=yes"
+ use vorbis || myconf="${myconf} disable-ogg=yes disable-vorbistags=yes"
+
+ echo ${myconf}
+}
+
+src_compile() {
+ egnustep_env
+ egnustep_make "$(cynthiune_get_config)" || die "make failed"
+}
+
+src_install() {
+ egnustep_env
+ egnustep_install "$(cynthiune_get_config)" || die
+}
diff --git a/gnustep-apps/cynthiune/files/cynthiune-0.9.5-as-needed.patch b/gnustep-apps/cynthiune/files/cynthiune-0.9.5-as-needed.patch
new file mode 100644
index 000000000000..e707a44a2a4b
--- /dev/null
+++ b/gnustep-apps/cynthiune/files/cynthiune-0.9.5-as-needed.patch
@@ -0,0 +1,22 @@
+--- frameworks.make.orig 2008-12-09 18:05:15.000000000 +0100
++++ frameworks.make 2008-12-09 18:05:22.000000000 +0100
+@@ -2,13 +2,16 @@
+
+ ADDITIONAL_INCLUDE_DIRS += $(foreach fdir,$(foreach fdir,$(FRAMEWORKS_DIRS),$(foreach framework,$(FRAMEWORKS),$(wildcard $(fdir)/$(framework).framework))),-I$(fdir)/Headers)
+ ifeq (yes, $(local-build))
+- _ldflags = $(foreach framework,$(FRAMEWORKS),$(foreach efdir,$(foreach fdir,$(FRAMEWORKS_DIRS),$(wildcard $(fdir)/$(framework).framework)), -Wl,-rpath,$(if $(wildcard $(shell pwd)/$(efdir)),$(shell pwd)/$(efdir),$(efdir))/Versions/Current -L$(efdir)/Versions/Current) -l$(framework))
++ _ldflags = $(foreach framework,$(FRAMEWORKS),$(foreach efdir,$(foreach fdir,$(FRAMEWORKS_DIRS),$(wildcard $(fdir)/$(framework).framework)), -Wl,-rpath,$(if $(wildcard $(shell pwd)/$(efdir)),$(shell pwd)/$(efdir),$(efdir))/Versions/Current -L$(efdir)/Versions/Current))
++ _libs = $(foreach framework,$(FRAMEWORKS), -l$(framework))
+ else
+- _ldflags = $(foreach framework,$(FRAMEWORKS),$(foreach efdir,$(foreach fdir,$(FRAMEWORKS_DIRS),$(wildcard $(fdir)/$(framework).framework)), -L$(efdir)/Versions/Current) -l$(framework))
++ _ldflags = $(foreach framework,$(FRAMEWORKS),$(foreach efdir,$(foreach fdir,$(FRAMEWORKS_DIRS),$(wildcard $(fdir)/$(framework).framework)), -L$(efdir)/Versions/Current))
++ _libs = $(foreach framework,$(FRAMEWORKS), -l$(framework))
+ endif
+
+ ifeq (mingw32, $(GNUSTEP_TARGET_OS))
+-ADDITIONAL_GUI_LIBS += -L$(FRAMEWORKS_DIRS)/../../Cynthiune.app $(_ldflags)
++ADDITIONAL_GUI_LIBS += -L$(FRAMEWORKS_DIRS)/../../Cynthiune.app $(_ldflags) $(_libs)
+ else
+ ADDITIONAL_LDFLAGS += $(_ldflags)
++ADDITIONAL_GUI_LIBS += $(_libs)
+ endif