summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2003-01-27 20:49:07 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2003-01-27 20:49:07 +0000
commita9b388ccc5615c076e336226110f789a764b8194 (patch)
treeee0629b2482edb2f1505555fb7c04dda49559be8 /gnome-extra
parentadded new gcc 3.2 happy version for ppc only (diff)
downloadgentoo-2-a9b388ccc5615c076e336226110f789a764b8194.tar.gz
gentoo-2-a9b388ccc5615c076e336226110f789a764b8194.tar.bz2
gentoo-2-a9b388ccc5615c076e336226110f789a764b8194.zip
New version that might have fixed a funky sync problem I was seeing. Masked.
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-pilot/ChangeLog7
-rw-r--r--gnome-extra/gnome-pilot/files/digest-gnome-pilot-0.1.711
-rw-r--r--gnome-extra/gnome-pilot/files/gnome-pilot-0.1.70-usb.patch47
-rw-r--r--gnome-extra/gnome-pilot/gnome-pilot-0.1.71.ebuild63
4 files changed, 117 insertions, 1 deletions
diff --git a/gnome-extra/gnome-pilot/ChangeLog b/gnome-extra/gnome-pilot/ChangeLog
index 5c3da7e38007..7f02e17a88b4 100644
--- a/gnome-extra/gnome-pilot/ChangeLog
+++ b/gnome-extra/gnome-pilot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/gnome-pilot
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-pilot/ChangeLog,v 1.13 2002/12/13 10:56:56 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-pilot/ChangeLog,v 1.14 2003/01/27 20:49:00 g2boojum Exp $
+
+*gnome-pilot-0.1.71 (27 Jan 2003)
+
+ 27 Jan 2003; g2boojum <g2boojum@gentoo.org> gnome-pilot-0.1.71.ebuild :
+ New version
10 Dec 2002; foser <foser@gentoo.org> gnome-pilot-0.1.65-r3.ebuild gnome-pilot-0.1.65-r5.ebuild :
Fixed gob deps (bug #11633)
diff --git a/gnome-extra/gnome-pilot/files/digest-gnome-pilot-0.1.71 b/gnome-extra/gnome-pilot/files/digest-gnome-pilot-0.1.71
new file mode 100644
index 000000000000..106d20434144
--- /dev/null
+++ b/gnome-extra/gnome-pilot/files/digest-gnome-pilot-0.1.71
@@ -0,0 +1 @@
+MD5 9d0018831605418aa6f74f129b5a506f gnome-pilot-0.1.71.tar.bz2 679057
diff --git a/gnome-extra/gnome-pilot/files/gnome-pilot-0.1.70-usb.patch b/gnome-extra/gnome-pilot/files/gnome-pilot-0.1.70-usb.patch
new file mode 100644
index 000000000000..e306fa9df09b
--- /dev/null
+++ b/gnome-extra/gnome-pilot/files/gnome-pilot-0.1.70-usb.patch
@@ -0,0 +1,47 @@
+--- gnome-pilot-0.1.70/capplet/util.c.usb 2002-09-16 19:08:08.000000000 +0200
++++ gnome-pilot-0.1.70/capplet/util.c 2002-12-03 17:14:38.000000000 +0100
+@@ -642,6 +642,7 @@
+ return ;
+ }
+ } else if (device->type == PILOT_DEVICE_USB_VISOR) {
++/* don't check anything, it could be no device if we are using devfs
+ struct stat sb;
+
+ if (stat (device->port, &sb) != 0) {
+@@ -660,7 +661,7 @@
+ error_dialog (str);
+ g_free (str);
+ return ;
+- }
++ }*/
+ }
+
+ }
+--- gnome-pilot-0.1.70/gpilotd/gpilotd.c.usb 2002-12-03 16:08:24.000000000 +0100
++++ gnome-pilot-0.1.70/gpilotd/gpilotd.c 2002-12-03 17:29:24.000000000 +0100
+@@ -851,6 +851,7 @@
+ visor_devices_in (GIOChannel *io_channel,
+ GIOCondition condition,
+ GPilotContext *context) {
++ static firstime = TRUE;
+ GPilotDevice *device;
+ GList *l;
+ int i;
+@@ -862,11 +863,16 @@
+
+ g_assert (context != NULL);
+
+- sleep (2);
++ sleep (10);
+
+ if (context->paused)
+ return FALSE;
+
++ if (!firstime )
++ sleep (10);
++ else
++ firstime = FALSE;
++
+ /* Check /proc/bus/usb/devices for a usb device */
+ f = fopen ("/proc/bus/usb/devices", "r");
+
diff --git a/gnome-extra/gnome-pilot/gnome-pilot-0.1.71.ebuild b/gnome-extra/gnome-pilot/gnome-pilot-0.1.71.ebuild
new file mode 100644
index 000000000000..b4912c31fd9d
--- /dev/null
+++ b/gnome-extra/gnome-pilot/gnome-pilot-0.1.71.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-pilot/gnome-pilot-0.1.71.ebuild,v 1.1 2003/01/27 20:49:01 g2boojum Exp $
+
+IUSE="nls"
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnome Pilot apps"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/sources/gnome-pilot/0.1/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/gnome-pilot/"
+
+DEPEND="sys-devel/perl
+ >=gnome-base/control-center-1.4.0.1-r1
+ >=gnome-base/gnome-libs-1.4.1.7
+ =gnome-base/gnome-panel-1.4*
+ >=dev-libs/pilot-link-0.11.0
+ =dev-util/gob-1*
+ >=gnome-base/libglade-0.17"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc "
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ # USB patch from Mandrake. Allows gnome-pilot to watch /dev/pilot even
+ # when it does not yet exist (because of using devfs).
+ patch -p1 < ${FILESDIR}/gnome-pilot-0.1.70-usb.patch
+}
+
+src_compile() {
+
+ local myconf
+
+# use gtk2 \
+# && CFLAGS="${CFLAGS} `pkg-config --cflags libglade vfs`" \
+# || CFLAGS="${CFLAGS} `gtk-config --prefix`"
+
+ use nls \
+ && myconf="--enable-nls" \
+ || myconf="--disable-nls"
+
+ myconf="${myconf} --enable-usb --with-gnome-libs=/usr/lib"
+
+
+ mkdir intl && touch intl/libgettext.h
+
+ econf ${myconf} || die
+
+
+ emake || die
+}
+
+src_install () {
+ einstall || die
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS
+}