summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-28 17:01:15 +0000
committerJustin Lecher <jlec@gentoo.org>2015-06-28 17:01:15 +0000
commita771ff6fd85da0ff489b1a153fcbdd09e8cc8c8a (patch)
tree99c902cc4cfde98036cd702dafacb6bfc496570a /gnome-extra
parentalpha stable wrt bug #551728 (diff)
downloadgentoo-2-a771ff6fd85da0ff489b1a153fcbdd09e8cc8c8a.tar.gz
gentoo-2-a771ff6fd85da0ff489b1a153fcbdd09e8cc8c8a.tar.bz2
gentoo-2-a771ff6fd85da0ff489b1a153fcbdd09e8cc8c8a.zip
Add fixes for latest glib, Gtk and vala changes, bug #553348
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/activity-log-manager/ChangeLog9
-rw-r--r--gnome-extra/activity-log-manager/activity-log-manager-0.9.7-r1.ebuild52
-rw-r--r--gnome-extra/activity-log-manager/files/activity-log-manager-0.9.7-ambiguous.patch139
3 files changed, 199 insertions, 1 deletions
diff --git a/gnome-extra/activity-log-manager/ChangeLog b/gnome-extra/activity-log-manager/ChangeLog
index 678023e9694f..ab4fbf60321a 100644
--- a/gnome-extra/activity-log-manager/ChangeLog
+++ b/gnome-extra/activity-log-manager/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/activity-log-manager
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/activity-log-manager/ChangeLog,v 1.22 2015/06/27 11:31:33 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/activity-log-manager/ChangeLog,v 1.23 2015/06/28 17:01:15 jlec Exp $
+
+*activity-log-manager-0.9.7-r1 (28 Jun 2015)
+
+ 28 Jun 2015; Justin Lecher <jlec@gentoo.org>
+ +activity-log-manager-0.9.7-r1.ebuild,
+ +files/activity-log-manager-0.9.7-ambiguous.patch:
+ Add fixes for latest glib, Gtk and vala changes, bug #553348
27 Jun 2015; Pacho Ramos <pacho@gentoo.org> activity-log-manager-0.9.7.ebuild:
Fix typo in VALA_MAX_API_VERSION variable, it also builds with 0.26 (even if
diff --git a/gnome-extra/activity-log-manager/activity-log-manager-0.9.7-r1.ebuild b/gnome-extra/activity-log-manager/activity-log-manager-0.9.7-r1.ebuild
new file mode 100644
index 000000000000..2146f8757f56
--- /dev/null
+++ b/gnome-extra/activity-log-manager/activity-log-manager-0.9.7-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/activity-log-manager/activity-log-manager-0.9.7-r1.ebuild,v 1.1 2015/06/28 17:01:15 jlec Exp $
+
+EAPI=5
+
+GNOME2_LA_PUNT="yes"
+VALA_MIN_API_VERSION="0.26" # Fails with 0.24, but works with 0.26 and older versions
+#VALA_MAX_API_VERSION="0.26" # build fails with vala-0.28
+WANT_AUTOMAKE=1.13
+
+inherit autotools eutils gnome2 vala versionator
+
+DESCRIPTION="GUI which lets you easily control what gets logged by Zeitgeist"
+HOMEPAGE="https://launchpad.net/activity-log-manager/"
+SRC_URI="http://launchpad.net/history-manager/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libgee:0
+ dev-libs/glib:2
+ gnome-extra/zeitgeist
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/pango"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ virtual/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+src_prepare() {
+ DOCS="README NEWS INSTALL ChangeLog AUTHORS"
+
+ rm src/${PN}.c || die
+
+ epatch \
+ "${FILESDIR}"/${PN}-0.9.0.1-gold.patch \
+ "${FILESDIR}"/${P}-gtk-icon_size.patch \
+ "${FILESDIR}"/${P}-ambiguous.patch
+ sed \
+ -e "/^almdocdir/s:=.*$:= \${prefix}/share/doc/${PF}:g" \
+ -i Makefile.am || die
+ vala_src_prepare
+ eautoreconf
+ gnome2_src_prepare
+}
diff --git a/gnome-extra/activity-log-manager/files/activity-log-manager-0.9.7-ambiguous.patch b/gnome-extra/activity-log-manager/files/activity-log-manager-0.9.7-ambiguous.patch
new file mode 100644
index 000000000000..ba582aef8978
--- /dev/null
+++ b/gnome-extra/activity-log-manager/files/activity-log-manager-0.9.7-ambiguous.patch
@@ -0,0 +1,139 @@
+ src/blacklist-dbus.vala | 4 ++--
+ src/security-widget.vala | 2 +-
+ src/unified-privacy-applications.vala | 16 ++++++++--------
+ src/unified-privacy.vala | 4 ++--
+ 4 files changed, 13 insertions(+), 13 deletions(-)
+
+diff --git a/src/blacklist-dbus.vala b/src/blacklist-dbus.vala
+index 355a684..fd165e3 100644
+--- a/src/blacklist-dbus.vala
++++ b/src/blacklist-dbus.vala
+@@ -137,7 +137,7 @@ namespace Alm {
+ return false;
+ }
+
+- public async void find_events (string id, TreeIter iter, ListStore store)
++ public async void find_events (string id, TreeIter iter, Gtk.ListStore store)
+ {
+ Event event = new Event();
+ event.manifestation = Zeitgeist.ZG.USER_ACTIVITY;
+@@ -165,7 +165,7 @@ namespace Alm {
+ store.set_value(iter, 5, counter);
+ }
+
+- public void get_count_for_app (string app_id, TreeIter iter, ListStore store) {
++ public void get_count_for_app (string app_id, TreeIter iter, Gtk.ListStore store) {
+ find_events(app_id, iter, store);
+ }
+
+diff --git a/src/security-widget.vala b/src/security-widget.vala
+index 4394924..e983c15 100644
+--- a/src/security-widget.vala
++++ b/src/security-widget.vala
+@@ -39,7 +39,7 @@ namespace Alm {
+
+ private void set_up_ui () {
+
+- var liststore_delay = new ListStore (2, typeof (string), typeof (int));
++ var liststore_delay = new Gtk.ListStore (2, typeof (string), typeof (int));
+ TreeIter iter;
+ liststore_delay.append (out iter);
+ liststore_delay.set (iter, 0, "1 second", 1, 0);
+diff --git a/src/unified-privacy-applications.vala b/src/unified-privacy-applications.vala
+index 9b06f44..a4966d3 100644
+--- a/src/unified-privacy-applications.vala
++++ b/src/unified-privacy-applications.vala
+@@ -60,7 +60,7 @@ namespace Alm {
+ }
+ }
+
+- public void get_count_for_app(string id, TreeIter iter, ListStore store) {
++ public void get_count_for_app(string id, TreeIter iter, Gtk.ListStore store) {
+ this.blacklist_interface.get_count_for_app(id, iter, store);
+ }
+
+@@ -131,7 +131,7 @@ namespace Alm {
+ private class ApplicationsTreeView : Gtk.Box {
+
+ private ApplicationBlacklist app_blacklist;
+- private ListStore store;
++ private Gtk.ListStore store;
+ private TreeView treeview;
+
+ HashTable<string, AppChooseInfo> blocked_apps;
+@@ -145,7 +145,7 @@ namespace Alm {
+ N_COLS
+ }
+
+- public ListStore liststore {
++ public Gtk.ListStore liststore {
+ get {
+ return this.store;
+ }
+@@ -160,7 +160,7 @@ namespace Alm {
+ this.blocked_apps = blocked;
+ this.unblocked_apps = unblocked;
+
+- this.store = new ListStore (TreeViewCols.N_COLS,
++ this.store = new Gtk.ListStore (TreeViewCols.N_COLS,
+ typeof (string),
+ typeof (Gdk.Pixbuf),
+ typeof (string));
+@@ -292,7 +292,7 @@ namespace Alm {
+ private class AppSelectionTreeView : Gtk.Box {
+
+ private ApplicationBlacklist app_blacklist;
+- private ListStore store;
++ private Gtk.ListStore store;
+ private TreeView treeview;
+
+ enum TreeViewCols
+@@ -312,7 +312,7 @@ namespace Alm {
+ }
+ }
+
+- public ListStore liststore {
++ public Gtk.ListStore liststore {
+ get {
+ return store;
+ }
+@@ -323,7 +323,7 @@ namespace Alm {
+
+ this.app_blacklist = app_blacklist;
+
+- this.store = new ListStore (TreeViewCols.N_COLS,
++ this.store = new Gtk.ListStore (TreeViewCols.N_COLS,
+ typeof (string),
+ typeof (Gdk.Pixbuf),
+ typeof (string),
+@@ -426,7 +426,7 @@ namespace Alm {
+ }
+ }
+
+- public ListStore liststore {
++ public Gtk.ListStore liststore {
+ get {
+ return treeview.liststore;
+ }
+diff --git a/src/unified-privacy.vala b/src/unified-privacy.vala
+index 0d46370..c64f78d 100644
+--- a/src/unified-privacy.vala
++++ b/src/unified-privacy.vala
+@@ -55,7 +55,7 @@ namespace Alm {
+
+ //General stuffs
+ private TreeView exception_list;
+- private ListStore exception_list_store;
++ private Gtk.ListStore exception_list_store;
+
+ private Switch record_button;
+
+@@ -262,7 +262,7 @@ namespace Alm {
+ exception_vbox.pack_start (al2, false, false, 5);
+
+ // Exception TreeView
+- this.exception_list_store = new ListStore (4,
++ this.exception_list_store = new Gtk.ListStore (4,
+ typeof(string), // Full file path of application desktop file.
+ typeof(Gdk.Pixbuf?), // Pixbuf
+ typeof(string), // File basename or ApplicationName