summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-07-17 20:15:40 +0000
committerPacho Ramos <pacho@gentoo.org>2013-07-17 20:15:40 +0000
commit50bfb7aca836d00cee409a49bdc41fe7b36e1c33 (patch)
tree8fa7e2c6c3946606e4bf6f065817005e9f739afa /gnome-extra
parentVersion bump (diff)
downloadgentoo-2-50bfb7aca836d00cee409a49bdc41fe7b36e1c33.tar.gz
gentoo-2-50bfb7aca836d00cee409a49bdc41fe7b36e1c33.tar.bz2
gentoo-2-50bfb7aca836d00cee409a49bdc41fe7b36e1c33.zip
Version bump
(Portage version: 2.1.12.13/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-contacts/ChangeLog7
-rw-r--r--gnome-extra/gnome-contacts/gnome-contacts-3.8.3.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/gnome-extra/gnome-contacts/ChangeLog b/gnome-extra/gnome-contacts/ChangeLog
index da77ee35f737..dc1b90f68eb3 100644
--- a/gnome-extra/gnome-contacts/ChangeLog
+++ b/gnome-extra/gnome-contacts/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/gnome-contacts
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-contacts/ChangeLog,v 1.19 2013/06/30 21:30:09 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-contacts/ChangeLog,v 1.20 2013/07/17 20:15:40 pacho Exp $
+
+*gnome-contacts-3.8.3 (17 Jul 2013)
+
+ 17 Jul 2013; Pacho Ramos <pacho@gentoo.org> +gnome-contacts-3.8.3.ebuild:
+ Version bump
30 Jun 2013; Gilles Dartiguelongue <eva@gentoo.org>
gnome-contacts-3.8.2.ebuild:
diff --git a/gnome-extra/gnome-contacts/gnome-contacts-3.8.3.ebuild b/gnome-extra/gnome-contacts/gnome-contacts-3.8.3.ebuild
new file mode 100644
index 000000000000..89956a541515
--- /dev/null
+++ b/gnome-extra/gnome-contacts/gnome-contacts-3.8.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-contacts/gnome-contacts-3.8.3.ebuild,v 1.1 2013/07/17 20:15:40 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.18"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="GNOME contact management application"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Contacts"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="v4l"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+VALA_DEPEND="
+ $(vala_depend)
+ >=dev-libs/gobject-introspection-0.9.6
+ dev-libs/folks[vala]
+ gnome-base/gnome-desktop[introspection]
+ gnome-extra/evolution-data-server[vala]
+ net-libs/telepathy-glib[vala]
+ x11-libs/libnotify[introspection]
+"
+# Configure is wrong; it needs cheese-3.5.91, not 3.3.91
+RDEPEND="
+ >=dev-libs/folks-0.7.3:=[eds,telepathy]
+ >=dev-libs/glib-2.31.10:2
+ >=dev-libs/libgee-0.10:0.8
+ >=gnome-extra/evolution-data-server-3.5.3:=[gnome-online-accounts]
+ >=gnome-base/gnome-desktop-3.0:3=
+ net-libs/gnome-online-accounts
+ >=net-libs/telepathy-glib-0.17.5
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libnotify:=
+ >=x11-libs/gtk+-3.7.10:3
+ x11-libs/pango
+ v4l? ( >=media-video/cheese-3.5.91:= )
+"
+DEPEND="${RDEPEND}
+ ${VALA_DEPEND}
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Regenerate the pre-generated C sources, bug #471628
+ if ! use v4l; then
+ touch src/*.vala
+ fi
+
+ gnome2_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure $(use_with v4l cheese)
+}