summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-09-13 21:10:53 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-09-13 21:10:53 +0000
commit3742043df09d80f799b8c42ebbc0416ced233417 (patch)
treea8ed5aa80aa6f37cfeeb2461ac98df8f6831338d /gnome-extra
parentVersion bump. Fix parsing of m3u and mp4. (diff)
downloadgentoo-2-3742043df09d80f799b8c42ebbc0416ced233417.tar.gz
gentoo-2-3742043df09d80f799b8c42ebbc0416ced233417.tar.bz2
gentoo-2-3742043df09d80f799b8c42ebbc0416ced233417.zip
Version bump. Translation updates.
(Portage version: 2.2_rc78/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/contacts/ChangeLog7
-rw-r--r--gnome-extra/contacts/contacts-0.12.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/gnome-extra/contacts/ChangeLog b/gnome-extra/contacts/ChangeLog
index bb7d4c6a2e69..7759e30ebb2f 100644
--- a/gnome-extra/contacts/ChangeLog
+++ b/gnome-extra/contacts/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/contacts
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/contacts/ChangeLog,v 1.9 2010/09/02 13:13:46 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/contacts/ChangeLog,v 1.10 2010/09/13 21:10:53 eva Exp $
+
+*contacts-0.12 (13 Sep 2010)
+
+ 13 Sep 2010; Gilles Dartiguelongue <eva@gentoo.org> +contacts-0.12.ebuild:
+ Version bump. Translation updates.
02 Sep 2010; Pacho Ramos <pacho@gentoo.org> -contacts-0.10.ebuild,
contacts-0.11.ebuild, +files/contacts-0.11-fix-make-3.82.patch:
diff --git a/gnome-extra/contacts/contacts-0.12.ebuild b/gnome-extra/contacts/contacts-0.12.ebuild
new file mode 100644
index 000000000000..0378599ff5c8
--- /dev/null
+++ b/gnome-extra/contacts/contacts-0.12.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/contacts/contacts-0.12.ebuild,v 1.1 2010/09/13 21:10:53 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="A small, lightweight addressbook for GNOME"
+HOMEPAGE="http://pimlico-project.org/contacts.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dbus"
+
+RDEPEND=">=gnome-extra/evolution-data-server-1.8
+ >=x11-libs/gtk+-2.6"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35.0
+ >=dev-util/pkgconfig-0.9"
+
+# README is empty
+DOCS="AUTHORS ChangeLog NEWS"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable dbus)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix compilation with USE="-dbus", bug #247519, upstream bug #628614
+ epatch "${FILESDIR}/${PN}-0.9-dbus.patch"
+
+ # Fix compilation with gmake-3.82, bug #333647, upstream bug #628615
+ epatch "${FILESDIR}/${PN}-0.11-fix-make-3.82.patch"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}